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1 Signal Generator Overview

CAUTION To avoid damaging or degrading the performance of the instrument, do not exceed
33 dBm (2W) maximum of reverse power levels at the RF input. See also Tips for
Preventing Signal Generator Damage on www.agilent.com.

* Signal Generator Features on page 2
e Modes of Operation on page 4

* Front Panel Overview on page 5

* Front Panel Display on page 9

* Rear Panel Overview on page 12
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Signal Generator Overview
Signal Generator Features

Signal Generator Features

N5171B/N5181B, RF analog models: 9 kHz to 1 (N5171B only), 3, or 6 GHz (Options 501, 503, and
506 respectively)

N5172B/N5182B, RF vector models: 9 kHz to 3 or 6 GHz (Options 503, and 506 respectively)
step & list sweep of frequency, power, or frequency and power
vector models can include waveforms in list sweep

automatic leveling control (ALC)

real-time modulation filtering

8648/ESG code compatible

10 MHz reference oscillator with external output

two channel power meter display

user settable maximum power limit

user flatness correction

external analog I/Q inputs (vector models)

enhanced assembly replacement

GPIB, USB 2.0, and 100Base-T LAN interfaces

deep amplitude modulation providing greater dynamic range
manual power search (ALC off)

SCPI and IVI-COM driver

multiple baseband generator synchronization when using multiple signal generators (master/slave
setup)

with Signal Studio Software, vector models can generate 802.11 WLAN, W-CDMA, cdma2000,
1xEV-DO, GSM, EDGE, and more

real-time baseband generator (Option 660)

pulse train generator (Option 320)

LF multifunction generator (Option 303)

narrow pulse modulation, including internal pulse generator (Option UNW)
analog differential I/Q outputs (vector models, Option 1EL)

analog modulation: AM, FM, and ®M (Option UNT)

arbitrary 1I/Q waveform playback up to 200 MSa/s (vector models, Option 656/657)
external AM, FM, and ®M inputs (Option UNT)

Wideband AM (vector models, Option UNT)

flexible reference input, 1 - 50 MHz (Option 1ER)

LO In/Out for phase coherency (Option 012)

phase noise interference (vector models, Option 432)
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* expanded license key upgradability (Option 099)

For more details on hardware, firmware, software, and documentation features and options, refer to
the data sheet shipped with the signal generator and available from the Agilent Technologies website

at hitp://www.agilent.com/find/X- Series_SG.
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Modes of Operation

Depending on the model and installed options, the Agilent X-Series signal generator provides up to
four basic modes of operation: continuous wave (CW), swept signal, analog modulation, and digital
modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to
a single frequency and power level. Both the analog and vector models can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the
analog and vector models provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog
modulation types available depend on the installed options.

Option UNT provides AM, FM, and ®M modulations. Some of these modulations can be used together.

NOTE The Mod On/Off hardkey and LED functionality are only valid for instruments with Option
UNT installed.

Refer to 14. Mod On/Off and LED.

Option 303 provides a multifunction generator that consists of seven waveform generators.

Option UNW provides standard and narrow pulse modulation capability.

Digital Modulation (Vector Models with Option 65x Only)

In this mode, the signal generator modulates a CW signal with a arbitrary I/Q waveform. 1/Q
modulation is only available on vector models. An internal baseband generator (Option 65x) adds the
following digital modulation formats:

*  Custom Arb Waveform Generator mode can produce a single-modulated carrier or
multiple-modulated carriers. Each modulated carrier waveform must be calculated and generated
before it can be output; this signal generation occurs on the internal baseband generator. Once a
waveform has been created, it can be stored and recalled, which enables repeatable playback of
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 265.

e Custom Real-Time Waveform Generator mode can produce a single-modulated carrier or
multiple-modulated carriers. Each modulated carrier waveform must be calculated and generated
before it can be output; this signal generation occurs on the internal baseband generator. Once a
waveform has been created, it can be stored and recalled, which enables repeatable playback of
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 265.

*  Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode,
the frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer
to “Creating a Custom Multitone Waveform” on page 297.
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e  Two-tone mode produces two separate continuous wave signals (or tones). The frequency spacing
between the signals and the amplitudes are adjustable. To learn more, refer to Chapter 12,
"Multitone and Two-Tone Waveforms (Option 430)".

e Dual ARB mode is used to control the playback sequence of waveform segments that have been
written into the ARB memory located on the internal baseband generator. These waveforms can
be generated by the internal baseband generator using the Custom Arb Waveform Generator
mode, or downloaded through a remote interface into the ARB memory. To learn more, refer to
“Dual ARB Player” on page 130.

Front Panel Overview

5. Arrows and Select 8.Trigger
7.MENUS 11. Preset
4.Numeric 9. Local and User
1.Host USB 2.Display 3. Softkeys Keypad Cancel/(Esc) 10. Help | Preset

6. Page Up

it Agitent  MXG Vector Signal Generator

S
c>

o mill
{Reerrai

®0 @
] e

[Mod A
on/ot

BEEE
EO0000

'@@GGH

1/0 Routing & Optimization 1/0 Adjustments: OFf O
S EEs &
1/ Aajustints, Qinput RF Oulrmt 500
e 1/0Q Calibrations| D
(O} 03:24  Tore1of3 D
Y __d 5 A! AP .
12.RF
Output
21. More and LED 18.Knob 16. 1 Input P
20.Ret 19. Incr Set
22. Power Switch and LEDs 0-Return 15. Page Down
17. Q Input
14. Mod On/Off and LED
13. RF On/Offand LED
1. Host USB
Connector Type A

USB Protocol 2.0

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can
connect or disconnect a USB device without shutting down or restarting the signal generator. The
instrument also has a rear panel device USB connector (see page 14) used to remotely control the
instrument.

2. Display

The LCD screen provides information on the current function. Information can include status
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indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are located
on the right hand side of the display. See also, “Front Panel Display” on page 9.

3. Softkeys
A softkey activates the function indicated by the displayed label to the left of the key.

4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 35.

5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for editing.
See “Entering and Editing Numbers and Text” on page 35.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” on
page 36. When text does not fit on one page in the display area, use this key in conjunction with the
Page Down key (page 7) to scroll text.

1. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access
information.
See page 129 See page 63

See page 74 See page 50

L

FREQ

AMPTD

See page 40

Active onlyon  See page 113 See page 57
vector models.
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8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control,
cancels an active function entry, and cancels long operations (such an IQ calibration).

10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on
page 34.

11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user-defined). See “Presetting
the Signal Generator” on page 34.

12. RF Output

Connector Standard: female Type-N
Option 1EM: Rear panel female Type-N
Impedance: 50 Q

Damage Levels 50 Vdc, 2 W maximum RF power

13. RF On/0ff and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The
RF On/0ff LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active modulation
format. This hardkey does not set up or activate a format (see “Modulating the Carrier Signal” on
page 48).

The MOD ON/OFF LED lights when modulation of the output is enabled.

NOTE The Mod On/Off hardkey and LED functionality are only valid for instruments with Option
UNT installed.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on
page 36. When text does not fit on one page in the display area, use this key in conjunction with the
Page Up key (page 6) to scroll text.
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16. I Input (vector models only)

Connector Type: female BNC Impedance: 50 Q
Signal An externally supplied analog, in-phase component of I/Q modulation.

The signal level is /2 +Q2 = 0.5 Vs for a calibrated output level.

Damage Levels 1 V

See also, “I/Q Modulation” on page 188.

17. Q Input (vector models only)

Connector Type: female BNC Impedance: 50 Q
Signal An externally supplied analog, quadrature-phase component of I/Q modulation.

The signal level is /2 +Q2 = 0.6 Vs for a calibrated output level.

Damage Levels 1 Vins

See also, “I/Q Modulation” on page 188.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit,
character, or item in a list. See also, “Front Panel Knob Resolution” on page 22.

19. Incr Set

This hardkey enables you to set the increment value of the currently active function. The increment
value also affects how much each turn of the knob changes an active function’s value, according to
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 22).

20. Return

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED
lights and all signal generator functions deactivate. The signal generator remains connected to the
line power, and some power is consumed by some internal circuits. In the on position, the green LED
lights and the signal generator functions activate.
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Front Panel Display

1. Active Function Area 2. Frequency Area 3. Annunciators 4. Amplitude Area

FREQUERCY 6.000 000 000 00 &x= ““P_Liwa']z.oo dbn

Scroll Bar

If there is more
text than can be
displayed on one
screen, a scroll
bar appears here.
Use the Page Up
and Page Down
keys to scroll
through the text.

5. Error Message Area 6. Text Area 7. Softkey Label Area

1. Active Function Area
This area displays the currently active function. For example, if frequency is the active function, the

current frequency setting appears. If the currently active function has an increment value associated
with it, that value also appears.

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error
conditions. An annunciator position may be used by more than one annunciator; in this case, only
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

OM Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ®M.

ARB The ARB generator is on. ARB is running and not waiting on a trigger.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.
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This annunciator appears when...

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off.
Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator
(see UNLOCK, below).

CHANCORR The internal channel correction is enabled.

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at
temperature.

DIGBUS The digital bus is in use.

DIGMOD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of
the error messages or clear the error queue (see “Reading Error Messages” on page 62).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ®M annunciator replaces FM.

I/Q 1/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or
VXI-11/Sockets (LAN) interface.

M-TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 106).

OFFS An output offset is set (see “Setting an Output Offset” on page 104).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI-11/Sockets (LAN) interface. When the
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.

REF An output reference is set (see “Setting an Output Reference” on page 105).

RF OFF The signal generator’s RF Output is not enabled.

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI-11/Sockets (LAN)
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI-11/Sockets
(LAN) interface.

T-TONE Two-Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of

instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF,
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the
error messages (see “Reading Error Messages” on page 62).

WATRG The current modulation mode is waiting on the Arb trigger.

WINIT The signal generator is waiting for you to initiate a single sweep.

4. Amplitude Area

This area displays the current output power level setting (If the RF Output is off, this area is greyed
out).
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b. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent
message remains displayed. See “Reading Error Messages” on page 62.

6. Text Area

This area displays signal generator status information, such as the modulation status, and other
information such as sweep lists and file catalogs. This area also enables you to perform functions
such as managing information (entering information, and displaying or deleting files).

1. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of
the display. Softkey labels change, depending on the function selected.
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Rear Panel Overview

Digital Modulation Connectors (Vector Models Only) on page 15 1. AC Power Receptacle

V—'.-;----L o ..A’ D ODOOOO®oe

— CGLE—
: o.’..o."h
A

ITAL BUS 1/0 P Aux 1] 300W MAX
___________ e Ba— '— by sorsaoti | SERIAL NO.
101 Mﬂx BUY 2201240V 50/60Hz
---- 4
@
. . 10. LAN
Option 1EM 9. GPIB 13.'SD Card
only 6.TRIG1&2 8. 10MHz OUT ar
Seepage7 2. EXT1& 7.REFIN 12. Host USB
EXT 2 5-PULSE 11. Device USB

4. SWEEP OUT

1. AC Power Receptacle

The AC power cord receptacle accepts a three-pronged AC power cord that is supplied with the
signal generator. For details on line setting requirements and the power cord, see the
Installation Guide.

CAUTION To avoid the loss of data, GPIB settings, or current user instrument states that have not
been permanently saved to non-volatile memory, the signal generator should always be
powered down either via the instrument’s front panel power button or the appropriate
SCPI command. Signal generators installed in rack systems and powered down with the
system rack power switch rather than the instrument’s front panel switch display a
Error -310 due to the instrument not being powered down correctly.
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2. EXT 1 & EXT 2

Connector female BNC Impedance nominally 50 Q
Signal An externally supplied £1 V,, signal that produces the indicated depth.
Damage Levels 5 V., and 10 V,

3.LF OUT
Connector female BNC Impedance 50 Q
Signal Voltage range: 0 to +5 V,,
Offset: -5 V to +5 V, nominal
For more information, see page 69.
4. SWEEP OUT
Connector female BNC Impedance <1 Q
Can drive 2 kQ.
Signal Voltage range: 0 to +10 V, regardless of sweep width
In swept mode: beginning of sweep = 0 V; end of sweep = +10 V
In CW mode: no output
This is a multiple use connector. For signal routing selections, see pages 42 and 113.
b. PULSE
Connector female BNC Impedance nominally 50 Q
Signal Externally supplied: +1 V = on; 0 V = off

Damage Levels <-0.3 and >+5.3 V

6.TRIG1&2
Connector female BNC Impedance high Z
Signal An externally supplied TTL or CMOS signal for triggering operations, such as point to point

in manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

Damage Levels <-0.5 and >+5.5 V

7. REFIN
Connector female BNC Impedance nominally 50 Q
Signal An externally supplied —3.5 to +20 dBm signal from a timebase reference that is within 1 ppm.

In its factory default mode, the signal generator can detect a valid reference signal at this connector
and automatically switch from internal to external reference operation. See “Presetting the Signal

Generator” on page 34. With Option 1ER (flexible reference input), you must explicitly tell the signal
generator the external reference frequency you wish to use; enter the information through the front
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panel or over the remote interface.

8. 10 MHz OUT

Connector female BNC Impedance nominally 50 Q
Signal A nominal signal level greater than 4 dBm.
9. GPIB

This connector enables communication with compatible devices such as external controllers, and is
one of three connectors available to remotely control the signal generator (see also 10. LAN and
11. Device USB).

10. LAN

The signal generator supports local area network (LAN) based communication through this connector,
which enables a LAN-connected computer to remotely program the signal generator. The LAN
interface supports auto—-MDIX. The signal generator is limited to 100 meters on a single cable
(100Base-T). For more information on the LAN, refer to the Programming Guide.

11. Device USB

Connector Type B
USB Protocol Version 2.0

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal
generator.

12. Host USB

Connector Type A
USB Protocol 2.0

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can
connect or disconnect a USB device without shutting down or restarting the signal generator. The
instrument also has a rear panel device USB connector (see page 14) used to remotely control the
instrument.

13. SD Card

Holds the Secure Digital (SD) non-volatile memory card.
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Digital Modulation Connectors (Vector Models Only)

1 0UT, Q OUT, | OUT, Q OUT

NOTE | OUT and Q OUT, require Option 1EL.

Connector Type: female BNC Impedance: 50 Q
DC-coupled
Signal
I ouT The analog, in-phase component of I/Q modulation from the internal baseband generator.
Q OoUuT The analog, quadrature-phase component of I/Q modulation from the internal baseband
generator.
| OUT Used in conjunction with the I OUT connector to provide a balanced?® baseband stimulus.
Q ouT Used in conjunction with the @ OUT connector to provide a balanced® baseband stimulus.
Damage Levels > 1 Vrms DC Origin Offset typically <10 mV

Output Signal Levels into a 50 Q Load

* 05 Vp, typical, corresponds to one unit length of the I/Q vector

* 0.69 V. (2.84 dB), typical, maximum crest factor for peaks for m/4 DQPSK, alpha = 0.5
* 0.71 Vp (3.08 dB), typical, maximum crest factor for peaks for n/4 DQPSK, alpha = 0.35
* Typically 1 V,_, maximum

3Balanced signals are signals present in two separate conductors that are symmetrical relative to ground, and are opposite in polarity
(180 degrees out of phase).
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BB TRIG 1 & BB TRIG 2

Connector

Signal

EVENT 1

Connector

Signal

Damage Levels

PAT TRIG

Connector

Signal

Damage Levels

female BNC Impedance nominally 50 Q

Reserved for arbitrary and real-time baseband generators I/0O, such as markers or trigger
inputs.

female BNC Impedance: nominally 50 Q

A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.

Adjustable to * one timeslot; resolution = one bit

Markers

Each Arb-based waveform point has a marker on/off condition associated with it.

Marker 1 level = +3.3 V CMOS high (positive polarity selected); -3.3 V CMOS low (negative polarity
selected).

Output on this connector occurs whenever Marker 1 is on in an Arb-based waveform (see “Using
Waveform Markers” on page 145).

<-4 and > +8 V

female BNC Impedance: nominally 50 Q

A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger.
The input to this connector triggers the internal digital modulation pattern generator to start
a single pattern output or to stop and re-synchronize a pattern that is being continuously
output. To synchronize the trigger with the data bit clock, the trigger edge is latched, then
sampled during the falling edge of the internal data bit clock.

This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse (high or low) = 100 ns
Width

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods
<-4 and > +8 V

DIGITALBUS 1/0

This is a proprietary bus used by Agilent Technologies signal creation software. This connector is not
operational for general purpose use. Signals are present only when a signal creation software option
is installed (for details, refer to http./www.agilent.com/find/signalcreation).

NOTE The X-Series’ Digital BUS I/O connector can be used for enabling operation with the Agilent
Technologies N56106A PXB MIMO Receiver Tester.
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AUX1/0

Pin 1 = Event 1
18 1 Pin 2 = Event 2
View looking into rear panel female 36—pin connector Pin 3 = Event 3
Pin 4 = Event 4
36 19 Pin 5 = Sample Rate Clock Out
Pin 6-36 = application specific*

* Refer to the application’s help for more
The AUX I/O connector is a shielded .050 series board mount connector. information.

Event 1, 2, 3, and 4 (pins 1 - 4)

A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.

Adjustable to + one timeslot; resolution = one bit

Markers

Each Arb—based waveform point has a marker on/off condition associated with it.

Marker level = +3.3 V CMOS high (positive polarity selected); —3.3 V CMOS low (negative polarity selected).

Sample Rate Clock Out (pin 5)
This output is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data.

Damage levels:< -0.5 and > +5.5 V.
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2 Setting Preferences & Enabling Options

The Utility menu provides access to both user and remote operation preferences, and to the menus in
which you can enable instrument options.

Remote Operation

GPIB Address and Remote Language on page 24

Configuring the LAN Interface on page 25

Enabling LAN Services: “Browser,” “Sockets,” and “VXI-11” on page 26
Configuring the Remote Languages on page 27

Utility

Y

e

Utility
I/0 ConfigM User Preferences
Front Panel Knob Resolution on page 22
Instrument. |
B SETETES Setting Time and Date on page 22
Displagn\Reference Oscillator Tune on page 23
Power On/, | Display Settings on page 20
Freset

Power On and Preset on page 21
Instrument InfoM

//

lore 1 of 2 Enabling an Option on page 29
Upgrading Firmware on page 23
Utility
services———Hardware Assembly Installation and Removal Softkeys on page 31
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User Preferences

From the Utility menu, you can set the following user preferences:
¢ Display Settings, below
* Power On and Preset on page 21

¢ Front Panel Knob Resolution on page 22

Display Settings

See also, Using Secure Display on page 308.

Utility > Display Display
Range: 0 to 100
Brichtness 4+
75.0 %
Screen Saver
Jaly] Light Only: turns the display light off, leaving the text visible at a low intensity.

SEREET Sﬁggg 1 Light & Text: turns the display light and the text off.
(Light & Text) If the display remains unchanged for long periods of time, use this mode to

Screen Saver prevent the text from burning the display.
Oelau: 1 hr

Range: 1 to 12 hours, in 1 hour increments

_— Palette Select
Display Dark text on a light
Selecgaggégzg > Brioht Color background.
(Bright Color)

Light text on a dark

When on, commands executed through
Update in Remote |— ; xecu ug background.

o the remote control bus update the signal D=tk EElEr
generator display accordingly.

Activate,
Secure Display \page 308

Activate
Restrictede
Display

HMonochrome Bright without color

For details on each key, use key help
as described on page 34.

NOTE With the brightness set to minimum, the display may be too dark to see the softkeys. If this
happens, use the figure above to locate the brightness softkey and adjust the value so that
you can see the display.
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Power On and Preset

Pouerup Tupe

Utility > Power On/Preset “Pouer On/Preset | Last
Fower 0On >
(Preseti™ = Preset

Preset. Language,
(SCPI lissF

Restore Sustem
ings toe
Default Values

Select the GPIB language desired after a preset.

See also, the Programming Guide and the SCPI Command
Restores persistent settings

Reference.
f:thg:? ur::if:tctggrt;)é;;)ower Available only when 8648 is either the selected preset language or
tgthei;-rfjactor{/ defaults the selected remote language (see page 24).

Y
Restore Sustem
Confirm Restore

Sus Settimgs to
Default Values

*Caution

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to
non-volatile memory, the X-Series signal generator should always be powered down either via the instrument’s front
panel power button or the appropriate SCPl command. X-Series signal generators installed in rack systems and
powered down with the system rack power switch rather than the instrument’s front panel switch display a Error -310
due to the instrument not being powered down correctly.

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.
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Front Panel Knob Resolution

— Makes the increment value of the current function the active entry.

Utility >
Instrument Adjustments . . .
The increment value and the step/knob ratio determine how much each

turn of the knob changes the active function value.

patusHentts For example, if the increment value of the active function is 10 dB and the

SEERYITED (RELHE step/knob ratio is 50 to 1, each turn of the knob changes the active
\ function by 0.2 dB (1/50th of 10 dB).

Time/OateM— page 22.

To change the amount for each turn of the knob, modify the increment
Ref Oscillator

Tune }— page 23. value, the step/knob ratio, or both.
u]
AL mgﬁg%g? Executes the ALC Modulator Bias Adjustment. When using
Bims Gdiustment the ALC in open loop mode, this compensates for open loop

power drift due to temperature and humidity.

SCPI Commands:

-CALibration:ALC:MODulator:BIAS For details on each key, use key help

HMore 1 of 2 as described on page 34.
Setting Time and Date AdJustnents Tine Date
Step/Knob Ratio Time/Date
Utility > S0/1 OfFf
CAUTION Changing the time or date can Instrument Adjustments >
adversely affect the signal Time/Daterl— lEe e

generator’s ability to use time—based
licenses, even if a time—based
license is not installed.

Ref Oscillator
Tune Set Time

Execute
ALC Modulator Set Date
Bigs Adjustment

The signal generator’s firmware tracks the
time and date, and uses the latest time

and date as its time/date reference point. Hore 1 of 2

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time-based licenses,
and that you are resetting the signal generator’s time/date reference point. When you set a new time
or date that is later than the signal generator’s current reference point, that date becomes the new
reference point. If you then set the date back, you run the risk described in the next section.

Original time/date reference point New time/date reference point

> e

Time

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the
reference point. If you set the time back more a few hours, you disable the signal generator’s ability
to use time-based licenses, even if there is no license installed at the time that you set the time
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Setting Preferences & Enabling Options
Upgrading Firmware

back. In this case, you can re-enable the signal generator’s ability to use time-based licenses by
moving the clock forward to the original time or simply waiting that length of time.

Reference Oscillator Tune
Utility > Instrument Adjustments

Adjustments Tunes the internal VCTXCO oscillator frequency.
step/Knab HEB}& The user value offsets the factory tuned value (the value is added to the
factory calibrated DAC value). The tune value of 0 sets the factory

Time/Dates calibrated value.
- The range; —8192 to 8192, can be set by using the front panel keypad,
X USEIDNEEET knob or remote command.
0

Execute
ALC Modulator
Bigs Adjustment

See also the SCPI Command Reference.

Hore 1 of 2 For details on each key, use key help
as described on page 34.

Upgrading Firmware

For information on new firmware releases, go to http:/www.agilent.com/find/upgradeassistant.
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Remote Operation Preferences

Remote Operation Preferences

For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

Iiiiiil'

Utility

I/0 Configk

Instrument.,
Adjustments

Displaur

Fower On/,
Freset

Instrument Infok

.

fore 1 of 2

I/0 Confio

GPIE Setupw
LAN Setupe
LAN Services,
Setup

Remote LaTguage'

CPI)

SCPI Loo/Helpe

NOTES

GPIB Setup
GPIB Address
19

——page 25

———page 26

Select the desired language.

This setting is not persistent and is cleared by performing an
instrument Preset. In most cases, it is best to use Utility >
Power On/Preset > Language for a permanent language
change. See page 27.

USB is also available. It is not shown in the menu because it requires no configuration.

For details on using the instrument remotely, see the Programming Guide.

For details on each key, use key help as described on page 34.

24
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Configuring the LAN Interface

Utility > 1/0 Config

I/0 Confio

GPIE Setuprk

—

LAN Setupk
LAN Services |
Setup

Remote Language,
(SCPI

SCPI Loo/Helpe

NOTES

LAH Setup

Hostname
A-N5182B-00021

= LAN Config

Confia Tupe,
CAULO)

Manual Config,
Settings

| page 26.

Advanced,

Settings”™

Proceed Hith
Reconf iourat ion

Auto
(DHCP/Aut.o-IP)

Manual

Setting Preferences & Enabling Options
Remote Operation Preferences

Manual Settings

IF Address
0.0.0.0

Subnet. Mask
0.0.0.0

Default Gatewsy
0.0.0.0

ONS Serwver

Domain Mame

Y

Confirm

Confirm Change
(Network Will
restart)

Use a 100Base—T LAN cable to connect the

signal generator to the LAN.

Use a crossover cable to connect the signal

generator directly to a PC.

For details on using the instrument remotely,
refer to the Programming Guide and to
www.agilent.com and search on FAQs: Hardware
Configurations and Installation for the Agilent

MXG.

Adv Settings

Default Values

Dunamic ONS
Off

mokS /OMNS=50
0ff HGN

Restore LAN
Settings torf—

Values are listed in the
Programming Guide

For details on each key, use key help as described on page 34.

Confirm

Confirm Restore
LAN Settimgs to
Default Values

g SOCO.E01ilent.com
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Setting Preferences & Enabling Options
Remote Operation Preferences

Enabling LAN Services: “Browser,” “Sockets,” and “VXI-11"
Utility > 1/0 Config

LAH Services
T i Enable remote
L FTP Seruer (browser) access to the -
[ 0n 1 3 lUeb Services
GPIE Setupk o Lin instrument’s file system. Use a browser to control
uegFgerer 1 the signal generator.
Heb Servicese > —
LAN Setupe SCPI Services License Manager License Manager Server
rugr |
SCPI Servicese—— Sockets SCPI DFF (On) allows updates of the
LAN Services, Off instrument licenses, disable
Setup > for additional instrument
YAI-11 SCPI security.
Remote Language, Off
(SCPI)
Proceed With,
Reconf igurat ion _
SCPI Log/Helpe Confirm
_— Confirm Chanoe
CInstrument
Will Reboot)
For details on each key, use key help For more information refer to
as described on page 34. the Programming Guide.

26 Agilent MXG and EXG X-Series Signal Generators User’'s Guide



Configuring the Remote Languages

Utility > 1/0 Config
I/0 Confio

GPIE Setuprk

LAN Setupe

LAN Services,
Setup

Remote Language,
(SCPI)

SCPI Loo/Helpe

Remote Language

SCPI

NS181A ,M5182R
ELL23C ,ELL38C
EB2570,E82670
ESEE3E

EB2L7C ,EB257C
ES267C

fore 1 of 3

For details on each key, use key help

as described on page 34.

Setting Preferences & Enabling Options
Remote Operation Preferences

Select the desired Remote language.

Remote Language

ES2L 1A ,E82LLA
EB251A ,EB25LA

ELL2%E ,ELLExE

86L3A/B/C/D
(GPIE onlu)

8BSER ,8657A /B
(GPIE onlul

8bb2A
(GPIE onlu)

fore 2 of 3 5

Remote Language

Remote Language

8E63A SHUZ00A
(GPIE onlu) SMATEZ00A
Fohde & Schuarze— SMJ100A
Aerof Lexr SMI0
SHL
Sy

fore 3 of 3 fore 1 of 2

Refer to the SCPI Command Reference.

SME100A
SHEV100A

— 3410 Series

Remote Language

Remote Language

Agilent MXG and EXG X-Series Signal Generators User’'s Guide
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Setting Preferences & Enabling Options
Remote Operation Preferences

Configuring the Preset Languages

Figure 2-1 N5171B/72B/81B/82B

Utility > Power On/Preset Select the desired Remote language.

Pouer Dn/Preset Preset Language Preset Language Preset Language Preset Language
Pawer On, G EB24 1A ,EBZLLA 86534 SHUZ00A
(Preset.) ES251R,EB25LA (GPIE only) SHATEZ006A

FREsEt (EmEERs \ NS181A,N51824 ELLZxB ELL3xE Rohde & Schuarz SHJ100A
| ELUZEC ELL3EE e Aerof Lex SHIO
Restore Sustem \ EB2570,E52670 BRSEE: ,BRE7A/E
T ES W \ EBEE3E (GPIE only) Sk
\ \ EB2L7C ,EBZS7C 86526 -
EBZE7C (GPIE only)
\\ Hore 1 of 3 _ | fore 2 of 3 _ More 1 of 2
\ Preset Language
page 21 SHE100A

SHEV100A

For details on each key, use key help Refer to the SCPI Command Reference.
as described on page 34.

» Preset Language

3410 Series
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Setting Preferences & Enabling Options
Enabling an Option

Enabling an Option

There are two ways to enable an option:

¢ Use the License Manager software utility:
1. Run the utility and follow the prompts.

2. Download the utility from www.agilent.com/find/LicenseManager and select license (.lic) files
from an external USB Flash Drive (UFD).

¢ Use SCPI commands, as described in the Programming Guide.
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Setting Preferences & Enabling
Enabling an Option

Options

Viewing Options and Licenses

Utility > Instrument. Info Options Info
Instrument Info Inst. t
Dimgnostic Infoe nsuggggﬂsb
; Auxiliary
Options Infobl— coetiare Options"| ™
Self Tests iy
Installed,
Eoard Info

Front. Panel Testse

Instrument options appear

here. A check mark means that

an option is enabled.

Aux Softuare Licenses

Service Software Licenses
appear here.

Haveform Licenses

03

Have ID Days Left Description

Waveform licenses from some
Signal Studio applications appear here.

03/09/2012 14:31

Instrument Options
Option Expiratipn

+

+
oo9 permanent. \
012 permanent. \
021 permanent. \
022 permanent.  \
023 permanent.
093 permanent.
1EA permanent.

Description

Security and removable memory card
Internal solid state memory
L0 in/fout for phase coherencd
Upgrade EBG memory from 32 Msa to 256 Msa
Upgrade EBG memory from 32 Msa to 512 Msa
Upgrade EBG memory from 32 Msa to 1 Gsa
Expanded license key upgradabilitu
High power output

03/09/2012 14

[Oigitgl output connec ity 1ith the MNS102
Digital input connectivity with the WS102A

A

For details on each key, use key help

as described on page 34.
29
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Setting Preferences & Enabling Options
Hardware Assembly Installation and Removal Softkeys

Hardware Assembly Installation and Removal Softkeys

Utility > More 2 of 2 > Service For details on each key, use key help
as described on page 34.

Remove Assy

Prepare
CPU Assembly
For Remowal

Service

Remove Assembly

Confirm Removal
of CPU Assembly

Prepare
Install Assembly RF Assembly
For Remowal

Prepare
BEG Assembly

For Remowal Vector models only

Note: When pressed, a Confirm Removal menu (similar to the
one shown here for the CPU assembly) is opened for the RF and
BBG assemblies too.

Note: When pressed, a Confirm Install menu (similar to the one
shown here for the CPU assembly) is opened for the RF and BBG
assemblies too.

Y
Install Assu
Finalize Confirm
LPU fssembly Installation
Installation of CPU ASsemblu
Finalize
Abort.
Iﬁgtgﬁﬁggﬁéﬁ Installation
Finalize
%Egtgﬁgﬁéﬁ | —_Vector models only

Note:

Each Remove Assembly softkey (CPU/RF/BBG) when enabled will display a message in the lower left quadrant of display indicating
assembly prepared for removal or removal has been aborted.

Each Install Assembly softkey, when enabled will display a message in the lower left quadrant of display indicating assembly prepared for
installation or installation has been aborted.

Refer also, to the Service Guide.
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Hardware Assembly Installation and Removal Softkeys
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3 Basic Operation

This chapter introduces fundamental front panel operation. For information on remote operation,

refer to the Programming Guide.

Presetting the Signal Generator on page 34

Viewing Key Descriptions on page 34

Entering and Editing Numbers and Text on page 35
Setting Frequency and Power (Amplitude) on page 37
Setting ALC Bandwidth Control on page 39
Configuring a Swept Output on page 40

Modulating the Carrier Signal on page 48

Working with Files on page 50

Reading Error Messages on page 62

Agilent MXG and EXG X-Series Signal Generators User's Guide
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Basic Operation
Presetting the Signal Generator

Presetting the Signal Generator

-
e

To return the signal generator to a known state, press either Preset or User Preset.

User

el Preset is the factory preset; User Preset is a custom preset** (see also, page 21).

To reset persistent settings (those unaffected by preset, user preset, or power cycle*),
press: Utility > Power On/Preset > Restore System Defaults.

*Caution

To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to
non-volatile memory, the instrument should always be powered down either via the instrument's front panel power
button or the appropriate SCPI command. instrument's installed in rack systems and powered down with the system
rack power switch rather than the instrument's front panel switch display a Error -310 due to the instrument not
being powered down correctly.

**You can create more than one user preset by giving each saved state file a different name (see Figure 3-9 on page 60).

Viewing Key Descriptions

ﬁ The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.

2. Press the desired key.
The help displays and the key’s normal function does not execute.
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Basic Operation
Entering and Editing Numbers and Text

Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Use the number keys and decimal point to enter numeric data.
Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

Local

Cancel/ zaue Page up/down keys move tables of data up and down within the display area.

Esc)

— = Left/right arrow keys move the cursor horizontally.

Use the Select hardkey to choose part of an entry, as when entering alpha
Incr Page characters. In some menus, the Select key also acts as a terminator, and is
gt Down | equivalent to the Enter softkey.

SIS
319
be

To specify a negative value, enter the
negative sign either before or after
the numeric value (this key is a toggle).

EIEIEIS
BElEE

prse Backspace moves the cursor to the left, Note: Rotating the knob increases or

deleting characters as it goes. decreases a numeric value, changes a
highlighted digit or character, or steps
et through lists or items in a row.

90

See also, Front Panel Knob Resolution on page 19

For details on each key, see page 34.

Entering AIpha Characters Note: File names are limited to 25 characters.

Data entry softkeys appear in various T Text Entru ]
menus. If their meaning is not clear in
context, use the help key (described on
page 34) to display an explanation. Use
the softkey next to the alpha table for
help on the table.

Enter

Clear Text

Editing Mode
il Feplace

Selecting data that accepts alpha
characters, displays one of the menus Show Al Table | to move the cursor
shown at right. =% | within the active value
HIJKLH rather than within the
Use the arrow keys or knob to highlight HOPQRSTUULIXYZ ::P:: :ZE::;#m the
the desired letter, then press the Select I P '
hardkey (or the softkey next to the

alpha table). To correct errors, use Bk Add/edit comments for saved
Sp or Clear Text instrument state files (see page 57).

To terminate the entry, press the Enter
softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the
letters A through F (use the numeric keypad for other values).
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Entering and Editing Numbers and Text

Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.
2. Open the table editor: Press Sweep > More > Configure List Sweep.

The signal generator displays the editor shown in the following figure.
Active Function Area Cursor

Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable)
item, either press Select, or simply enter the desired value.

List Table
Edit Item
List Node Ualues
Po 1711 Frequency  Pouer Uaveform pell
1 -14L. 00— CH <no modulation? 2.000 m=
2| 00000000000 GHz -- O ¢no modulation) 2.000 ms Insert Fou
3| B[00000000000 GHz -— CH (no modulat ion) 2.000 ms
L| B0000D0D0DNG GHz —— CH (ng modulat ion) /ﬂ.DDD ms
5| B-0000000000MNGHz —— CH (ng' modulation) 2.000 Delete Row
6| Bl.00000000000 GNz —— CH (np modulation? 2.000
7| Bl.00000000000 GH -— CH (o modulat ion) 2.000
8| B[00000000000 GHz 2.000
9| Bl.000000D0O000 GHz (vector models of 2.000 /ms Goto Rouw
10| & 00000000000 GHz 2.000/ ms
/ // [[(_Nore 1 of 2
Table Editor Name Table Items Table Editor Softkeys Indicates that
Table items are also Used to load, navigate, modify, and another menu
called data fields. store table item values. For details . : .
Current / Total Number of Pages on each key, use the key help- is available; to
display the
Press the Help hardkey and then second menu
the desired key. press More.

Highlight the desired item: use the arrow keys or the knob to move the cursor.
4. (Optional) Display the selected item in the active function area: Press Select.
Modify the value:

e If the value is displayed in the active function area, use the knob, arrow keys, or numeric
keypad to modify the value.

e If the value is not displayed in the active function area, use the numeric keypad to enter the
desired value (which then appears in the active function area).

6. Terminate the entry:

e If available, press the desired units.
e If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.
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Setting Frequency and Power (Amplitude)

Figure 3-1

Frequency and Amplitude Softkeys

Basic Operation

Setting Frequency and Power (Amplitude)

In Frequency mode, this menu is
-a—automatically displayed when entering
a numeric value with the front panel

In Amplitude mode, this menu is
automatically displayed when entering
a numeric value with the front panel

keypad. ¢ keypad.
Frequency Frequency Units Amplitude Pouer Unils ?&”yjzgfgﬂgﬁ:fs
Freq Ref Set Opens the electromotive force.
9 e lrs GHz AttenfLlyl  Atten/ALC dEm |  Emfis the output
Control voltage with no
Freg Ref menu. load. This unit is
on |—page 104 MHz s duy || extemal only.
representation as
Freq Offset well as increment
0.00 Hz kHz dBuvemf and decrement
values are in dBm.
Freq Multiplier He Note: dBuV, mV,
1.000 i and nVemf behave
similarly (i.e. Values
Leveling are external only.
Freq Channelse memf Internal
Contral representation as
Hore 1 of 2 well as increment
IGTER R and decrement
Sets the current relative phase of values are in dBm.).
the RF output signal as the zero i}
Frequencu reference. Amplitude
All subsequent adjustments are AmPtd Ref Set
Phase Ref Set - : .
relative to this adjustment. 0.00 dém
This softkey sets a user
Adjust Phase R&t.d Ref determined maximum power
0.000 rad ~Freq Channels ] On level on the instrument that is
g - 1 persistent.
Reference req Lhdnne s Amptd Offset
Oscillator?| Pa9e 38 an 0.00 oB _
Anplitude Available on vector
Improuve Channel Humber 5 models with BBG.
non-fiarmonics 1 llser Flatnesse—page 8 lUser Pouer Maxh Enables the instrument
il On to select between two
i ; ower levels with a
evice DH%\EUtDBl% ﬂltef_“nate.._ﬁardware marker or
a Amelitude using an external BNC.
fore 2 of 2 fore 2 of 3
—_—— Ehénnel Band,, — Gl EW 39
tP-G5H Base) (Auto)*[——Page
nables the mode to improve non-harmonics performance (low spurs mode).
Note: When this mode is enabled, the instrument switching speed and behavior of
the source’s settled signal are affected. Poueﬁoggg, Foner OpT Tiodes
To display the next menu, press More. Optimize S/M
play p Hore 3 of 3 a2

Enables the optimize signal-to-noise ratio state (Optimize S/N) On or Off. /_'

The optimize signal-to—noise softkey changes the attenuator and alc setting to provide
optimal signal-to—noise performance; it does not change the RF output power.
Caution: When the optimize signal-to-noise ratio state is enabled, some increased levels of
harmonic distortion can occur. This increased harmonic distortion could degrade ACPR and

EVM.

Note: This mode is mutually exclusive with attenuator hold (Atten Hold), and any modulation
type. A settings conflict error will be generated if attentuator hold or any modulation is
activated when optimize signal-to—noise is active (On).

For details on each key, use key help
as described on page 34.

Refer to the SCPI/ Command Reference.

Optimize

Harmonics
an

Modifies the attenuator and ALC settings
for optimal performance. It does not
change the RF output power.
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Setting Frequency and Power (Amplitude)

Example: Configuring a 700 MHz, —20 dBm Continuous Wave Output

1.

Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the
front panel display areas are shown on page 9).

Set the frequency to 700 MHz: Press Freq > 700 > MHz.

The signal generator displays 700 MHz in both the FREQUENCY area of the display and the active
entry area.

Set the amplitude to —20 dBm: Press Amptd > —-20 > dBm.

The display changes to —20 dBm in the AMPLITUDE area of the display, and the amplitude value
becomes the active entry. Amplitude remains the active function until you press another function
key.

Turn on the RF Output: Press RF On/O0ff.

The RF Output LED lights, and a 700 MHz, —20 dBm CW signal is available at the RF OUTPUT
connector.

Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.
Freq > More

+ Ref Oscillator
Int |——Uuses the signal generator’s internal reference oscillator.
Frequency
uses the REF IN connector to get it's Frequency Reference. Note: An
Fhase Ref Set Ext. error screen is displayed if the reference is not connected or is tuned
to the wrong frequency.
QUJHSBDEhaSg _ uses the signal generator’s internal reference unless a signal is
o Pl Ref Oscillator Auto present at the rear panel REF IN connector. If an external signal is
Ref Oscillator present, that signal is used as the reference.
Reference Sourcek .
i '——»l | uses the baseband generator clock (BBG) as the reference oscillator
oEEEEr (UL EEE source. Available on vector models with BBG.
Ref Oscillator
nDn—har;$EDigg [BudiIFFEE)
an 10.0000000 MHz
Ref Oscillator Range: 1 to 50 MHz
EXt BEIH For guaranteed operation below 2 MHz, select Narrow bandwidth; in Wide bandwidth,
arroq s operation using frequencies below 2 MHz is not guaranteed.
Hore 2 of 2

Figure 3-2 illustrates the better close in phase noise of the wide bandwidth mode. If the
external reference you are using is noisy or spurious, use the narrow bandwidth mode.

With Wide bandwidth selected, if you select a frequency less than 2 MHz, the signal
generator displays a warning message.

For details on each key, use key help as described on page 34.
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Figure 3-2 Using an External Referenc

e Oscillator

Basic Operation
Setting ALC Bandwidth Control

MXG Close In Phase Noise @1 GHz

-4.00E+01

-4, 50E+01 Do L

-5.00E+1 u

-5 50EHI1

narrow bandwidth mode,

-5 O0E-+H11

external reference

5 50E401
"

wide bandwidth mode,

-7 O0E-+H01

external reference

-7 B0EH01

-6 00E-+H01

-B.S0EHT

-9.00E+1

-9.50E+HT

dBc/Hz

-1.00E+02

-1.05E+02

-110E+02

-118E+02

-1 20E+02

-1 25E+02

-1 30E+12

-1.35E+02

-1.40E+02

-1.45E+02

-1.50E+02
1.00E-+10

1.00E+01 1.00E-+02

1.00E+03 1.00E+04

Offset Frequency

1.00E+05

1.00E-+18

Setting ALC Bandwidth

Figure 3-3 Amplitude Softkeys

Amplitude

AttensALC,
Control

ALC /

Off NN

Leveling,
Control

fore 1 of 3

For details on each key, use key help
as described on page 34.

Control

Amplitude
Ametd Ref Set
0.00 dEm

v
Amptd Ref
Mz o
Ametd Of fset
0.00 dB
User Flatnesse

Output Blankin
bFFon R

fore 2 of 3

Amplitude

User Power Maxk

| Alternate,
| Amplituds

J ALC B,
| (AuULo)

Fower Opt,
Modes

fore 3 of 3

Refer to the SCPI Command Reference.

> ALC Banduidth

Enables the
automatic
——ALC
bandwidth
mode
(Auto).

Auto

200 Hz

2 kHz

20 kHz

To display the next menu, press
More.
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Basic Operation
Configuring a Swept Qutput

Configuring a Swept Output
The signal generator has two methods of sweeping through a set of frequency and amplitude points:

Step sweep (page 42) provides a linear or logarithmic progression from one selected frequency,
amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along the
sweep. The sweep can progress forward, backward, or manually.

List sweep (page 44) enables you to enter frequencies and amplitudes at unequal intervals, in
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list sweep
data in the file catalog (page 55).
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Basic Operation
Configuring a Swept Output

Figure 3-4 Sweep Softkeys

During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

The selected sweep type determines the displayed parameter.

- h ’ < Progress Bar: Note that very fast sweeps
Selecting step sweep also displays the step spacing (Lin or Log).

can appear to sweep randomly or
backward.

FREQUEHCY AAPLITUDE Sueep/L1s
00 J 0 00 GHz —144.00 dBm oLy Sueep fode
Of f
Sweep Tupe
Sueep/List Status Informatfion List Freq
Sreep L OfFf 0ffF gl
Steep Tupe {(Step LIN SSiHS?g %
Manual Mode o OFfF fAretd
SHeep Direction: Up on
Sreep Repeat 1 Cont
Sweep Triooer : FreeBun
Step Points 10 Point Triooer : FreeRun .
Freq Step Size : 0.00Hz gronfisure, page 42
Step Dnell 1 2.000msec
I nore ﬁ of 3
—Trisser Seiop ] Sweep without waiting for )
rigger Setup a trigger at each point. On vector models:
& 0 Point Trigger pauses for the dwell Available Whef .
ree hun time prior to the first sweep. See Sweep Type = List
page 108.
Sueep/List Trioger Key
Confioure Trigger on a remote command.
List Sneep*[—Page 44
Bus Apply a TTL/CMOS signal to the
Sweep Trigoer | Trigger In connector.
Free Run) EXT
(Trigger 13* Down sweeps from
. . Sueep/L1St stop to start
PDlTEP;ElaSﬁGV frequency/amplitude.

INT i i
(Pulse Sunc)® SEER Béﬁﬁcﬁmmn

fore 1 of 2

Up sweeps from start
to stop
SWeep Retrace frequency/amplitude.

page 48 f

<

Periodically issue a trigger event to

Trigger Setup whatever selects it as a source.

lore 2 of 3 ; .
Timer Trigger Using timer trigger with single
sweep results in a delay prior to the

first sweep. See page 108.

Route Connectors,
& Set Polarity

fore 3 of 3

—page 42

For details on each key, use key help as described on page 34.
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Routing Signals

Sweep > More > More > Route Connectors

Step Sweep
Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, or

both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. The
sweep can progress forward, backward, or be changed manually.

Figure 3-5 Signal Routing Softkeys

Route Connectors Trig 1 Out BHC Trig 1 Out BHC
Foute To
Trig 1 ENCe > Hone LKI
(None )
Sueep Dut BHC
Tr“HiSu%eBﬁ& Routes Step or SHeep Trig Out Sieep Run
(Sweep Trig Outl Sueep Out )| List Sweep

signals.
Sueepﬁgﬂ%eeﬁ& > Source Settled Trigger 2
(SHeep Out) Source Settled | Routes non Step

/

or List Sweep
Route To signals (i.e. SCPI Pulse Sunc Pulse
ERSEIED S Pulse Wideo command

development.

Trigger Out, Pulse Yideo Swept. Func Done
FRILEI1iEY Pulse Sunc Source Settled is
These softkeys are not affected by Hore 1 of 2 —} - Hore 2 of 2
only available for Trig Out Polarity
wi?h": %%remodels Sweep Run Neg Pos softkey
selection.

fore 1 of 2
Routes a signal to the Trig Out (Trig 1 or Trig 2) rear
panel connectors as follows:

(L TS [0~ None: No signals are routed to Trig 1 or Trig 2 BNCs
Foute To Sueep Dut BHC i X .
BE TRIG 1 BHCe Sweep Trigger Out: Sweep Trigger Out signal (trigger
(Marker 23 Suept Func Done handshake)
Route To Source Settled: Source Settled signal
EB THIG(SDEEQ’ %ﬂ%ﬂz iﬂg‘ﬁgﬁsfqr Pulse Sync: Pulse Modulation Synchronization signal
through 4 to the Pulse Video: Pulse Modulation Video signal
Route To rear panel )
EVENT 1 BNCK baseband BNC LXI: LXI Trigger Output
tMarker 1) connectors. Sweep Run: Sweep Run signal (sweep is running)
PATT ?a%eeﬁgb Other Trigger BNC: The signal on the other Trigger
(None ) BNC
Pulse BNC: The signal on the PULSE IN BNC
Swept Func Done: Swept Function Sweep Done signal
Marker 1
Marker 2
-
Marker 3
\ Marker L )
For details on each key, use key help as described on page 34.
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Figure 3-6 Sweep Softkeys

v

Sueep/List
SHeep,
(OfF2

Sweep Tupe
List

Sweep Repeat
Single ﬁ!

Conf igure

Step Swesptl—

fore 1 of 3

fore 1 of 2 |

Step Sueep
Freq Start
. 00000000000GHz
Freg Stop
&.00000000000GHz
Ametd Start
-1L4L.00 dBm

Amptd Stop
—1hL.00 dBm

# Points
101

Step Sueep
Step Dnell
2.000 msec

Step Spacing
LOG

LIN Freq Step
0.00 Hz

Example: Configuring a Continuous, Linear Step Sweep

Output:

of 500 ms at each of six equally—spaced points.

Basic Operation
Configuring a Swept Output

For details on each key, use key help
as described on page 34.

Dwell Time = the time that the signal is settled and you can make
a measurement before the sweep moves to the next point.

(Point to point time is the sum of the value set for the dwell plus
processing time, switching time, and settling time.)

Step Sweep and List Sweep dwell times are set independently.

Lin = steps equally spaced over the sweep; the output changes
linearly.

Log = step spacing increases logarithmically over the sweep; the
output changes exponentially.

Sets the step size for a linear step sweep in frequency (the difference
between frequency points).

NOTE: Setting the step size will determine the number of points in the
step sweep based on the current start and stop frequencies. Due to the
integer number of step points, the step size may be adjusted in order to
yield a true linear sweep between the start and stop frequencies.

A signal that continuously sweeps from 500 to 600 MHz and from —20 to 0 dBm, with a dwell time

1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step spacing
selection, you do not need to set these parameters.

2. Open the step sweep menu: Press Configure Step Sweep.

Set the following parameters:

Start frequency 500 MHz:

Stop frequency 600 MHz:

Amplitude at the beginning of the sweep, —20 dBm:
Amplitude at the end of the sweep, 0 dBm:
6 sweep points:

Dwell time at each point, 500 milliseconds:

Press Freq Start > 500 > MHz
Press Freq Stop > 600 > MHz
Press Amptd Start > —20 > dBm
Press Amptd Stop > 0 > dBm.
Press # Points > 6 > Enter

Press More > Step Dwell > 500 > msec

Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd Off On.

A continuous sweep begins, from the start frequency/amplitude to the stop frequency/amplitude.
The SWEEP annunciator displays, and sweep progress is shown in the frequency display, the

amplitude display, and the progress bar.
Turn the RF output on: Press RF On/O0ff.

The RF LED lights, and the continuous sweep is available at the RF Output connector.
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List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear

ascending, descending, or random order. List sweep also enables you to copy the current step sweep
values, include a waveform in a sweep (on a vector instrument), and save list sweep data in the file
catalog (page 55). Dwell time is editable at each point. For fastest switching speeds, use list sweep.

Figure 3-7 List Sweep Configuration Softkeys and Display

™ Sueep Hode | For details on each key, use key help
as described on page 34.
v 0ff
Sueep/List Freg
Sueep, - an
COff) -
Displays the selected ”Eﬁd
LSNEB Tope sweep type parameters -
s (see page 45) Available only on vector models,
and
Sweep Repeat = Li
Sirois ﬁ! only when Sweep Type = List.
page 42
. FREQUEHCY AAPLITUDE List Table
Configure,
Step S
ep Sheep 6.000 000 000 00 GHz _144.00 dBn Edit Item
fore 1 of 3
Sueep/List
. Haveform
Conflaure,) g B|-144.00|-- CH (no modulation) 2.000 ms
List Sheep . 00000000000 -144.00|-- ©M (no modulation) 2.000 ms Insert Rou
£.00000000000 GHz|-1bb4.00|-- CH ¢no modulation) 2.000 ms
e TiFiEEEr £.00000000000 GHz|-144.00|-- CH (o modulation) 2.000 ms
TFree Ao * £.00000000000 BHz|-144.00|-— CH (no modulation) 2.000 ms Delete Row
£.00000000000 GHz|-1bb4.00|-- CH ¢no modulation) 2.000 ms
. . £.00000000000 GHz|-1bb4.00|-- CH ¢no modulation? 2.000 ms
Point Trigger, £.00000000000 GHz|-1b4.00 2.000 ms
(Free Run) £.00000000000 GHz|-1b4.00 2.000 ms Goto Rowk
£.00000000000 GHz|-1h4.00 ? 2.000 ms
02/23/2012 14:19 fore 1 of 2

Each line defines the Vector models only
Nore 2 of 3 corresponding point in

the sweep. For example, —_—
line 1 defines point 1. List Table
Sueep/List Load/Storek

Sweep Direction see page 45
Down NI T Preset Listh
Sueepuﬁ?t The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell

time is the same at each point; List Sweep dwell time can be different at each point. Insert Item
Dwell Time = the time that the signal is settled and you can make a measurement before the

sweep moves to the next point. Delete Item
Point-to—Point Time = the sum of the value set for the dwell plus processing time, switching OLell Tupe
time, and settling time. S =]

Route Connectors Hore 2 of 2
& Set Polaritu®~_ 06 42

fore 3 of 3

44 Agilent MXG and EXG X-Series Signal Generators User’s Guide



Basic Operation
Configuring a Swept Output

Example: Configuring a List Sweep Using Step Sweep Data
1.

Set up the desired step sweep, but do not turn the sweep on. This example uses the step sweep
configured on page 43.
In the SWEEP menu, change the sweep type to list:
Press SWEEP > Sweep Type List Step to highlight List.
The display shows sweep list parameters, as shown below.
FREQUENCY ANPLITUDE Sueep/List
6.000 000 000 00 &= -144.00 cen Sueen,
SHeep Tupe
Sueep/List Status Information List %
SHeep : Off
Sueep Tupe : Step LI S e
Manual Mode : Off
SHeep Direction: Up
Sreep Repeat : Cont
Sweep Triocger @ FreeRun
Step Points 101 Point Triooer : FreeRun
Configure,
Step Ouell : 2.000msec SiEEp EPEEE
02/25/2012 12:53  Hore 1 of 3

Open the List Sweep menu: Press More > Configure List Sweep.

Clear any previously set values from the menu and load the points defined in the step sweep into
the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset.

The display updates with the values loaded from the step sweep, as shown.

FREQUEHCY

6.000 000 000 00 s+

ANPLITUDE

-144.00 8o

List Hode Ualues
Po 1/11

1 Frequency  Pouer Haveform Duell
1| = ERE | —1L4L4.00|-- CH (no modulation? 2.000 ms
2| £.00000000000 GHz|-1hb.00 2,000 ms
3| £.00000000000 GHz(-1bb.00 2.000 ms
4| £.00000000000 GHz|-1hb.00 2,000 ms
9| E.00000000000 GHz|-1hb.00 2,000 ms
6| E£.00000000000 GHz|-1hb.00 2,000 ms
7| 6.00000000000 GHz|-1hb.00 2,000 ms
8| £.00000000000 GHz|-1uk.00 Waveforms are available 2.000 ms
9| E£.00000000000 GHz|-1hb.00 2,000 ms
10| £.00000000000 GHz|-1u4.00 only on vector models. 2.000 ms
02/23/2012 1L:37

List Table

Load/Stores

FPreset Liste

Inzert Item

Delete Item

Ouell Tupe
Step

Hore 2 of 2

Vector Models:

Presetting the list clears
any previously selected
waveforms.

For information on
selecting a list sweep
waveform, see Example:
Editing List Sweep
Points on page 46.

5. Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off On.

Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, the
SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

6. If not already on, turn the RF output on: Press RF On/Off.
The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.
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Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 36.

1.

2
3.
4

10.

11.
12.

FREQUEHCY ANPLITUDE Arb Uaveform

6.00000000000 sz -144.00 den cugﬁﬁg%mgﬁ‘fggi;m— Either select a waveform,
1

Select Segment On Sequence On
Po 171 BBG Hedia Points Int Hedia Seas

Create the desired list sweep. This example uses the list sweep created in the previous example.
If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error.
Ensure that the sweep type is set to list: Press SWEEP > Sweep Type List Step to highlight List.

In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 ms:

a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.

The next item in the table (the frequency value for point 2) highlights.

Change the selected frequency value to 445 MHz: Press 445 > MHz.

Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row.
This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent rows.

Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in row
5, then press More > Insert Item.

This places a copy of the highlighted frequency value in row 6, shifting the original frequency
values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the
power and dwell time entries do not shift down).

Change the still active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in row 5
is now the active parameter.

Insert a new power value (-2.5 dBm) for point 5, and shift down the original power values for
points 5 and 6 by one row: Press Insertltem > -25 > dBm.

To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy
of the existing value down: Highlight the dwell time in row 7 and press Insert Item.

For an analog instrument, go to step 14. For a vector instrument, continue with step 12.
Select a waveform for point 2:

a. Highlight the waveform entry for point 2 and press the More > Select Waveform.
The signal generator displays the available waveforms, as shown in the following example.

)]

Displad Haveform,
And Markers or

RAMP_TEST_LIFM 200 S5 ARTEMMAZM 2097152 Wavefarm,
ME_TEST | 200 Sz Seoments®

(no modulationd

select no modulation.

Goto FRowe

b. Highlight the desired waveform (in this example, SINE TEST) and press either the Select
hardkey or the Select Waveform softkey.

46
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13. As desired, repeat step 12 for the remaining points for which you want to select a waveform. The
following figure shows an example of how this might look.

ANPLITUDE List Table

-144.00

6.000 000 000 00 &+

Select Haveformk The empty entry is equivalent to
| choosing CW (no modulation).

cH
List NHode Values Ulation)
Po 1711

1 Frequency
1| £.00000000000 GHz ms
2| 445, 00000000000 FHz . 0.000 ms Insert Row
3| &.00000000000 GHz|-1bk.00 2.000 ms
4| £.00000000000 GHz|-1bk.00 2.000 ms
5|590.00000000000 FHz| -2.50 2.000 ms Delete Row
6| E.00000000000 GHz| -2.50 2.000 ms
7| &.00000000000 GHz|-1bk.00 2.000 ms
8| &.00000000000 GHz|-1bk.00 2.000 ms
9| &.00000000000 GHz|-1bk.00 2.000 ms Goto Roue
10| £.00000000000 GHz|-1bk.00 2.000 ms
02/24/2012 11:10 Hore 1 of 2

14. Turn sweep on:
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15. If it is not already on, turn the RF output on:
Press RF On/Off.

The SWEEP annunciator appears on the display, indicating that the signal generator is sweeping,
and the progress bar shows the progression of the sweep.

NOTE If the instrument is in manual sweep (page 48), the active row (row 6 in the figure above) is
the selected (manual) point, and the signal generator outputs the settings for that selection
when the RF output is on.

Example: Using a Single Sweep
1. Set up either a step sweep (page 43) or a list sweep (page 4b).

2. In the List/Sweep menu, set the sweep repeat to single:
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting to
be initiated.

If not already on, turn the RF output on: Press RF On/Off.
4. Initiate the sweep: Press Single Sweep.
A single repetition of the configured sweep is available at the RF Output connector.

As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the
progress bar shows the progression of the sweep.

At the end of the sweep, there is no progress bar, and the WINIT annunciator replaces SWEEP.
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Example: Manual Control of Sweep
1. Set up either a step sweep (page 43) or a list sweep (page 4b).
2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter > Return.
3. Select manual mode: Press More > Manual Mode Off On.
When you select manual mode, the current sweep point becomes the selected manual point.
4. If it is not already on, turn the RF output on: Press RF On/Off.
Select the desired point to output: Press Manual Point > number > Enter.
The progress bar changes to indicate the selected point.

6. Use the knob or arrow keys to move from point to point. As you select each point, the RF output
changes to the settings in that selection.

The SWMAN annunciator
indicates that the sweep
is in manual mode.

When you enter a manual point,
the progress bar moves to and
stops at the selected point.

The currently sweeping
parameter stops and
displays the selected point.

The parameters of the selected sweep point (point 3
of 6 in this example) define the signal available at the
RF Output connector.

FREOUEHCY ANPLITUDE eep/List
Configure,

List Sueep

fMlanual Point: 100 Skeep Trigoer,

Sueep/List Status Information (Free Runi
Sheep : Freg+Amptd (Current Point : 100/104 ) . .
Steep Tupe 1 List Skeep Speed 1 273ptsssec PDlTEP;ElESﬁGD
Frequency Points: 104 Manual Mode HE
Amplitude Points: 104 Manual Hode When you turn manual mode on, the
OFf M current sweep point becomes the
Duell Tupe : List manual point.

Manual Point
100

0272472012 11:18 Hore 2 of 3

Modulating the Carrier Signal
To modulate the carrier signal, you must have both

¢ an active modulation format
and

¢ modulation of the RF output enabled

Example

1. Preset the signal generator.

2. Turn on AM modulation: Press AM > AM 0ff On (requires Option UNT).
You can turn on the modulation format before or after setting signal parameters.
The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating
that a modulation format is active.
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3. Enable modulation of the RF output: Press the Mod On/0ff key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not
modulate until you subsequently turn on a modulation format.

Annunciator indicates active AM modulation @

FREQUEHCY ANPLITUDE ;1]
6.000 000 800 00 &z -144.00 den Lge
At LED indicates that any active

AN Path modulation format can modulate

Analog Hodulation Status Information 2 B the carrier.

AfL FuncGenl Depth:0.1% Hfm:Sine(L00. 0Hz)
Ar2 FuncGenl Depth:0.1x Hfm:SinecL00. OHz) _ar .
AE T Tnpdt Depth:0.5V=100x off ~<«——AM modulation format on.
Fri FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz)
Fr2 FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz) AM Depth
Bl FuncGenl Dev:0.000rad Wfm:Sine ko0, 0Hz) a E b
2 FuncGenl Dev:0.000rad Hfm:Sine koo, 0Hz) T
LFOut  IntHonitor Ampl:0. 0004 Monitored:FuncGenl

AM Source,

(Func Gen 13
- | tore 1 of 2

NOTE To turn modulation off, press the Mod On/0ff key until the LED turns off.

When the Mod On/0ff key is off, the carrier signal is not modulated, even with an active
modulation format.

4. To make the modulated carrier available at the RF output connector, press the RF On/0ff key until
the LED lights.

See also: “Using Analog Modulation (Option UNT)” on page 63
“Using Pulse Modulation (Option UNW or 320)” on page 113
“I/Q Modulation” on page 188
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Simultaneous Modulation

NOTE The Agilent X-Series signal generators are capable of simultaneous modulation. All
modulation types (AM, FM, ¢M, and Pulse) may be simultaneously enabled. But, there are

some exceptions. Refer to Table 3-1.

Table 3-1 Simultaneous Modulation Type Combinations

AM? FM oM Pulse®
AM -- X X X
FM < -- not applicable X
oM %€ not applicable -- X
Pulse X b'q b ¢ --

dLinear AM and Exponential AM cannot be enabled simultaneously. Refer to Chapter 4.
bPulse modulation requires Option UNW. Refer to Chapter 6.
°FM and oM cannot be enabled simultaneously.

Working with Files

¢ File Softkeys on page 51

¢ Viewing a List of Stored Files on page 52

e Storing a File on page 53

¢ Loading (Recalling) a Stored File on page 55

* Moving a File from One Media to Another on page 56
¢  Working with Instrument State Files on page 57

¢ Selecting the Default Storage Media on page 61

The signal generator recognizes several types of files, such as instrument state files, license files, and
list sweep files. Files can be stored either in the signal generator’s internal storage or on the USB
media. This section provides an overview of how to navigate the signal generator’s file menus, and
how to view, store, load, and move files.

The Agilent MXG and EXG non-volatile internal memory is allocated according to a Microsoft
compatible file allocation table (FAT) file system. Refer to the Programming Guide.

See also: Storing, Loading, and Playing a Waveform Segment on page 132.
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File Softkeys

Catalog
Catalog Tupe

Basic Operation
Working with Files

For details on each key, use key help as described on page 34.

Note: Available file types depend on the installed options.

Display internal or USB
files, depending on the
selected storage media.

(Binaru)”

\)

Delete Filew

Copu File

Deletions require
confirmatipn.
Fename File
Delete ALl
Binary Files™
fore 1 of 2
Catalog Default Storage
nutomatiﬁgélﬁ gse
» edia
EEiED 72 If Present
. Use Onli
Securitur— page 307 Tl BEeraEs
USE File Managerk Uggeﬂggig

Internal/USBE

Specifu Default
p- Storaoe Path fork

Storage Selectionk
(USB if present)

fore 2 of 2

Shows the current directory

5.000 000 O

Media

Cataloo Tupe

ALl

Binary

State

List

User Flatness

fore 1 of 2

page 61

\J
AMPLT

0 00 &Hz

Al

USB(I]irectorg: /NEG uaueFBrms)

File Hame
JE_LIEM
2TOME_HFH
COMAZK_SCHAN_LIFM
COMAZE_PILOT_LFM
EDGE_BURST_HFM
GSM_BURST_HFM
QAM1E_LFH
OPSK_HFM
HCOMA_10PCH_LIFM

Tupe

TUDE

-144.00 den

85.LMB Free
Nodified

01/
o1/
01/11/07
01/11/07
01/11/07
01/11/07
01/11/07
01/11/07
01/11/07

02/24/2012 15:18

Instrument operating paramet

User flatness calibra

Catalog

fore 2

Default Path

Use Current
Directory As
Default Path

Go To
Default Path

reate Directory

Use ask

Copd File tod
Instrument

Up Dir‘ector‘g_

Delete File or
Directory

Create Directory

ARE,
Catalog Tupes

Modulat ion,
Catalog Tupes

Pulze Train

ers (see page 57).

Sweep data from the List Mode Values table editor.

tion corrections.

Tupe page 52

\

Displays 1Q Files

Displays FSK
Files
FIR

/L

Displays FIR
Files

Displays a list of
Pulse Train files.
Bit

/]

Displays Bit
Files

of 2

Available only with USB connected
(i.e. Without external USB connected,

/ softkeys are greyed out).

The signal generator does not
format USB media or change file
permissions. Use a computer to
perform these operations.

The display indicates when the current directory is the default storage path.
For information on setting the default storage path, see page 61.

This key changes, depending on
the selected file. See page 55.

page 56

Available only when the

current directory is not the

top level directory.
Requires

confirmation

fore 1 of 2

——page 56

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message External USB Storage attached. \When you
disconnect the USB media, the message External USB Storage detached displays. When you open the External Media menu without USB media connected, the
signal generator displays the message External Media Not Detected.
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ARB File Softkeys

Waveform files and their associated
marker and header information.

Catalog Tupe frb Catalog Tupe frb Catalog Tupe
Catalon Tupee " BBG Seoments FTEE
Modulation Stored
Catalog Tupes® Seaments
FIR Sequence
Pulse Train Dr1oD Note: Available file types depend on the installed options.
Bit MOMOD
Hore 2 of 2 fore 1 of 2

For details on each key, use key help as described on page 34.

Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to
Auto, as described on page 61.

Viewing a List of Files Stored in the Signal Generator
1. If USB media is connected, disconnect it. The signal generator’s storage media switches to
internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press > Catalog Type > desired catalog (in this example, All). The
selected files appear in alphabetical order by file name, as shown in the following figure.

FREQUEHCY ANPLITUDE Catalog

The selected file catalog and 6.000 000 00 00 GHz - 1 44.00 aBm Eatalog(gﬁ?,

the storage media

Delete Filew

Catalog of\All Files in Int Storage 32kB used 29.2GE free
File Hame Tupe Size Hodified

1 ] B 12/1L/11 1 )
2 802_11AC_1B0MHZ _2560. HFM SHULIFH 10/28/11 13:27 Copy File
3 802 11AC_B0MHZ 2560 HFH ShivlFH . 10/28/11 13:27

g P Fa 268D 02/20/1% 18:60

6 FHFADIO_1.56 HiHKR 381N 10/30/11 19:38 Rename File
7 FHRADIO_15G MylFH 1.L43968  10/30/11 19:19

8 FHRADIO_1 GG HyHOR 173 B 10/30/11 19:38 )

9 FSKIFILE FSk 3L B 11/09/11 11:16 Delete ALL Filese
10 FSKZFILE FSk 34 B 11/09/11 11:16

0272472012 15:44 Hore 1 of 2
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Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which can
display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:

e With the USB media connected, select the desired file catalog: press > Catalog Type >
desired catalog. The selected files appear in alphabetical order by file name.

Using the USB File Manager:

¢ With USB media connected, open the USB File Manager: press File > More > USB File Manager.
The instrument displays the default directory on the USB Media, as shown in the following figure.
Note that when you attach USB media, the display goes directly to this menu.

FREQUEHCY ANPLITUDE USE MNedia
6.000 000 000 00 sz -144.00 e -
Copd File to,
Use the Page Up and [JSB Directory: /NXG waveforns 95.UME Free Instrument
Page Down hardkeys to scroll File Hame Tone size Hodified .
through the contents of the 12 TONE LT 10.EKE 0171107 17:29 Up Directory
2TOME_MFIH S92 B 01/11,/07
COMAZF_SCHAN_WFM 1.25MB  D1/11/07 :
COMAZ2K_PILOT_LFN ELOKB 01/11/07 Delete File or,
EDGE_RURST_WFM 9.3M8 01/11,/07 Directory
GSHM_BURST_HFM 9.34B 01/11,/07
QAMTE_LFHM 20K 01/11/07 17:23 )
QPSK_HFH 320kE 01411707 17: Create Directory
LCOMA_1DPCH_LFH 1.L7MB  D01/11/07
Hore 1 of 2

Storing a File

Several menus enable you to store instrument parameters. For example, you can store instrument
states, lists, and waveforms.

¢ An instrument state file contains instrument settings. For this type of file, use the Save hardkey
shown in Figure 3-8 on page 57.

¢ For other types of data, use the Load/Store softkey (shown below) that is available through the
menu used to create the file.
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File Type Save From

List Sweep menu
State Save menu
Waveform Mode menu

User Flatness ~ Amplitude menu
User Preset User Preset menu
Pulse Train Pulse Train menu

Text Entry

Enter

Load From
Selected File Clear Text

Load/Storer|—e

Store To, Editing Mode
File Ml Feplace

\i

Show Alpha Table
Off

[BCOEFGHIJKLN
HOPORSTUUNXYZ
u_$a8+L1

Use this menu to enter the file name,
as described on page 35.

File Length (including extension)
Internal Media: 25 characters
For details on each key, use key help as described on page 34. USB Media: 39 characters
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Loading (Recalling) a Stored File

There are several ways to load (recall) a stored file.

Basic Operation
Working with Files

¢ For an instrument state file, use the Recall hardkey shown in Figure 3-8 on page 57.

* For other types of data, use the Load/Store softkey (shown below) that is available through the
menu used to create the file.

Load fStor‘eb}—b

Loading a File From USB Media

To load a file from USB media, use the USB file manager shown below.

File > Catalog Type > <type> > More > USB File Manager

or

File > More > USB File Manager

or

Insert the USB media

USB Nedia

Enter Directory

Copy File to
Instrument

Delete File or
Directory

Create Directory

fore 1 of 2

For details on each key, use key help as described on page 34.

This key changes, depending
on the selected file.

Load From
Selected File

Confirm Load

Confirm Load
From File

Store To,
File

Eile Type Recall From
List Sweep menu
State Save menu
Waveform Mode menu

User Flatness
User Preset
Pulse Train

Amplitude menu
User Preset menu
Pulse Train menu

Copy & Select User Flatness
Copy & Play Waveform
Copy & Play Sequence
Enter Directory

Recall Instrument State
Load List

Load Pulse Train

Install licenses

N tion (USB disconnected)

File Type Extension  Pressing Select with file highlighted...
List list loads list and starts sweep
State .state load instrument state
Waveform .waveform loads and plays waveform
User Flatness .uflat loads and applies user flatness
User Preset .uprst loads and executes user preset
License lic installs purchased license
Pulse Train .ptrain loads and applies pulse train
Use File Use File Use File

Load Sweep List

Recall State

Copy & Select
User Flatness
Corrections

Copy & Play
Haveform

Copy & Play
Sequence

fore 1 of 2

If the signal generator does not recognize the file,

you must select how the file is to be used.

Load Pulse Train
Load Filter
Load Multi-Tone
Load DigHod

Load
Multi-Carrier
OigHod

fore 2 of 3

—»

Load Pulse Train
Load Filter
Load Multi-Tone
Load DigHod

Load
Multi-Carrier
OigHod

fore 2 of 3
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Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

File > Catalog Type > <type> > More > USB File Manager

or

File > More > USB File Manager

or

Insert the USB Flash Drive (UFD)

USB Nedia

Enter Directory |

This key changes,
depending on the selected
file. See page 55

Whether a menu is available

Selecting a waveform or
an unknown file type
displays this softkey.

Copd File to,
Instrument

Copy File to [\
Instrument |/

Oelete File or,
Directory™]

Create Directory

fore 1 of 2

depends on the selected file.

Moves up one directory level

Requires confirmation

USB Nedia

Catalog

Catalog Tupe,
(Binarul

Select
Internal Filel(sisl———p

to Copy to USE

Copd File to,
Instrument

If the file type is recognized
the “Filename.xxx copied
to Internal Storage” is
displayed.

Catalog Type Menu
page 51

Copu ALl Filese

Oelete ALl Files,
in Current Dir

fore 2 of 2

Requires confirmation

These softkeys are
only available on
vector models with
BBG.

p Copu All Files

Internal Storage
to USE

USE to
Internal Storage

USE
to BEG Memory

For details on each key, use key help as described on page 34.

Copy File As

Sweep List

Instrument State

User Flatness
Corrections

Sequence

fore 1 of 3

Copy File As

Pulze Train

Filter

Multi-Tone Setup

Dighod Setup

Multi-Carrier
Dighod Setup

fore 2 of 3

Copy File As

I0 Definition

FSK Definition

Data Bit File

Have forme

EBG Memory

Internal Storage

hese softkeys are only
available on vector
models with BBG.
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Working with Instrument State Files

Saving an Instrument State on page 58

Saving a User Preset on page 58

Recalling an Instrument State on page 58

Basic Operation
Working with Files

Recalling an Instrument State and Associated Waveform File on page 59

Recalling an Instrument State and Associated List File on page 59

Moving or Copying a Stored Instrument State on page 60

Figure 3-8 Save and Recall Softkeys

Save State
SAVE
Seql1] RegCO0]

Select Reg:
(available) 00

Select Seqi

fore 1 of 2

Save State
Select Seqi

Oelete ALl
Fegs in SeqC1]

Oelete AL,
Sequences

For details on each key, use key help

as described on page 34.

Recall State
RECALL
Seql1] Reol—-1

Select Reo:

Select Seqi

Oelete ALl
Fegs in SeqC1]

fore 1 of 2

Recall State

Oelete AL,
Sequences

Auto Recalle

The following information is not stored in a state file:

System Security Level

System Security Level Display
System Security Level State
Web Server (HTTP)

Sockets SCPI (TELNET)

Sweep lists

Display State On/Off

Files

Pulse Train lists

Hostname

IP Address

Default Gateway

1/Q Calibration Data

Subnet Mask

When saved to the signal generator, instrument settings
(states) save to instrument state memory*. Instrument
state memory is divided into 10 sequences (0 through 9);
each sequence comprises 100 registers (00 through 99).

Delete softkeys in the Save and Recall menus enable you
to delete the contents of a specific register, or the contents
of all sequences in the state file catalog.

The signal generator requires that you confirm a deletion.

*Caution

To avoid the loss of data, GPIB settings, or current user
instrument states that have not been permanently saved
to non-volatile memory, the instrument should always be
powered down either via the instrument's front panel
power button or the appropriate SCPl command.
instrument's installed in rack systems and powered down
with the system rack power switch, rather than the
instrument's front panel switch display a Error -310 due to
the instrument not being powered down correctly.

Remote Language Step increment values

FTP Server ARB Files
Manual DHCP MAC
VXI-11 SCPI User Power Correction
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Saving an Instrument State

1.

Preset the signal generator and set the following:
¢ Frequency: 800 MHz ¢ Amplitude: 0 dBm ¢ RF: on
(Optional, vector models only) Associate a waveform file with these settings:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first
move it from internal or external media to BBG media, see page 132.

Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > Enter.
Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg.

If a waveform is currently selected, saving the instrument state also saves a pointer to the
waveform file name.

Add a descriptive comment to sequence 1 register 01:

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment appears in
the Saved States list when you press Recall. If the instrument state has an associated waveform,
entering the waveform name in the comment makes it easy to identify which instrument state
applies to which waveform.

Saving a User Preset

A user preset is a special type of instrument state file.

1.
2.

Preset the signal generator and set as desired.
Press User Preset > Save User Preset.

This saves a state file named USER_PRESET, which the signal generator recognizes as containing
user preset information.

You can set up several preset conditions under different names:

1.
2.
3.

After you save a user preset, rename it to something other than USER_PRESET (see page 60).
Save as many user presets as you wish, renaming the USER_PRESET file each time.
Give the desired file the name USER_PRESET.

Recalling an Instrument State

1. Preset the signal generator.
2. Press Recall.
The Select Seq softkey shows the last sequence used, and the display lists any states stored in the
registers in that sequence; RECALL Reg is the active entry.
3. Select the desired instrument state:
If the desired state is listed in the currently selected sequence, press desired number > Enter.
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > Enter.
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Recalling an Instrument State and Associated Waveform File
1. Ensure that the desired waveform file exists, and that it is in BBG media (page 132).

If the waveform file is not in BBG media, this procedure generates an error.

Recalling an instrument state with an associated waveform file recalls only the waveform name. It
does not recreate the waveform file if it was deleted, or load the file into BBG media if it is in
internal or USB media.

Recall the desired instrument state (see previous example).
3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.
The name is displayed as the selected waveform.

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Recalling an Instrument State and Associated List File

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency
and/or amplitude values. Because you must load the list file from the file catalog, when you store a
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).
2. Load the desired list file:
a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key. This
is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].
4. Press Re-SAVE Seq[n] Reg[nn].

This overwrites previously saved instrument state settings with the new comment.
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Moving or Copying a Stored Instrument State

Figure 3-9 Instrument State File Catalog

l Sequence Register

FREQUEHCY

6.000

ANPLITUDE

-144.00 den

Catalog

000 000 00 s+

Catalog Tupe,
(State)

Delete Filew

Catalog of /State Files in Int Storage 32kB used 29.2GE free
F me Tupe Size Nodified
1 NN BlE B 12/1L/11 11:1k )
2 PERSISTENT STATE 2.L3kE 02/2L/12 18:06 Copy File

3 USER_PRESET STATE 601 B 02/2L4712 17:55

Fename File

Oelete All,
State Files

02/25/2012 12:15 Hore 1 of 2

The signal generator recognizes only the file named USER_PRESET as user preset information (page 58).

A user-created state file’s default name is its memory location (sequence and register).

To move the file, rename it to the desired sequence and register; you can not give a file the same
name as an existing file. If you rename a state file to something other than a valid sequence/register
name, the file does not appear in either the Save or Recall menu.
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Selecting the Default Storage Media

Basic Operation
Working with Files

You can configure the signal generator to store user files to either the internal storage or to external
USB media. To automatically switch between USB media and internal storage, depending on whether
USB media is attached, select Automatically Use USB Media If Present. To avoid storing any confidential

information in the instrument, select Use Only USB Media. To avoid storing any confidential information
to USB media, select Use Only Internal Storage.

This selection is unaffected by power—cycle or preset.

File > More >

Current
selection

Catalog

Goto FRowe

Securitue

USE File Managere

Internal/USBE

Storage SelectionM
USE if present)

— | Default Storage

fore 2 of 2

Automatically Use
USB Medi +

Nedia
If Present

This is the recommended selection. When USB media is attached to the
front panel, it is the selected media; when USB media is not attached,
internal storage is used.

nly | Memory in the instrument is used, and USB media is ignored.

Use 0O
Internal Storage

Use Only

USE Media \Media attached to the front panel USB connector is used, and no user

Specifu Default
Storage Path fore
USE M

data is stored to internal storage.

edia |~ Select the directory on the USB media to be used for all file operations

when USB media is attached and enabled.

For details on each key, use key help as described on page 34.
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Reading Error Messages

If an error condition occurs, the signal generator reports it to both the front panel display error
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed
separately; for information on the SCPI error queue, refer to the Programming Guide.

Characteristic Front Panel Display Error Queue
Capacity (#errors) 30
Overflow Handling Drops the oldest error as each new error comes in.
Viewing Entries Press: Error > View Next (or Previous) Error Page
Clearing the Queue Press: Error > Clear Error Queue(s)
Unresolved Errors® Re-reported after queue is cleared.
When the queue is empty (every error in the queue has been read, or the queue is cleared), the
No Errors following message appears in the queue:
No Error Message (s) in Queue 0of O

@Errors that must be resolved. For example, unlock.

Error Message Format Error Description
Error Number Error Message (May be truncated on the
-
R
—222 Data out of range; value clipped to lower limit.

Indicates that the user has entered a deviation, depth, or internal
source frequency that is beyond the specific limits

‘¥ \/___//
Explanation is provided in the Error Message file (see page 316)
(This is not displayed on the instrument)

The annunciator indicates an unviewed message.

new indicates a message generated
since messages were last viewed.

Modulation Status Information Error
Hod State Depth/Dev Source Rate Uavefo J
Fn on 1.0000KHZ Internal LO0. OHz Sine ” Message number and longer description

Yiew Prewious
Error Page

View Next

Error_Queue .4 \J Error Fage

» Settings conflict; Enabled modulation source conflicts (neu)
ulthngreumuslu enabled modulation source. Previous modulation 1 of 1
disanle

Clear
Error Quele(s)

Error messages appear in the lower left corner
of the display as they occur.

[##= PROTO_CODE == NOT FOR CUSTOMER USE #ws 0L /0B/2006 10017 |
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4 Using Analog Modulation (Option UNT)

NOTE The Mod On/Off hardkey and LED functionality are only valid for signal generators with
Option UNT installed.

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that
chapter.

¢ Using an Internal Modulation Source on page 66

¢ Using an External Modulation Source on page 67

¢ Removing a DC Offset on page 67

¢ Using Wideband AM on page 67

¢ Configuring the LF Output (Option 303) on page 69
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Analog Modulation Waveforms

Analog Modulation Waveforms

The signal generator can modulate the RF carrier with four types of analog modulation: amplitude,
frequency, phase, and pulse. For pulse modulation information, refer to Chapter 6, “Using Pulse
Modulation (Option UNW or 320),” on page 113.

Available internal waveforms include:

Sine
Triangle
Square
Pos Ramp
Neg Ramp

sine wave with adjustable amplitude and frequency

triangle wave with adjustable amplitude and frequency
square wave with adjustable amplitude and frequency
positive going ramp with adjustable amplitude and frequency

negative going ramp with adjustable amplitude and frequency

Analog Modulation Sources

The signal generator provides the following internal and external modulation input sources. Internal
modulation sources generate the five waveforms listed above unless noted otherwise.

Extl & Ext2

Func Gen 1

Func Gen 2

Dual Func Gen

Swept Func Gen

Noise Gen 1 & 2

an externally applied signal is used as the modulation input. Connect the signal to
the EXT 1 or EXT 2 connector on the rear panel of the instrument.

sine wave from the internal function generator. Instruments with Option 303 have
additional waveform choices listed above.

Func Gen 2 has the same capability as Func Gen 1. Available on instruments with
Option 303.

dual waveforms with individually adjustable frequencies and a percent- of-
peak-amplitude setting for the second tone. Available on instruments with Option
303.

swept waveforms with adjustable start and stop frequencies, sweep time, and
sweep trigger settings. Available on instruments with Option 303.

noise with adjustable amplitude generated as a peak-to-peak value (RMS value is
approximately 80% of the displayed value). Uniform and Gaussian distribution is
available. Available on instruements with Option 303.
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Using Analog Modulation (Option UNT)
Analog Modulation Sources

Figure 4-1 Analog Modulation Softkeys

FM/ FM/
oM oM

An FR/TH Fri/on
Al Tupe @ F1
[l E-F High BH
Al Path FI1 Path #11_Path
1 [EE] 2 2
1 FH Ll
an an On
A Oepth 4 page 67 FM Dew |— page 67 P Dew | page 67
0.1 4 pag 1.0000 kHz pag 0.000 rad pag
A Source M Source M Source
(Func Gen 13* (Func Gen 13* (Func Gen 13*
fore 1 of 2 —1 fore 1 of 2 —1 fore 1 of 2 —1
;1] FHA®A FH/on
Setup AM Sourcee Setup FM Sourcee Setup @M Sourcee
For details on
eachkey,Use | n pepth Couple FM Dey Couple @M Dey Couple
NI On an [ay]
A Hode
Morma 1
fore 2 of 2 HMore 2 of 2 fore 2 of 2
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Using an Internal Modulation Source

Using an Internal Modulation Source

1. Preset the signal generator.

2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4

Configure the modulation:

AM

FM

oM

a. Press AM

b. Set the AM type (Linear or Exponential):

AM Type to highlight desired type.
c. Set the AM Mode (Normal or Deep).

Default is Deep. To select Normal enable

More to highlight desired type.
d. Set the AM Depth:
Default 0.01%

Range 0.01 to 100%

e. Set the rate:

More > Setup AM Source > AM Rate > value

> frequency umnit

5. Turn on the modulation:

AM

AM Depth > value

a. Press FM/®M

b. Set the deviation:
FM Dev > value > frequency unit

c. Set the rate:
More > Setup FM Source > FM Rate >
value > frequency unit

FM

a. Press FM/®M > FM ®M

b. Set the BW (normal or high):
FM ®M to highlight desired type

c. Set the deviation:
®M Dev > value > pirad

d. Set the rate:
More > Setup ®M Source > ®M Rate >
value > frequency unit

oM

AM Off On softkey to On

FM Off On softkey to On

OM 0ff On softkey to On

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output”

on page 310.

See also “Modulating the Carrier Signal” on page 48.
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Using an External Modulation Source

Using an External Modulation Source

Currently selected

FNl Source
Extl
Source
(Func Gen 13
Ext2 S
Default ouice
Func Gen 1 Swept. Func Gen i fioise
Noise Gen 1,1 Uniform
Fune Gen 2 (Uniform™] >
Oual Func Gen No%ﬁe_%en %b Gaussian
Rear panel inputs are niform
described on page 12 Hore 1 of 2 -
r—.------. x )
ﬁ..... » o é o
= DAC CLK
1out aout ' aouv aemm BBTRIG2  EVENT1 DIGITAL BUS /0 C AUX /0 =L wwwm ‘ =
LF ouT. swz(vouro PULSE e = REFIN 10MHz our@ us__GPiB 2201240V 50/60Hz

1) )01 cmom S5
so® : — . ”3935%“3=....

AM, FM or ®M inputs

Removing a DC Offset

To eliminate an offset in an externally applied FM or ®M signal, perform a DCFM or DCOM
Calibration.

NOTE You can perform this calibration for internally generated signals, but DC offset is not usually
a characteristic of an internally generated signal.

1. Set up and turn on the desired modulation.
2. Press FM/®M > FM Source > Ext1 or Ext2 > More > Setup FM Source > Ext DC Cal.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal,
and the applied DC level becomes the new zero reference point. When you disconnect the DC signal,
perform the calibration again to reset the carrier to the correct zero reference.

Using Wideband AM

Wideband AM uses the I input of the I/Q modulation system. When the wideband AM is turned on,
the I/Q is turned on and the I/Q source is set to external. If the I/Q is turned off or the I/Q source
is set to internal, then the wideband AM turns off.
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Using an External Modulation Source

NOTE For frequencies between 9kHz and 5 MHz, Wideband AM turns off.

Figure 4-2 Wideband AM Softkey Menu

AM > AM Path 1 2 WB

l

FREQUEHCY

Analog Modulation Status Information

A1 FuncGenl Oepth:d. 13

ANUB I Input Depth:0.5U=100%
FAL ExtZ OC Devw: 1.0000kHz
Fr2 FuncGenl Dew:1.0000kHz
@MiHEN  Ext1l OC Dew:0.000rad
PHM2HEN  FuncGenl Dev:0.000rad

LFOut  IntHonitor Ampl:0. 0004

ANPLITUDE

6.000 000 000 00 &z -144.00 cen
[An] [L/0]

Wfm:Sine ko0, 0Hz)
Wfm:Sine ko0, 0Hz)

Imp:50 Ohm
Wfm:Sine ko0, 0Hz)
Imp:50 Ohm
Hfm:Sine koo, 0Hz)
FMonitored:FuncGenl

02/25/2012 14

125

;11
Enables and disables the
A Path wideband AM feature.
12 —Note: If the 1/Q is turned
off or the 1/Q source is set
AN to internal, then the
off wideband AM turns off.

For details on each key, use key help
as described on page 34.

Setting the Wideband AM

When the Wideband
active.

1. Set up and enable the desired modulation type.
2. Press AM > AM Path12WB to WB.

AM is enabled, these fields are
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Configuring the LF Qutput (Option 303)

The signal generator has a low frequency (LF) output. The LF output’s source can be switched
between an internal modulation source or an internal function generator.

Using internal modulation (Int Monitor) as the LF output source, the LF output provides a replica of
the signal from the internal source that is being used to modulate the RF output. The specific
modulation parameters for this signal are configured through the AM, FM, or ®M menus. The internal
source (AM, FM, or ®M) must be configured for the LF Out to provide a signal.

Using function generator as the LF output source, the function generator section of the internal
modulation source drives the LF output directly. Frequency and waveform are configured from the LF
output menu, not through the AM, FM, or ®M menus. You can select the waveform shape from the
following choices:

Available internal waveforms include:

Sine sine wave with adjustable amplitude and frequency

Triangle triangle wave with adjustable amplitude and frequency
Square square wave with adjustable amplitude and frequency

Pos Ramp positive going ramp with adjustable amplitude and frequency
Neg Ramp negative going ramp with adjustable amplitude and frequency
Pulse pulse with adjustable period and width

LF Out Modulation Sources

The signal generator provides the following modulation input sources. Internal modulation sources
generate the five waveforms listed above unless noted otherwise.

Int Monitor uses AM, FM or ®M settings.
Func Gen 1 waveforms from the internal function generator
Func Gen 2 waveforms from the internal function generator

Dual Func Gen dual waveforms with individually adjustable frequencies and a percent- of-
peak-amplitude setting for the second tone. Available on instruments with Option
303.

Swept Func Gen swept waveforms with adjustable start and stop frequencies, sweep time, and
sweep trigger settings. Available on instruments with Option 303.

Noise Gen 1 & 2 noise with adjustable amplitude generated as a peak-to-peak value (RMS value is
approximately 80% of the displayed value). Uniform and Gaussian distribution is
available. Available on instruements with Option 303.

DC selects a DC voltage level as the LF output BNC source

NOTE The LF Out Off On softkey controls the operating state of the LF output. However when the LF
output source selection is Int Monitor, you have three ways of controlling the output. You can
use the modulation source (AM, FM, or ®M) on/off key, the LF output on/off key, or the Mod
On/Off softkey.
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Configuring the LF Output (Option 303)

The RF On/0ff hardkey does not apply to the LF OUTPUT connector.

Configuring the LF Output with an Internal Modulation Source

In this example, the internal FM modulation is the LF output source. See Figure 4-3.

NOTE

Internal modulation (Int Monitor) is the default LF output source.

Configuring the Internal Modulation as the LF Output Source

You have
activated

1
2
3.
4
5

Press Preset.

Press the FM/®M hardkey.

Press FM Dev > 75 > kHz.

Press More > Setup FM Source > FM Rate > 10 > kHz.
Press Return> Return > FM Off On.

set up the FM signal with a rate of 10 kHz and 75 kHz of deviation. The FM annunciator is
indicating that you have enabled frequency modulation.

Configuring the Low Frequency OQutput

1.

Press the LF Out hardkey.

2. Press LF Out Amplitude > 3 > V.
3. Press LF Qut Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is
frequency modulated using the Int Monitor source selection (default source).

Figure 4-3 Configure the LF Out Source with FM

FM and LF annuciators indicate Frequency Modulation is the LF Out source

FREQUEHCY

6.000 000 0' ' ' ' BHz

anota: 3.000 V

RF_OFF

Incr: 500.0my
Analog Modulation Status Information
Arl FuncGenl Depth:0. 1 Hfm:Sine ko0, 0Hz)
A2 FuncGenl Depth:0. 12 Hfm:Sine koo, 0Hz)
AMLE I Tnput Oepth: 0. Sv=100:
FH1 FuncGenl Dev:75. 0000kHz Hfm:Sine(10.0000kHz)
FHZ FuncGenl Oewv: 1. 0000kHz Hfm:51ine (LOO.OHZ)
Bl FuncGenl Dev:0.000rad Wfm:Sine ko0, 0Hz)
[rilulel FuncGeni Oey 0. 000rad Lifm:Sine(L00.OH=2
LFOut  IntHAonitor Ampl :3. 000V Monitored :FuncGenl

N FM Modulation as the LF Out Source

OL4/07/2012 15:16

LF Out using the Int Monitor source (default selection). For details on each key, use key help
as described on page 34.

70

Agilent MXG and EXG X-Series Signal Generators User’'s Guide



Using Analog Modulation (Option UNT)
Configuring the LF Output (Option 303)

Configuring the LF Qutput with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Qutput Source
1. Press Preset.

2. Press the LF Out hardkey.

3. Press LF Qut Source > Func Gen 1.

Configuring the Waveform
1. Press Setup LF Out Source > LF Qut Waveform > Sine.

2. Press LF Out Freq > 500 > Hz.
3. Press Return.

This returns you to the top LF Output menu.

Configuring the Low Frequency Qutput
1. Press LF Out Amplitude > 3 > V.

This sets the LF output amplitude to 3 V.
2. Press LF Qut Off On.

Figure 4-4 shows that the LF output is now transmitting a signal using the function generator that is
providing a 3 V sine waveform.

Figure 4-4 LF QOut Status Display

LF Out annunciator

6.000 000 000 00 &z
it Frea: D00.0 Hz Incr: 500.0Hz
Analog Modulation Status Information
Arl FuncGenl Depth:0. 1 Hfm:Sine ko0, 0Hz)
A2 FuncGenl Depth:0. 12 Hfm:Sine koo, 0Hz)
ArHE I Input Depth:0.5v=100%
Fri FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz)
Fr2 FuncGenl Dew:1.0000kHz Wfm:Sine ko0, 0Hz)
1 FuncGenl Dens:0.000rad Hfm: Sine(LO0.0Hz)
LFOut  FuncGenl Ampl :3. 000V _ Hfm:Sine(500.0Hz)
.
N
o~ 0L /0772012 15:01

For details on each key, use key help

LF Out configuration as described on page 34.
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Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that
chapter.

Using the Dual Power Meter Display on page 74

Using Flatness Correction on page 82

Using Internal Channel Correction on page 91

Using External Leveling on page 93

Using Unleveled Operating Modes on page 101

Using an Output Offset, Reference, or Multiplier on page 104
Using Free Run, Step Dwell, and Timer Trigger on page 108
Using a USB Keyboard on page 111
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Using the Dual Power Meter Display

The dual power meter display can be used to display the current frequency and power of either one
or two power sensors. The display outputs the current frequency and power measured by the power
sensors in the larger center display and in the upper right corner of the display. Refer to Figure 5-2,
Figure 5-2, and Figure 5-3.

Figure 5-1 Dual Power Meter Display with Power Sensors A and B Calibrated

Once turned on, the
ChA:-BE.4LE dBm L _power meter
dBm ChB:-49.31 dBm EB??“ readings are always
B visible, even if
another instrument
’ Chanoel A, feature is selected
Perter Meter Heasurements Setup gig.)Sweep, AM,
Channel B
ChA (usB: myu7u0013) ChB (sck: 1u1.121.92.70) oFf
Hg%g:: Hg%g:: This area is the main
Channel El. display for the dual
Setup power meter
_61.40 dBm _48,64 dBm calibration frequency
and current power
N
[SS8.000 Hz 50.000 MHz [~measured.
2872012 17:43

If channel A or
channel B power
sensors or both are
displayed, and the
AMPTD or the FREQ
softkeys are pressed,
the large power
meter measurements
remains displayed.

After the first
connection, if the
connection is
successful, the
model number and
’ ’ serial number of the
For details on each key, use key help as described on page 34. power sensor is
displayed.
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Figure 5-2 Dual Power Meter Display Menu

.—> Auxiliary
Fouer Meter,

FREQUEHCY

Measurements™

6.000 000 000 00 &+

Pouer Heter Measurements

ANPLITUDE

-20.00 den

02/23/2012 12:23

Pouer Heter

Channel A
| Off i

Chanoel A,
Setup

Channel B
| Off i

Channel B,
Setup
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Enables the power sensor on
channel A.

See
[—page 76

Enables the power sensor on
[ channel B.

Channel B is configured similarly to
[ channel A. See page 76

For details on each key, use key help

as described on page 34.
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Figure 5-3 Configuring the Power Sensor Channels

AUX Fctn > Power Meter
Measurements

Pouer Heter Channel A Setup
Chanmel A Connect ion,
an Settings ™
Chanoel A, Channel

Setup Settinos
Channel B
]
Ehangg%ugb Zero Sensor
Calibrate Sensor
USB U2000A Series Power

Sensors do not require the
sensor to be calibrated.

—

ChA Settinos

External Pouer
Meter Channel
ElE

The MXG/EXG use the
USB U2000A Series Power
Sensor’s “Internal” zero.
Refer to the USB U2000A
Series Power Sensor’s
documentation. Channel Freguency
Settings

Zero Sensor and Calibrate
Sensor softkeys are
inactive during a
measurement.

Channel Offset
0.000

i Enables averaging. Instrument
B aa Ny —jefault is Auto with 1024 points.

Measurement.
Units
| dEm i

ChA Connection

Connmection Tupe,
(50

Fouer Meter

Note: This figure illustrates channel A; channel B is similar.

—— Connection Tupe

ckets) Enables the power meter
connection type: Sockets

LAN, VXI-11 LAN, or USB.

IF Address
Note: The VXI-11 softkey is
Fouer Meter used to communicate
IP EBE% remotely with a power meter

Selects the channel on the
| _external power meter that the
power sensor is connected to.

| Selects the frequency that channel
A has been calibrated to.

| __Enables a power offset in dB for
dB the current channel.

Connection Tupe

For details on each key, use key help as
described on page 34.

that has a GPIB connector
via LAN-GPIB gateway.

Sockets LAN: Sets the
IP port to 5025 (standard)
or 5023 (telnet)
programming.

Sockets
Sets the power meter’s IP
ddress or LAN-GPIB
YHI-141 gateway’s IP address (Sockets PDHBEPHEtBE
LAN and VXI-11 LAN only). CheE
Whether a softkey is available
Use
depends -on the selected PH UHI-11
Connection Type. Device Mame
opib0,13

VXI-11 LAN: Opens a
menu for entering a
device name for the
power meter being used.
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Example: Dual Power Meter Calibration

In the following example a U2004A USB Power Sensor is connected to channel A and a N1912A
P-Series Power Meter and 8482A Power Sensor are connected to channel B and are zeroed and
calibrated, as required.

On the signal generator:

1. Setup for Step Sweep. “Configuring a Swept Output” on page 40.

CAUTION Verify RF Output power is off before continuing.

2. Connecting the Channel A power sensor: Connect USB sensor to the signal generator. The
MXG/EXG should display a message across the bottom that reads similar to:
USB TMC488 device (USB POWER SENSOR,MY47400143) connected

Figure 5-4 MXG/EXG Displays Connection to U2000 USB Power Sensor
FREQUEHCY

6.000 000 000 00 &z

‘USB THCL88 device (USB POUER SEHSOR.NYL7L00143) connected | >

3. Press Aux Fctn > Power Meter Measurements > Channel A Setup > Connection Settings > Connection Type >
USB Device (None) > USB POWER SENSOR (MY47400143)

4. Press Return > Zero Sensor

A diagnostic dialog box appears the initial time that a U2000 Series power sensor with a
different serial number is connected to the signal generator (refer to Figure 5-5). After the U2000
has been recognized by the signal generator, the U2000 power sensor is saved as a softkey in the
instrument and the dialog box in Figure 5-5 won’t be displayed (press DONE, if you see this
message).

Figure 5-5 Diagnostic Dialog Box for USB Sensor

| Dimgnostic Dialog

Verifu That the sensor is connected to the Power Meter
Reference or the MXG RF Out

Agilent MXG and EXG X-Series Signal Generators User’'s Guide 71



Optimizing Performance
Using the Dual Power Meter Display

A Running Calibration(s) bar is displayed on the signal generator. Refer to Figure 5-6 on
page 78.

Figure 5-6 Running Calibration(s) Bar (Zeroing Sensor)

6.000 000 000 00 &=

RF_OFF

Pouer Heter Measurements

Running Calibration¢s)
S0% complete

|
For details on
each key, use key
help as described
1 on page 34.
NOTE The U2000 Series USB Power Sensor, does not require a 50 MHz calibration. If a

calibration is attempted with the U2000 Series Power Sensors, the signal generator
displays a message reading:

The U2000 series power sensor does not require a 50 MHz calibration. Refer to
Figure 5-7 on page 78.

Figure 5-7 Diagnostic Dialog Box Displayed for U2000 Power Sensor

B 00N N0 0NN NN cxz

: Dimgnostic Dialog
Pouel

The U2000 series power sensor does not require a 50 MHz oK
calibration

For details on

each key, use key

| help as described
on page 34.

5. Press Return > Return > Channel A to On

The current power meter sensor reading should be displayed in the ChA portion of the
instrument's display and in the upper right portion of the display under Power Meter. Refer to
Figure 5-8.
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Figure 5-8 Channel A Power Sensor Displayed on MXG/EXG

[RF_OFF | /POYER NETER | Payer feter /7
6.000 000 000 00 aHz b G

Chanoel Ay
Setup

Pouer Heter Measurements

Channel B

A cusB: nMyL7LODIL3) &

-69.81 dBm

50.000 MHz
help as described

\ ‘( on page 34.

6. On the N1912A P-Series Power Meter (Channel B power sensor): Connect the N1912A P-Series
Power Meter to the LAN.

7. Connect the power meter sensor to channel B of the power meter.

Channel B,
Setup

For details on

NOTE It is recommended, but not required to use the channel B on the N1912A. This provides
continuity with the signal generator’s dual display. For this example, the U2004A has
already used up the channel A position on the signal generator.

8. Connect the power sensor input to the 50 MHz reference of the power meter.
9. Press Channel B Setup

10. Press Connection Settings > Sockets

11. Press IP Address > IP address > Enter

NOTE The IP address of the power meter should be displayed in the ChB section of the display.

Figure 5-9 Channel B Power Sensor with IP Address Entered

RF_OFF_|/POUER NETER

ChA:—69.81 dEm Channel A

0ff iGN

6.000 000 000 00 &z

Chanoel Ay
Pouer Heter Measurements Setup

L —
ChA (usB: MyL7u001L3) ( R

Channel B,
-69.81 dBm et
50.000 MHz For details on
each key, use key
Ol 02‘2008 15:L8 help as described
on page 34.

12. Press Return > Channel Settings > External Power Meter Channel to B.
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13. On the signal generator: Press Channel B to On and then back to Off again. This initializes the
signal generator to the external power meter.

14. Press Return > Zero Sensor

A diagnostic dialog box is displayed each time an external power meter is being used and the
Zero Sensor or Calibrate Sensor softkey is pressed (refer to Figure 5-10 on page 80).

Verify the power sensor is connected to the 50 MHz reference of the power meter.

Figure 5-10 Diagnostic Dialog Box for Channel B

FREQUEHCY

RF_OFF |/POUER NETER

40.000 000 000 00 &Hz ENA: -60.80 dEm
: Dimgnostic Dialog
Pouer —

[: Werifu That the sensor is conmected to the Power Meter N

Reference or the MXG RF Out

For details on
each key, use key
50.000 MHz help as described
on page 34.

15. Press Done
The Running Calibration(s) bar is displayed: Zeroing Sensor Please wait....
16. After Running Calibration(s) bar disappears: Press Calibrate Sensor
Diagnostic Dialog box is displayed that prompts for verifying the connection of the power sensor

to the power meter 50 MHz reference (refer to Figure 5-11 on page 80).

Figure 5-11 Diagnostic Dialog Box for Calibration

RF_OFF

40 00N NNn 0NN NN - exz

: Dimgnostic Dialog
Pouel

Verifu That the sensor is connected to the Power Meter DOME
Reference or the MXG RF Out

For details on
each key, use key

T . help as described
on page 34.
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17. Press Done

Calibration progress bar is displayed. Refer to Figure 5-12 on page 81.

Figure 5-12 Running Calibration(s) Bar (Calibrating Sensor)

"**%0.000 000 000 00 sz | - 20.00 (.

Pouer Heter Measurements

Running Calibration¢s)
S0% complete
I

For details on
each key, use key
help as described
on page 34.

18. Press Return > Channel B to On

19. The current power meter sensor reading should be displayed on the signal generator in the ChB
portion of the display and in the upper right corner of the display under Power Meter and to the
left of the Power Meter power sensor reading.

Figure 5-13 Channel B Power Sensor Displayed on MXG/EXG

FREQUEHCY

40.000 000 000 00 &Hz

RE_OFF _|/POUER NETER | Pouer leter 7
Channel &
P OFf

D=l CET
ChE:-43.31 dEm

Chanoel Ay
Pouer Heter Measurements Setup
L, —
ChA cusB: nyu7u001L3) ChB ¢stk: 1u1.121.92.70) (_ Epnal B )
Channel B,
eLup

-61.40 dBm -48.64 dBm Sl —

each key, use key
50.000 MHz 5 H= help as described
5 on page 34.

20. The power sensors are now ready to be connected in a measurement setup.
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Using Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601
sequential linearly or arbitrarily spaced frequency points to compensate for external losses in cables,
switches, or other devices. Using an Agilent N1911A/12A, E4419A/B, or U2000 Series power
meter/sensor to calibrate the measurement system, a table of power level corrections can
automatically be created for frequencies where power level variations or losses occur. Supported
connection types to the power meter/sensor are Sockets LAN, VXI-11 LAN, USB, and GPIB via
VXI-11 LAN using a LAN-GPIB gateway (e.g. Eb810A Gateway or equivalent).

NOTE A power meter with GPIB requires using the Connection Type VXI-11 softkey, as well as a
LAN-GPIB gateway, to control a power meter. Refer to the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009), Agilent X-Series FAQs “How do I connect
to the LAN?”, and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device.

If you do not have an Agilent N1911A/12A or E4419A/B power meter, or U2000A/01A/02A/04A
power sensor, or if your power meter does not have a LAN, GPIB, or USB interface, the correction
values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may
save individual user flatness correction tables to the signal generator’s memory catalog and recall
them on demand.

Follow the steps in the next sections to create and apply user flatness correction to the signal
generator’s RF output (see page 86).

Afterward, follow the steps in “Recalling and Applying a User Flatness Correction Array” on page 90
to recall a user flatness file from the memory catalog and apply it to the signal generator’s RF
output.
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Figure 5-14 User Flatness Correction Softkeys
For details on each key, use key help

m as described on page 34.

Amplitude Amplitude — User Flatness
Atten/ALC pmetd Ref Set Flatness
Control® 060 dEm on
ALC Amptd Ref Conf ioure
oFf iz Cal Arrag®
Starts the
Amptd Offset Do Cal |——user
.00 (&3 flatness
— calibration.
onf igure
User Flatnesse Power Heter® See
page 86 User Flatness
Leveling, Output Blankin
Control Off 0O mﬂ Freq Start
n 5. 00000000000GH=
Hore 1 of 3 __ | 5 Hore 2 of 3
Freg Stop
Y . 00000000000GHz
FREQUEHCY AAPLITUDE User Flatness # Points
2
6.000 000 000 00 &=z -144.00 aen Edit. Ttem
Inzert Row
User Flatness: (UNSTORED) _—
Frequency Correction User Flatness
1 Undef ined ;
Conf igure
2 Delete Rou Step Arrag”]
Goto Rowe Load Cal Array
HhD RO From Step Arrad
Load/Stares Preset Lists——Confirm
0272572012 15:50 Hore 1 of 2 »
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Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array
contains ten frequency correction pairs (amplitude correction values for each specified frequency),
from 500 MHz to 1 GHz.

An Agilent N1911A/12A or E4419A/B power meter and E4413A power sensor are used to measure
the RF output amplitude at the specified correction frequencies and transfer the results to the signal
generator. (A U2000 Series power meter/sensor could be used in lieu of the power meter and E4413A
power sensor.) The signal generator reads the power level data from the power meter, calculates the
correction values, and stores the correction pairs in the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a LAN,
GPIB, or USB interface, you can enter correction values manually.

Required Equipment

e Agilent N1911A/12A or E4419A/B power meter (a power meter is not required with the
U2000A/01A/02A/04A Power Sensor)

¢ Agilent E4413A E Series CW power sensor or U2000A/01A/02A/04A Power Sensor
* GPIB, LAN, or USB interface cables, as required

* adapters and cables, as required

NOTE For operating information on a particular power meter/sensor, refer to its operating guide.

Connect the Equipment

Connect the equipment as shown in “Connect the Equipment” on page 85.

NOTE During the process of creating the user flatness correction array, the power meter is
remotely controlled by the signal generator.
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e Agilent N1911A/12A or E4419A/B power meter® °
e Agilent U2000A/01A/02A/04A power Sensor?

E5810A
LAN/GPIB Gateway

Signal
Generator

RF Output

Input Port

USB port for connecting

USB-compatible power " Cables ™
meters/sensors (e.g.
N1911A/12A Power Meters and other
and U2000A Series USB ~ g
Power Sensors). ™
Flatness
Corrected
| Output
Out In e Power Sensor

Device Under Test
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LAN, GPIB, or USB interface cables,
as required
adapters and cables, as required

The LAN, GPIB*, and USB connections are
for convenience. If your power meter does
not have LAN, GPIB, or USB, then manually
enter corrections as described in the
correction entry step in this section.

*GPIB control of a power meter requires a
LAN-GPIB gateway and use of the connection type
VXI-11. Refer to the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094—-90009),
Agilent X-Series FAQs “How do | connect to the
LAN?", and to the E5810A User’s Guide or
equivalent LAN/GPIB gateway device.

Power Meter
(if applicable)

Note: Agilent U2000 Series
USB Power Sensors connect
directly to the signal generator’s
front panel USB port (i.e. the
power meter is not applicable).

For operating information, refer to the power meter/sensor documentation.
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Figure 5-15 Configure Power Meter Menu Softkeys

AMPTD > More > User
Flatness > Configure Power
Meter

P Connection

Connection Tupe,

Connection Tupe

Enables the power meter
connection type: Sockets

Sockets LAN, VXI-11 LAN, or USB.

(Sockets)™

LAN only).

on the selected

Y
Pl Config

Connect ion,
Settinas

Fouer Meter
hanne 1
ElE

Zero Sensor

USB U2000A Series Power
Meters do not require the
sensor to be calibrated.

Calibrate Sensor

Basic Procedure
1. Create a user flatness array.

a. Configure the power meter/sensor
b. Connect the equipment
c. Configure the signal generator
d. Enter the user flatness correction values
2. Optionally, save the user flatness correction data.

Apply user flatness correction to the RF Output.

Sets the power meter’s IP
address or LAN-GPIB

P%Eegdgeter gateway'’s IP address
B58 I (Sockets LAN and VXI-11
Fouer Meter
IF Eggt —This softkey is dependent

Connection Type.

-
-

Note: The VXI-11 softkey is
used to communicate
remotely with a power meter
that has a GPIB connector
via LAN-GPIB gateway.

WHI-11

P Connection

Connection Tupe,
L (USB)

Open a menu
to enter the
USB device
name.

Sockets LAN: Sets the

IP port to 5025 (standard)

or 5023 (telnet)

programming.

Fouer Meter
IF Port
5025

VXI-11 LAN: Opens a

D P UHﬁ—ll menu for entering a For details on
euég?m?r{% [—device name for the each key, use key

power meter being used.  help as described

on page 34.
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Configure the U2000A/01A/02A/04A Power Sensor

Connect the power sensor to the signal generator’s front panel USB port. Refer to “Connect the
Equipment” on page 85.

1.

2. Zero the power sensor using the signal generator softkeys.

CAUTION Verify the signal generator RF Output power is set to the desired amplitude before
performing the power meter zero. No RF Output amplitude check is done by the signal
generator during zero.

NOTE The signal generator’s RF Output LED remains unchanged during zeroing of the power

sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor,
the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware
has turned off the RF Output’s power.

For operating information on your particular power sensor, refer to its operation guide.

Configure the E4419A/B and N1911A/12A Power Meter

1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter, using the softkeys on the signal
generator or the front panel of the power meter.
Enter the power sensor calibration factors into the power meter as required.

4. Enable the power meter’s cal factor array.

NOTE  The signal generator’s RF Output LED remains unchanged during zeroing of the power

sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor,
the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware
has turned off the RF Output’s power.

For operating information on your particular power meter/sensor, refer to its operating
guide.

Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1.

Configure the signal generator:

a. P

reset the signal generator.

b. Set the signal generator’s connection type to the power meter/sensor:

i.

ii.

Press AMPTD > More > User Flatness > Configure Power Meter > Connection Type > connection
type.

If connection type is USB:
1. Zero Sensor

2. Go to step c.
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else

If Sockets LAN or VXI-11 LAN: Press Power Meter IP Address > power meter’s or LAN-GPIB
gateway IP address > Enter.

iii. If Sockets LAN: Press Power Meter IP Port > IP port > Enter.
else
If VXI-11: Press PM VXI-11 Device Name > device name > Enter.

When connecting directly to the power meter, enter the device name as specified in the
power meter’'s documentation. Typically, this is “inst0” and is case sensitive for some
power meters. Refer to your power meter’s documentation, the Agilent Connectivity Guide
USB/LAN/GPIB Connectivity Guide (E2094-90009), and Agilent X-Series FAQs “How do I
connect to the LAN?”

When connecting via a LAN-GPIB gateway, enter the SICL address of the power meter.
Typically, this is “gpib0,13”, where “gpib0” is the GPIB SICL interface name of the
gateway and “13” is the GPIB address of the power meter. Refer to the Agilent
Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094-90009), Agilent X- Series
FAQs “How do I connect to the LAN?”, and to the E5810A User’s Guide or equivalent,
LAN/GPIB gateway device.

Open the User Flatness table editor and preset the cal array:
Press Return > Configure Cal Array > More > Preset List > Confirm Preset with Defaults.

In the Step Array menu, enter the desired flatness—corrected start and stop frequencies, and
the number of points:

Press More > Configure Step Array >
Freq Start > 500 > MHz >
Freq Stop > 1 > GHz >
# of Points > 10 > Enter

Populate the user flatness correction array with the step array configured in the previous
step:

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.
Set the output amplitude to 0 dBm.
Turn on the RF output.

88
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2. Connect the power meter to the RF output and enter the correction values:

With a Power Meter Over LAN, GPIB, or USB

i. Create the correction values:
Press More > User Flatness > Do Cal.

The signal generator begins the user
flatness calibration, and displays a progress bar.

The amplitude correction values load
automatically into the
user flatness correction array.

ii. View the stored amplitude correction values:
Press Configure Cal Array.

The user flatness correction array title displays User Flatness:

ii.

iii.

iv.

vi.

Manually

Open the User Flatness table editor and highlight
the frequency value in row 1:
Press More > User Flatness > Configure Cal Array.

The RF output changes to the frequency value of
the table row containing the cursor.

Note the value measured by the power meter.

Change the sign on the delta value (e.g. the delta
value of the 0 dBm reference value (step f), and the
measured value from i is -.34, change the value to
+.34).

Highlight the correction value in row 1.

Press
Select > enter the delta calculated in step iii > dB.

(e.g. For this example enter +.34)

The signal generator adjusts the output amplitude
based on the correction value entered.

Repeat steps ii — v until the power meter reads 0 dBm.

vii. Highlight the frequency value in the next row.

viii.Repeat steps ii through vii for the remaining rows.

(UNSTORED), without a name,

indicating that the current user flatness correction array data has not been saved to the file

catalog.

Optional: Save the User Flatness Correction Data

1. Press Load/Store > Store to File.

2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a USERFLAT file. Any
user flatness correction files saved to the catalog can be recalled, loaded into the correction array,
and applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output

¢ Press Return > Flatness Off On.

The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the

array is applied to the RF output.
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Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction
Values on page 87.

1. Preset the signal generator.
2. Recall the desired User Flatness Correction file:
a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm Preset.
b. Press Load/Store.
Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file:
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On to On.
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Using Internal Channel Correction

The internal channel correction feature corrects the 100 MHz baseband bandwidth flatness and phase
for arbitrary center frequencies. This feature is off by default, as the switching speed performance of
the instrument is impacted when this feature is on.

This calibration should be run when the ambient temperature has varied by at least 5 degrees
Celsius from the ambient temperature at which the previous calibration was run.

NOTE There is an internal calibration routine that can be run to collect correction data for both
the baseband and RF magnitude and phase errors over the entire RF frequency range on any
unit with options 6563 and 656. The internal channel correction cannot be turned on until
after the correction has been executed once.

When this feature is off, the box will behave as it always has. When this feature is on, the internal
I/Q path is active, the I/Q Correction Optimized Path is RF Output, and the frequency is changed by
more than 1 kHz, the firmware will calculate a channel correction filter £50 MHz about the specified
frequency. For List/Sweep, the calculation will be done prior to the first sweep using the specified
frequencies when either waveform sweep is active or the baseband is on and the instrument is
optimized for the internal path. This calculation will cache corrections for up to the maximum
number of cache points (256). For list/sweep, the sweep will pause and recalculate the correction
caches before running again.

CAUTION In the case of arbitrary frequency switching, once the correction cache is full (256
unique frequency points), the oldest frequency corrections will be forgotten as new
frequencies are selected.

Whenever I/Q Timing Skew, [/Q Delay, Quadrature Angle Adjustment, or the Int
Equalization Filter is adjusted, all caches are forgotten.

Additional characteristics of the internal channel correction:

*  When the internal channel correction is on, arbitrary frequency switching while the baseband is
on will take up to an additional 290 ms (72 ms typical) the first time that frequency is specified.
After the first time that a frequency is selected, switching to that frequency again takes an
additional 1 ms.

* If a frequency sweep is activated, then the calculation and caching will occur up front for the
first 256 unique frequencies, and all additional unique frequencies will have the characteristics of
arbitrary frequency switching.

e If the I/Q Correction Optimized Path softkey is set to Ext I/Q, then only the baseband corrections
will be applied and the frequency switching will be unaffected.

e If active, the ACP Internal I/Q Channel Optimization filter and the Equalization filter, will be
convolved with the internal channel correction. A hamming window is applied and the resulting
filter will be truncated to 256 taps.
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Figure 5-16 Internal Channel Correction Softkeys
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SCPI Commands:
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[:SOURce] :DM: INTernal : CHANnel : CORRection [ : STATe] ?
:CALibration:BBG:CHANnel

Configure Internal Channel Correction

For details on each key, use key help as
described on page 34.

Toggles on or off the application of
the internal baseband generator
RF and baseband magnitude and
phase corrections across the
160MHz baseband bandwidth at
the current RF frequency.

When this feature is on, arbitrary
frequency switching while the
baseband is on will take up to an
additional 3.3ms (typical) to 6.8ms
the first time that frequency is

specified. After that, switching to

that frequency will take up to an
additional 1.3ms.

Up to 1024 unique frequencies can
be cached before the oldest cache
will be forgotten. If a frequency
sweep is activated, then the
calculation and caching will occur
up front for the first 1024 unique
frequencies, and all further unique
frequencies will have the
characteristics of arbitrary
frequency switching.

If the 1/Q Correction Optimized
Path is set to Ext I/Q Output then
only the baseband corrections will
be applied and the frequency
switching speed will be unaffected.

This correction will be convolved
with the ACP Internal I/Q Channel
Optimization filter and the
Equalization filter if they are active.
The resulting filter will be truncated
to 256 taps.

The following is a basic configuration for using the signal generator’s internal channel correction.

Refer to Figure 5-16.

On the signal generator:

1. Set the center frequency:

Press Freq >3 > GHz

2. Set the I/Q to internal (default):
Press 1/Q > 1/Q Source > Internal

3. Press 1/Q to On

4. Perform internal channel correction:

Press More > Int Channel Correction Off On to On
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Using External Leveling

CAUTION While operating in external leveling mode, if either the RF or the DC connection between
the signal generator and the detector is broken, maximum signal generator power can
occur. This maximum power may overstress a power—sensitive device under test.

Atten Hold sets to On and grays out (inactive) with Ext Detector

pUCAContnol &~ selection. When re-selecting Internal, the softkey becomes
Atten Hold active, but attenuator hold remains on. If desired, manually set it
an to off.
ANEIHIE With the Ext Detector selection, Set Atten has no effect on the
Atten/AlC,l g / output power level. During external detector use, use the
Control attenuator to keep the ALC power level at approximately 0 dBm
o when using negative dBm power levels. See page 96.
Off
Ext ALC Hold
SElEEED Leveling Mode
Internal

Leveling ™ Leveling |
CoctroiN— Leveling

Leveling Mode,] »

Hore 1 of 3 (Internal)
Prr Meter Once
Ext Leveling

—reTitade | A e

Amptd Ref Set
0.00 dEm

Prr Meter Cont

Amptd Ref This softkey works with only the Ext Detector selection. It uses
llrirfii on 16 dB as its zero reference point.

I ESels \These settings do not change the output power amplitude of the
signal generator, they only let you modify the front panel display

amplitude value so it closely approximates the power level

User FlsEnEesn measured at the output of the coupler/splitter. See page page 100.

Output Blankin
bFFon R

fore 2 of 3

Amplitude

User Power Maxk

Alternate,
Amplitude

ALC B,
(AuULo)

Fower Opt,
Modes

fore 3 of 3

Agilent MXG and EXG X-Series Signal Generators User’'s Guide 93



Optimizing Performance
Using External Leveling

External leveling lets you move the ALC feedback source closer to the device under test (DUT) so
that it accounts for most of the power uncertainties inherent to the cabling and components in a test
setup. Refer to Figure 5-17.

Figure 5-17 ALC Circuity

Signal Generator

gtFt)ctarluE;tcSmpm Leveled Output
ALC Modulator (see page 96).
RF Power Splitter l
_ | OUTPUT Component orlfml
[l (Amp, Filter, DUT,
| | Atten, etc.) =

g [] External Detector

(Negative output)
Cabling
ALC \' *——1 Internal Detector
Driver

:
¥

ALC INPUT

The external detector outputs a negative voltage to the signal generator’s rear panel ALC INPUT
connector based on the power level at the detector. As the RF power level at the coupler’s/power
splitter input changes, the external detector returns a compensating negative voltage. The ALC circuit
uses this negative voltage to level the RF output power by raising and lowering the signal’s power,
thus ensuring a constant power level at the point of detection (external detector). Since the point of
detection does not occur at the output of the device to which the detector is connected, there is
some power loss that is not compensated for by the external detector. For example on a coupler, the
coupled port siphons some of the signal’s energy to drive the external detector. In addition the
coupler experiences some insertion loss between the coupled port and the output.

Figure 5-19 on page 96 shows the input power versus output voltage characteristics for typical
Agilent Technologies diode detectors. Using this chart, you can determine the leveled power at the
diode detector input by measuring the external detector output voltage. For a coupler, you must then
add the coupling factor to determine the leveled output power.

When using an external detector, the signal generator’s power range may vary from the values shown
in the data sheet. This is primarily due to the efficiency of the detector. Always ensure that the
detector, coupler/power splitter are specified for the power and frequency range of interest. To
determine the signal generator’s actual power range during external leveling, see “Determining the
Signal Generator’s Amplitude Range” on page 98.

With external leveling, the displayed amplitude value can vary significantly from the actual output
power of the coupler/power splitter to which the external detector is connected (see Figure 5-18).
This is because the coupler/power splitter has it own signal characteristics (insertion loss, coupling
factor, and so forth), which are unknown to the signal generator, so it is typically unable to display
an accurate amplitude value. Also components between the signal generator and the external detector
can affect the output power of the coupler/power splitter. You can compensate for this power display
difference by using the
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Ext Leveling Amptd Offset softkey or the Amptd Offset softkey. The difference between the two softkeys is
that the ExtLeveling Amptd Offset functions only while external leveling is active. For more information
on using the external leveling offset feature, see “Adjusting the Signal Generator Display’s Amplitude

Value” on page 100.

Figure 5-18 Power Value Differences with External Leveling
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Figure 5-19 Typical Diode Detector Response at 25° C
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Option 1EQ Output Attenuator Behavior and Use

When using the internal detector, the Option 1EQ output attenuator enables signal generator power
levels down to —127 dBm at the RF Output connector. It accomplishes this by adding attenuation to
the output signal after the ALC detection circuit. The output power value (shown in the Amplitude
area of the display) is the resultant of the Set Atten and Set ALC Level values (see page 93). With the
external detector selected, the output attenuator no longer attenuates the output signal since the
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feedback for the detection circuit has been moved beyond the output attenuator. Because the
attenuator no longer affects the amplitude of the output signal, the output amplitude is determined
by only the Set ALC Level softkey.

With external leveling selected, the signal generator enables attenuator hold and the power range
approximates the range of a standard option (no attenuator) signal generator (see the Data Sheet).
As stated earlier, the actual output power may vary due to the external detector and the
coupler/power splitter performance characteristics.

NOTE When the internal detector (Internal selection) is reselected, the signal generator does not
turn the attenuator hold off.

Even though the output attenuator no longer affects the output power, it is still useful to drive the
ALC circuit to its mid—-power point of approximately 0 dBm, which is optimal for the internal leveling
circuitry and typically provides the best amplitude flatness results. This is useful with negative power
values of -5 dBm or less. For example, to drive the ALC to approximately mid-power with a —20
dBm power setting, add 25 dB of attenuation. This sets the ALC circuit to 5 dBm (-20 + 25).

NOTE If there is too much attenuation, it will drive the ALC circuit too high and cause the signal
generator to go unleveled. Ensure that you decrease the attenuation as you increase the
power level.

Configure External Leveling

Basic Setup Process
* If working with a single frequency signal, perform Steps 1 through 5.

¢ If working with multiple frequencies:
a. Perform Steps 1 through 4.
b. Perform a user flatness correction, see “Using Flatness Correction” on page 82.
e If working with a sweep:
a. Perform Steps 1 through 4.
b. Setup the sweep, see “Configuring a Swept Output” on page 40.
Setup the equipment, see “Equipment Setup” on page 97
Configure the carrier signal, see “Configuring the Carrier” on page 98

Select external leveling, see “Selecting External Leveling” on page 98.

> o

Determine the output amplitude range, see “Determining the Signal Generator’s Amplitude Range”
on page 98

5. Set the displayed power value, see “Adjusting the Signal Generator Display’s Amplitude Value” on
page 100
Equipment Setup

Set up the equipment as shown in Figure 5-20 on page 98. Place the external detector (detector and
coupler/power splitter) as close as possible to the DUT.
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Recommended Equipment
e Agilent 8474E negative detector
e Agilent 87301D directional coupler

* cables and adapters, as required

Figure 5-20 Typical External Leveling Setup using a Directional Coupler

Negative Detector

ALC INPUT q P
i T
(] EIS SR e s e e .
HERARREAARERS RF OUTPUT Leveled Signal
i %LEEO ™S
Signal Generator Amplifier Coupler

Configuring the Carrier
1. Press Preset.

2. Set the carrier frequency.
3. Set the power level to 0 dBm:
e If the signal generator has Options 1E1 and 520, set the output attenuator to zero dBm:
a. Press AMPTD > Atten/ALC Control > Atten Hold Off On to On.
b. Press SetAtten > 0 > dB.
c. Press SetALC Level > 0 > dBm.

Selecting External Leveling

Press AMPTD > Leveling Control > Leveling Mode > Pwr Meter Cont.

Determining the Signal Generator's Amplitude Range

The maximum output amplitude is frequency dependent. So if you are using multiple frequency
points and there is a need to know the maximum output amplitude for each frequency point, refer to
the “Amplitude” section of the X-Series Data Sheet. Then use this procedure to determine the
maximum amplitude for each band.
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With external leveling and Option 1EQ, the signal generator’s power range approximates that of a
standard option instrument (no Option 1EQ). But Option 1EQ does let you use the attenuator to
drive the ALC to its mid-power point when using negative amplitude values. However adding
attenuation does decrease the upper range limit. For more information, see “Option 1EQ Output
Attenuator Behavior and Use” on page 96.

1. If Option 1EQ is installed, adjust the attenuator to the desired level.

NOTE If the Option 1EQ output attenuator value is too high (approximately >55 dB), it will cause
an unlevel condition to occur when the RF output is turned on.

a. Press AMPTD > Atten/ALC Control > Atten Hold On > Set Atten.
b. Enter the attenuator value.
Turn on the RF output: Press RF On/0ff to On
3. Set the AMPTD step increment value to one dB.
e Press AMPTD > Incr Set > 1 > dB.
4. Determine the minimum amplitude value:
a. Set the amplitude to —25 dBM.
b. Using the down arrow key, decrease the amplitude until the UNLEVEL annunciator appears.
c. Using the up arrow key, increase the amplitude until the UNLEVEL annunciator is gone.

The value showing when the UNLEVEL annunciator is gone is the minimum amplitude range
value.

5. Determine the maximum amplitude value:
a. Set the amplitude to a value that does not cause the signal generator to go unleveled.

b. Using the up arrow key, increase the amplitude until it goes unleveled or an error message
indicating that the upper limit has been reached shows at the bottom of the display.

c. Decrease the amplitude value:

e If the unleveled annunciator appeared, decrease the amplitude until the annunciator is
gone. The value where the annunciator disappears is the maximum upper range value.

e If the signal generator displays Error: 501, Attenuator hold setting over range at
the bottom of the display, the value showing is the maximum upper range value.

To remove the error message, press the down arrow key until the message is gone. The
error appears when an attempt is made to increase the amplitude beyond the maximum
value as it relates to the current attenuator setting.
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Adjusting the Signal Generator Display’s Amplitude Value

When using external leveling, the signal generator’s displayed amplitude value will not match the
leveled power of the signal at the output of the coupler/splitter. To compensate for this difference,
the signal generator provides two methods for configuring the displayed power value so that it closely
matches the measured value at the output of the coupler/splitter.

1. Connect and configure a measurement instrument:

a. Connect the output of the coupler/splitter to either a power meter or a signal analyzer.

b. Configure the power meter/signal analyzer for measuring the power level of the signal.

2. Adjust the signal generator’s displayed amplitude value:
If using the ExtLeveling Amptd Offset Softkey:

This softkey uses 16 dB as its zero reference. The 16dB is the coupling factor of the internal
detector.

a.
b.

On the signal generator, press AMPTD > Leveling Control > Ext Leveling Amptd Offset.

While viewing the carrier amplitude value on the signal generator display, use the RPG
knob (detent knob) to adjust the offset value until the integer part of the displayed
amplitude value is the same as the integer portion of the measured value.

Each detent position adjusts the value by 1 dB.

Using the number keypad, make the necessary fractional adjustments to the display
amplitude value.

If using the Amptd Offset Softkey:

On the signal generator, press AMPTD > Leveling Control > More > Amptd Offset.

Calculate the difference between the signal generators displayed Amplitude value and the
measured value.

Using the numeric keypad, enter this difference as the Amptd Offset softkey value.

100
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Figure 5-21 Power Search and ALC Off Softkeys
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Auto: The calibration routine executes whenever
output frequency or amplitude changes.

Span: Pressing Do Power Search executes the
power search calibration routine once over a
selected frequency range.

The corrections are stored and used whenever you
tune the signal generator to within the calibrated
frequency range.

Manual: User must explicitly execute a power
search to calibrate the open loop ALC level.

3 RMS: Value is a DC
bias equivalent to the
value derived from the
file header or the
calculated value from
the current 1/Q data.

Fixed: Uses afixed 0.5
Vrms value (Same
value is used with Ext
1/Q data).

Manual: Allows user to
specify the DC bias
voltage value
(0-1.414 Vrms).
Modulated: Uses the
AC bias from the actual
modulating signal.

RMS

Fized

Manual

Modulated

Turning ALC off deactivates the signal generator’s automatic leveling circuitry. Turning ALC off is
useful when the modulation consists of very narrow pulses that are below the pulse width
specification of the ALC or when up converting external IQ signals and the modulation consists of
slow amplitude variations or bursts that the automatic leveling would remove or distort. When using
the internal IQ baseband generator, the best technique is to use the ALC hold marker function vs.
ALC off for the types of signals just described.

NOTE

After the ALC has been turned off, power search must be executed to set the proper output

power level requested on the front panel. Power search is executed automatically by default,
but the these settings can be overridden by using the Manual mode
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Power Search Mode

NOTE The power search mode cannot be used with bursted signals input via the external IQ inputs.

The MXG/EXG has three power search modes (for internal and external I/Q modulation) and four
power search references (for external I/Q modulation only). Refer to Figure 5-21 on page 101.

Power search executes a routine that temporarily activates the ALC, calibrates the power of the
current RF output, and then disconnects the ALC circuitry.

Power Search Modes (Applies to External and Internal I/Q Modulation)

e Auto — A power search is executed at each frequency or power change, and at each change to the
AM, burst, pulse, or I/Q modulation state.

¢ Span — When Power Search is set to Span, pressing Do Power Search executes the power search
calibration routine over a range of user-defined frequencies. The power search is stored and used
when the signal generator is tuned within a user-defined range. After the Span softkey is pressed,
select either Full or User. If User is selected, then the start and stop frequencies need to be
selected.

¢ Manual — When Power Search is set to Manual, pressing Do Power Search executes the power search
calibration routine for the current RF frequency and amplitude. In this mode, if there is a change
in RF frequency or amplitude, you will need to press Do Power Search again.

Power Search References (Only applies to Internal I/Q Modulation)

The four Power Search References control the power search function. These four references select the
reference voltage used while the RF signal is being I/Q modulated. (Power search references are not
used for analog modulation: FM, ¢M, or pulse modulation.)

CAUTION If the power search reference has the incorrect RMS voltage, the output power will be
incorrect. Refer to Figure 5-22, "Calculating the Output Power Error for a Single
Waveform Sample Point" and Figure 5-23, “Calculating the RMS Voltage of the
Waveform.”

NOTE A successful power search is dependent on a valid power search reference.

¢ Fixed - Reference level is 0.5 Vrms.

This reference functions with internal, external IQ and bursted signals. This is the instrument’s
default setting.

e RMS - User provided reference level 0-1.414 Vrms placed in the Waveform Header. Refer to
“Saving a Waveform’s Settings & Parameters” on page 139.

This reference functions with internal IQ and bursted signals.
¢ Manual - User provided reference level 0-1.414 Vrms.

This reference functions with internal, external IQ and bursted signals.
¢ Modulated — Uses the I/Q modulation signal as the reference level.

This reference functions with internal or external IQ. It is not functional with bursted signals or
a signal with varying Vrms.
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Figure 5-22 Calculating the Output Power Error for a Single Waveform Sample Point

The Output Power Error — () x log10((V1)/(V2))

Where:
V1 is the actual waveform RMS voltage
V2 is the entered RMS voltage

Note: If the RMS voltage value entered is lower than the actual RMS voltage, the output power will be higher than desired.
If the RMS voltage value entered is higher than the actual RMS voltage, the output power will be lower than desired.

Figure 5-23 Calculating the RMS Voltage of the Waveform
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The signal generator can calculate the RMS value automatically.if more
n=1

than two contiguous IQ data points are zero, the signal generator
calculation ignores those zero points. Also, because the RMS calculation,
that is done by the signal generator, is slow and may not be appropriate
for your application, it is recommended that the user calculate and enter
in their measured RMS value for the waveform file.

N =# of Samples

SCPI Commands:
[:SOURce] :RADio:ARB:HEADER:RMS <"file name"s>,<val> |UNSPeCified
[:SOURce] :RADio:ARB:HEADER:RMS? <"file name">

For a programming example of determining the RMS voltage of a waveform, refer to the Programming Guide and to the
Documentation CD that came with this instrument.

The RMS and MANUAL references are the most powerful selections. The user provides the reference
level. The IQ signal can be bursted (radar) or have different RMS levels (Wireless Signals). Once the

RMS/MANUAL reference level is set, the power search runs independent of the current Vrms value of
the waveform.

The RMS and MANUAL references, with a reference level of 1.0 Vrms are equivalent to a calculated
rms value of 1 and can be measured using SINE_TEST _WFM.

The FIXED, RMS, and MANUAL references use a DAC to apply the reference voltage and do not
require the IQ signal to be present.

NOTE The MXG/EXG reference voltage is designed to operate between 0.1 Vrms to 1 Vrms
nominally, but it can overrange to 1.414 Vrms. (The RMS can overrange to 1.414, if the
constant values are loaded manually and all “1”s are entered for the I and Q values.) See
also “Saving a Waveform’s Settings & Parameters” on page 139.

CAUTION The minimum reference level that results in a successful power search is dependent on
RF Frequency, RF Amplitude, and Temperature. An MXG/EXG power search using a
reference level of 0.1 Vrms for 0 dBm at 1 GHz may fail.
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Power Search Settings

For the power search routine to execute, the instrument must be in the following conditions:
¢ The I/Q modulation enabled On.

¢ The RF output enabled On.

¢ The Automatic Leveling Circuitry deactivated (Off).

¢ The RF Blanking set to On.

This function prevents power spikes during the power search (refer to “Using the RF Blanking
Marker Function” on page 156.)

*  When using summing for the internal Arb and the external I/Q, all four power reference modes
are available (e.g. Fixed, RMS, Manual, and Modulated).

*  When using the external IQ inputs, use the MANUAL reference mode, and make sure the external
I/Q signal is present when executing a power search. If the external I/Q signal is not present, the
power search will fail.

Example: Automatic Power Search
1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Turn the RF output on.

5. Deactivate the signal generator’s automatic leveling control:
Press AMPTD > ALC 0ff On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument change
that automatically initiates a power search.

When set to Auto, power search automatically executes when a significant instrument setting changes.
The Do Power Search feature enables you to decide when to execute a power search to compensate
for changes, such as temperature drift or a change in the external input.

Using an OQutput Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset
(positive or negative) from the entered value.

RF Output = entered value — offset value
Displayed Value = output frequency + offset value
To set an offset:

e Frequency: Press Freq > Freq Offset > offset value > frequency unit.
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e Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Indicates that an offset is on

FREQUENCY ®
6.000 000 001 00 &z | -143.00 den

Examples

Example | Example | Example

#1 # #3 Comments

Parameter

Entered (and displayed) Value: | 300 MHz | 300 MHz | 2 GHz The entered value must be positive.

Offset: 50 MHz —-50 MHz | -1 GHz An offset value can be positive or negative.

The signal generator alerts you if the

Output Frequency: 250 MHz | 350 MHz | 3 GHz output frequency or amplitude is out of range.

When using the signal generator as a local oscillator (LO), you can use the offset to display the
frequency of interest, as illustrated below:

Antenna tuned to 1321 MHz

RF Amplifier Mixer Filter IF Amplifier

IF Output
IF =321 MH 321 MH
z z

e

T Output Frequency = 1000 MHz

Selected Offset Slanal Generator Display
321 MHz 1321 MHz (Antenna Frequency)

Signal Generator —679 MHz 321 MHz (IF Output)
(local oscillator)

Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset
(positive or negative) by the entered value from a chosen reference value.

RF Output = reference value + entered value
To set a reference:
1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.”
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All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.”
All amplitudes entered are interpreted as being relative to this reference amplitude.

Indicates that a reference is on

FREQUEHCY REF

0.00 tz

ANPLITUDE

218400 ‘

Examples
Example | Example | Example
Parameter #1 #2 #3 Comments
Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.
Entered (and displayed) Value: | 2 MHz —2 MHz -1 GHz The entered value can be positive or negative.
Output Frequency: 52 MHz 48 MHz 1 GHz The signal generator alerts you if the output frequency or

amplitude is out of range.

To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the

steps above.

Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple
(positive or negative) of the output value.

Displayed Value = multiplier value X output frequency

Output Frequency = displayed value + multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency.

The display equals the output frequency times the multiplier value.
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Indicates that a frequency multiplier is on

600.000 000 00 r+

rrea: ©00.000 000 00 MHz

-— Freq Ref Set
144°00 dbn 0.00 Hz
Incr: 100.00000kHz Fres EBF

n

Freq Offset

0.00 Hz

02/25/2012 17:03 Hore 1 of 2

Optimizing Performance
Using an Output Offset, Reference, or Multiplier

Freg Multiplier
£32.000 %

Freq Channelse

Examples
Example | Example | Example
Parameter #1 #2 #3 Comments

Frequency Multiplier: 3 -3 4 The multiplier range can be set from:
+0.001 to +1000
-1000 to -0.001

Entered (and displayed) Value: | 600 MHz | -600 MHz | 8 GHz

Output Frequency: 200 MHz | 200 MHz 2 GHz The signal generator alerts you if the output frequency is
out of range.

When using the signal generator as the input to a system, you can set the frequency multiplier so
that the signal generator displays the output of the system, as illustrated below using a doubler:

Signal Generator

Input = 2 GHz

Doubler

Output = 4 GHz
—

Selected Entered/Displayed Signal Generator
Multiplier Frequency Output

2 4 GHz 2 GHz

When measuring mixers, the frequency multiplier and frequency offset are often used together. In the
upconverter example below, the multiplier is set to —1 and the offset is set to 3 GHz so that the
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signal generator displays frp.

Mixer

frE = 2200 — 2400 MHz fir = 3000 MHz

T fLo = 800 — 600 MHz

Selected Selected Entered/Displayed Signal Generator

Multiplier Offset Frequency Output (f o)
(frr)
Signal Generator -1 3000 MHz 2200 MHz 800 MHz
(local oscillator) -1 3000 MHz 2400 MHz 600 MHz

Using the Frequency and Phase Reference Softkeys

The MXG/EXG can be set to have either a user-determined frequency or phase reference.

Figure 5-24 Frequency Reference and Frequency Offset Softkeys

FREQUEHCY ANPLITUDE Frequency
600.000 000 00 mz -144.00 den Frea Ref Set
Freq: 600000 000 00 MHZ Incr: 100.00000kHz Fres EﬁF
Freq Offset
0.00 Hz

Freg Multiplier
1.000 =

Freq Channelse

02/25/2012 17:04 Hore 1 of 2

Using Free Run, Step Dwell, and Timer Trigger

Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in
a Step Sweep or a List Sweep. There are two possible measurement combinations:

Free Run with Step Dwell time (Figure 5-25 on page 110) the signal generator waits for the signal to
settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In addition,
the time to complete the entire sweep can vary. There is always a minimum value of Step Dwell for
each frequency point. The minimum Step Dwell timing for any point is fixed at a value of 100 us. The
time between frequency points is the sum of the settling time, plus the Step Dwell time. The settling
time is dependent on frequency, amplitude, band crossings, and other factors, so the time between
frequency points can vary.
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Timer Trigger instead of Free Run (Figure 5-25 on page 110) the signal generator generates equally
spaced triggers, and it moves to the next point at each trigger. This has the advantage that the time
between points is consistent and the overall sweep time is consistent. But, if the trigger is too fast,
the signal may not have time to settle before jumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the
point to point time is consistent, use Free Run and Set Dwell time.

If the signal’s point to point time requires consistency but the specific settling time at each point can
vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the signal
generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point to point time is
required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms,
depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers.
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Using Free Run, Step Dwell, and Timer Trigger

Figure 5-25 Free Run, Set Dwell, and Timer Trigger Softkeys

Sweep > Configure Step

Sweep > More

Step Sueep
Step Dnell
2.000 msec

Step Spacing
LOG

LIN Freq Step
0.00 Hz

Sweep > More

'

Sueep/List
Conf igure
List Sueep

Skeep Trigoer,
(Free Fun

Point Trigger,
(Free Fun

fore 2 of 3

— Free Run
Trigger Keu
Bus
EXT,
(Trigger 1)
(Pulse sunc®
ulse Sunc
) Ui

Trigger Setup

fore j of 2

Use Step Dwell with Free Run when additional measurement wait

[ ——————————____time s desired after settling.

If the signal is to be settled for a minimum specific time at each point
and it is not important if the point to point time is consistent, use
Step Dwell and Free Run time.

If the signal’s point to point time
requires consistency but the
specific settling time at each point
can vary, then use the Timer
Trigger. Avoid using too fast of a
sweep which does not allow the
signal generator to settle.

If the signal needs to be settled for
a specific minimum time and
consistent point to point time is
required, then you should set the
Timer Trigger to be the sum of the
switching time (900 us (Option
UNZ) or 5 ms (Standard)) plus the
minimum settled time that is

Trigger Setup

Timer Trigger

For details on each key, use key help as described

— Trig Timer Period
1.000

iEGRIOteg needed to make the measurement.

Example: If you need the signal to
remain settled for 3 ms, and you
have Option UNZ which settles in
0.9 ms, then set the time trigger to
the sum which is 3.9 ms.

msec
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Using a USB Keyboard

Optimizing Performance
Using a USB Keyboard

You can use a USB keyboard to remotely control the RF output state, the modulation state, and to
select a memory sequence and register.

The register selection, RF output state, and modulation state are affected by power cycle or preset,
but the USB keyboard control state and the sequence selection are not.

CAUTION To avoid the loss of data, GPIB settings, or current user instrument states that have not
been permanently saved to non-volatile memory, the signal generator should always be
powered down either via the instrument’s front panel power button or the appropriate
SCPI command. Signal generators installed in rack systems and powered down with the
system rack power switch rather than the instrument’s front panel switch display a
Error -310 due to the instrument not being powered down correctly.

Recall State

RECALL
Seql1] ReoC--1

Select Reo:

Select Seqi

Oelete ALl
Fegs in SeqC1]

fore 1 of 2

Recall State

Oelete AL
Sequences

Auto Recallyf——

USB Keyboard Key

Delete, Enter

Insert

Home, Up Arrow

End, Down Arrow

Page Up, Right Arrow, +

Page Down, Left Arrow, —
Deletes every register in every sequence.

NOTE: You cannot recover the registers after
deleting them.

Signal Generator Function
RF On/Off

Mod On/Off

Next Sequence

Previous Sequence

Recall Next State Register
Recall Previous State Register

50000000000 e ~144.00 @0 e e
REEIQRBQ:R—EG MUD RF Prew SEOQ

Turning the USB keyboard control off disables the USB
keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on see page 34.
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6 Using Pulse Modulation (Option UNW or 320)

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting the power level and frequency, refer to

Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that
chapter.

Pulse Characteristics on page 115

The Basic Procedure on page 117
* Example on page 117

Pulse Train (Option 320 - Requires: Option UNW) on page 119

Agilent MXG and EXG X-Series Signal Generators User’s Guide 13



Using Pulse Modulation (Option UNW or 320)

Figure 6-1 Pulse Softkeys

Pulse Source
Sguare
Pulse Source
Note: Pulse Period Free-Run Gated
ote: Pulse Perio
Pulse and Pulse Width are page 117
not available when - 117
Pulse | Pulse Trainis selected Triggered page Ext Pulse
on as the Pulse Source.
Vi Adiustable i
Pulse Source, _ Doublet Pulse Train |—page 119
(Free-Run 7 >
e .
7 Pllse Period / Trigger Doublet
N L.00 usec
_— — — / fore 1 of 2
Pulze Delay Trig 1 Out BHC Trig 1 Out BHC
0.00000000 sec /
S — — — Hone L¥I
Pulse Hidth
\_ _ 2.00 usec
— These softkeys are Sweep Trig Out -
More 1 of 2 only available when B 8 Low = settled EhEER [FUn
tsr;:? t':(;u'ASclejEStg%?ge 1S Latency from the external
Source Settled pulse input to the pulse Trigger 2
Pulse Doublet. sync output =~ 50-60 ns. =
Width Period
) . Pulse Sunc 50ns >50ns Pulse
Determines how the signal generator 20 ns <50 ns
responds to an external pulse signal. -
Normal = high state. TTL signal Pulse Wideo Swept. Func Done
Invert = low state.
Hore 1 of 2 > Hore 2 of 2
See also, page 13 - -
and page 16 Trig 2 Dut BHC Trig 2 Dut BHC
Ext Polarity \
Invert P None LK
Route( Connectors ) \
Route Conmectors,) o Route To
& Set Polaritu Trig (ﬁoﬁgg* Sueep Trig Out Sweep Aun \
Hore 2 of 2 . HDU%BE&E Select the\signal
ris Y > Source Settled Trigoer 1 routed to each
(ShEED TrlE OUE) output connector.
Available on vector Route To 7
: ; Sweep Out. BNCH
ggtéuments with (Seep O4L) Pulse Sunc Pulze P ~
i /
Pulse Yideo Swept. Func Done /
Trigg?r D.gt, More 1 of 2 —1—®_ lore 2 of 2
n-arity Sueep OUL BHC
/
4>
Sueep Out /
Y V4
Trigoer Polarity Source Settled
Trigggrlﬂuttl
0lari
Neg Rael Pulse Wideo
Trigoer Out 2
Polarit
Neg Pulse Sunc
Sueep Dut BHC
For details on each key, use key help EhEER [FUn Skept. Func Dane
as described on page 34. lore 1 of 2——»
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Using Pulse Modulation (Option UNW or 320)
Pulse Characteristics

Pulse Characteristics

NOTE  When using very narrow pulses that are below the signal generator’s ALC pulse width
specification, or leveled pulses with an unusually long duty cycle, it is often useful to turn
ALC off (see page 101).

Pulse Source Type Period® Width & Delay® Uses Trigger Event®
Square Internal free run pulse train with Determined by . .
a 50% duty cycle. user defined rate.
Free Run Internal free run pulse train User Defined User Defined —
(default)
Triggered Internal pulse train — User Defined v
User Defined:
First pulse is relative to the
Adjustable Two internal pulse trains for each . rising edge of trigger signal. v/
Doublet trigger event. Second pulse is relative to the
rising edge of first pulse.
See Figure 6-2 on page 116
The first pulse follows the
) X ) trigger signal.
Trigger Two internal pulse trains for each . V4
Doublet trigger event. Second pulse is user defined.
See Figure 6-3 on page 116
Gated Internal gated pulse train — User Defined v
External External pulse signal at the rear . . .
panel Pulse connector
Pulse Train Internal pulse train User Defined: v
User Defined
See Figure 6-4 on page 119

aAll delays, widths, and periods have a resolution of 10 ns.
ba signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an internally generated pulse.
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Using Pulse Modulation (Option UNW or 320)
Pulse Characteristics

Rear panel inputs are described on page 12

External pulse input

seraLNo. |

T CN10149

100/120V 50/60/400Hz
TRIG 1 TRIG 2 REFIN __ 10MHz OUT 2201200 50/60Hz

oeoee | ’

Figure 6-2 Adjustable Doublet

External
Trigger .
RF Output . I

' Pulse 1 ' Pulse 1 ' R '
\<¢—— Delay —»-'4—— Width ——" . .
The delay of the first pulse is measured from ' : :
the leading edge of the external trigger signal. ' [
. Pulse 2 ' Pulse 2 '
'«— Delay ' Width ———»

The delay of the second pulse is measured from
the leading edge of the first pulse.

Figure 6-3 Trigger Doublet

External
Trigger

RF Output —

Pulse 1 ! Pulse 1 !
~€— Delay —P+—— Width ——®

The first pulse follows the The delay of the second pulse is measured from
external trigger signal. the leading edge of the external trigger signal.
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The Basic Procedure

1. Preset the signal generator.

2. Set the carrier (RF) frequency.
3. Set the RF amplitude.
4

Configure the modulation:

Using Pulse Modulation (Option UNW or 320)
The Basic Procedure

a. Set the pulse source: Press Pulse > Pulse Source > selection
b. Set the parameters for the selected pulse source:
Square Free Run Triggered | Adjustable Doublet | Trigger Doublet Gated Pulse External
(default) Train®
Pulse Rate — — — — — — —
— Pulse — — — Pulse Period — —
Period
— Pulse Pulse Delay | Pulse Delay Pulse Delay — Pulse Delay —
Delay
— Pulse Pulse Width | Pulse Width Pulse Width Pulse Width — —
Width

@ Requires Option 320.

Pulse 2 Delay

Pulse 2 Width

b Up to 2047 pulse cycles (elements) composed of both Pulse On and Pulse Off can be user defined.

5. Turn on the modulation: Pulse Off On softkey to On.

The the PULSE annunciator lights, indicating that you enabled modulation.

Pulse On®

Pulse Off®

6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

See also, “Modulating the Carrier Signal” on page 48.

Example

The following example uses the factory preset pulse source and delay.

Output:

1. Preset the signal generator.
2. Set the frequency to 2 GHz.
3. Set the amplitude to 0 dBm.

A 2 GHz, 0 dBm carrier modulated by a 24 us pulse that has a period of 100 us.

Agilent MXG and EXG X-Series Signal Generators User’'s Guide
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Using Pulse Modulation (Option UNW or 320)
Example

4. Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.
Set the pulse width to 24 microseconds: Press Pulse > Pulse Width > 24 > usec

6. Turn on both the pulse modulation and the RF output.
The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output”
on page 310.
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Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 — Requires: Option UNW)

Pulse Train (Option 320 — Requires: Option UNW)

The Option 320 Pulse Train feature enables the specification of up to 2047 independent pulse cycles,
each of which has an “On Time”, during which the RF output is measurable at the RF output
connector, and an "Off Time", during which the RF output is attenuated. Each pulse cycle is similar
in function to other X-Series signal generator Pulse modes—the Pulse Train feature has up to 2047
cycles, instead of only a maximum of two (with Doublets). There are also repeat counts available for
each pulse. These repetitions count against the total count of 2047 cycles.

The instrument can import pulse trains from a .csv (comma separated values) file or some other
common ASCII format. It can also export to ASCII/CSV files as well. Export allows specification of
the decimal separator and a column separator. The import allows specification of the decimal
separator (to allow for ""), but the column separator is auto-detected. Refer to “Pulse Train Menu
Softkeys” on page 119 and “Display Pulse Train Menu Softkeys” on page 121.

Figure 6-4 Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train For details on each key, use key help as described on page 34.

— Train Triooger

Free-Run
Pulse
- Fulse Triooered
6.000 000 000 00 &=z -144.00 aen =
-]
Pulse Source, Gated
Pulse Modulation Status Information tPulse Train
Pulse State: Off Pulse Source: Pulse Train Trioger Mode, Free-Run continuously plays
(Triooered) the pulse train, ignoring all
triggers.
Trigoer Mode: Triggered Pulze Delay Triggered runs the pulse
Delay: 0.00000000 sec 1 0.00000000 sec train (after waiting the Pulse
19 Delay) each time an external
trigger is supplied to the
1 k——Train Iteration— Edit Pulse Traine PULSE BNC, the Trigger
Immediately softkey is
03/06/2012 11:09  Hore 1 of 2 pressed, or the Trigger SCPI
== command is sent.
Display area indicates Pulse Train is the current pulse Gated runs the pulse train
source. while an external trigger is
supplied (level triggered) to
Pulse the PULSE BNC connector.
Tricger The state of the GATEd

trigger is detected only when
the playback is transitioning
to orinidle. This means that,
once started, playback is
always completed, even if
the GATE trigger changes to
the inactive state.

Trigger Immediately causes Immediately
the pulse train to run once. —T

Ext Polarity
i=0ll Irvert

Foute Connectors
& Set Polarity

fore 2 of 2

SCPI Commands:

[:SOURce] : PULM: INTernal : TRAin: TRIGger FRUN|{TRIGgered} |GATEd
[:SOURce] : PULM: INTernal : TRAin: TRIGger: IMMediate

Refer to the SCPI Command Reference.
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Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 — Requires: Option UNW)

Figure 6-5 Edit Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train

FREQUEHCY

Pulse Train

6.000 000 000 00 &+

ANPLITUDE

2.000 us

-144.00 den

O9/06/2012 17:33

For details on each key, use key help as described on page 34.

Pulse Train
Goto Rou
Edit Item
Enter
Inzert Row
Goto Top Row
Delete Row
Goto Middle Row
Goto FRowe
Goto Bottom Row
Display
FPulse Train*"'page121
More 1 of 2 I

This Jolumn indicates the
row of a each pulse train
cycle.

. Ise cycle
Note: When the cycles pu :
(elements) are repeated, (ellemsi-m_) in the
the row numbers are pulse train.
skipped in the displayed

count for the number of

pulse cycles repeated.

Example: For the pulse

train displayed above, in

row 2, the 3 us On Time

and 2 us Off Time pulse

cycle is repeated twice.

But, only row 2 is

displayed for that pulse

cycle (i.e. row 3 is not

displayed).

SCPI Commands:
[:SOURce] : PULM: INTernal : TRAin:
[:SOURce] : PULM: INTernal : TRAin:
[:SOURce] : PULM: INTernal : TRAin
[:SOURce] : PULM: INTernal : TRAin:
[:SOURce] : PULM: INTernal : TRAin:
[ :SOURce] : PULM: INTernal : TRAin:
[:SOURce] : PULM: INTernal : TRAin:
[:SOURce] : PULM: INTernal : TRAin:
[:SOURce] : PULM: INTernal : TRAin:
[ :SOURce] : PULM: INTernal : TRAin:

Refer to the SCPI Command Reference.

Thisxolumn
displays the on
times for each

Th\s column
displays the off
times for each

ulse cycle pulse cycle
?elemer){t) in the (element) in the Import /Export
pulse train. pulse train.

LIST:PRESet

OFFTime <20ns - 42sec>
:OFFTime?
OFFTime:POINts?

ONTime <20ns - 42sec>

ONTime?
ONTime:POINts?
REPetition <1-2047>
REPetition?
REPetition:POINts?

This column
displays the repeat
times for each

page 122

SCPI Commands (continued):
:MEMory:CATalog:PTRain?
:MEMory :DELete:PTRain
:MEMory:EXPort [:ASCii] : PTRain <"filename">

:MEMory : EXPort [:ASCii] : SEParator: COLumn
TAB|SEMicolon|{COMMa} | SPACe

:SEParator:COLumn?
:SEParator:DECimal

:MEMory : EXPort [:

:MEMory: EXPort [ :
{poT} | coMMa

ASCii]
ASCii]

— e
Load/Store

/

These softkeys provide
ease of use in changing
the pulse cycle settings
in the pulse train.

'

Inzert Item

Delete Item

Delete ALl Row

fore 2 of 2

:SEParator:DECimal?
:PTRain <"filename">
:SEParator:DECimal

:MEMory :EXPort [:ASCii]
:MEMory : IMPort [:ASCii]

:MEMory : IMPort [:ASCii]
{poT} | coMMa

:MEMory:IMPort [:ASCii] : SEParator:DECimal?
:MMEMory:LOAD:PTRain <"filename">
:MMEMory:STORe: PTRain <"filename">
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Figure 6-6 Display Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > Display Pulse Train

FREQUEHCY

6.000 000 000 00 &+

| PULSE]

RF_OFF

Tine offset:  2.00 USEC
Pulse Train

[T TN o oL

2.00us % 10. 00ufed7div 39. 00usec

AN

0370772012 11:44

Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 — Requires: Option UNW)

Train Display This softk hifts the ti
. is softkey shifts the time
Time ']nggﬁ offset from the left hand side

{1 of the display to the one

usec =
specified. Increments and
decrements are 1/20th of
Zoom In the visible pulse train.
Zoom Out

Use these softkeys to optimize
the view of the different
characteristics of the pulse

Zoom In Max train.

Zoom Out. Max

\ \ \Z/ \
This value cag be These are'the division markers currently AN
adjusted with the set at 10.00 us/div for the currently
Time Offset softkey. displayed view. Use the zoom softkeys N\
to change the time/div value.
AN AN
AN AN
AN AN
N\
FREQUEHCY RE_OFF
6.000 000 000 00 &z
| PULSE]
time oerset: 2,00 USEC
Pulse Train
.00bsec I 10. D0usec/div 39. Dﬂhsec
l<€~ 2nd and 3rd —p | 5th, 6th, and 7th
| pulse cycles |<— pulse cycles —>| |
| (elements) or | | (elements) or rows
rows 2 and 3. _‘» 5,6,and 7. I<—_'>|
| | -

o L 4th pulse cycle
This is the initial (element) or row 4.
pulse cycle (row 1)

note that the On
Time portion of this
pulse is not showing
due to the

2 us offset.

Final pulse cycle
(element) in the
displayed pulse
train above. 8th
pulse cycle or row.
number 8.

For details on each key, use key help as described on page 34.
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Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 — Requires: Option UNW)

Figure 6-7 Pulse Train: Import From Selected File Softkeys

For details on each key, use key help as described on page 34.
Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

FREQUEHCY RF_OFF Pulse Train
6.000 000 000 00 &+ ( Load/stores}—page 53
PULSE
Import /Exportk
Pulse Train meart /Exp
On Time Off Time  Repeat
1 2.000 us 2.000 us 1
2 3.000 us 2,000 us el Insert Item These softkeys delete
L 2.000 us 2.000 us 1 individual On Time or Off
9 3.000 us 2.000 us 3 Time elements as well as the
8 2.000 us 2.000 us 1 Delete Item Repeat cycle counts.
9 _______________________
Deleting all Pulse Cycle rows
Delete ALl Roust| — — | —(elements) must be
confirmed.
03/07/2012 11:54 HMore 2 of 2
Confirm Import .~
Confirm Import
From File
FREQUEHCY RF_OFF Import/Export
6.000 000 000 00 &z Imeert, From o
* Selected File
PULSE —
Export To,l hage 123
Cataloo of Binary Files in Int Storage 32.7MB used LBESME free File 9
File Hame Tupe Size Hodified
1 DISPLAY.EMP EIMARY 76918 22/03/068 .
2 DORMVIPH.LIC BINARY 52l 22/09/06 Delete File
o EILOR 925695 22/09,/06
] L 040510
L 55 OL/05/10 Goto RouM age 123
FTRAINZ.CSY EINARY 15 OL/05/10 09: Fig e ¢
HMPIMFO. KL BIMARY 296 22/09/06 22:37
Import Decimal
lEEﬁ:ar‘atDr‘ . .
Comma [~ Selects whether the decimal point
= ﬁ isa"." ora"," during import of
/ LS L s Hore 1 of 2 - CSVIASCII files.

This value is persistent across

E' PTRAIN.csv - Notepad This file’s data structure uses decimals in the numbers preset/recall and power cycles.
and so requires the Import Decimal Separator to be set to

Dot.

SCPI Commands:
:MEMory:IMPort[:ASCii]:SEParato
r:DECimal DOT|COMMa

:MEMory:IMPort[:ASCii]:SEParato

KF_OFF r:DECimal?
6.000 000 000 00 &z
PULSE
Note: Column
separated values are Pulse Train ) )
auto-detected by the On Time Off Time Repeat
instrument. % _a% %888 Hg % < . After confirming import of the file
o o th file’ Ise trai I
6 2.000 Us 3.000 Us 2 are displayed: o e
B _____

Pulse train imported as CSU
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Figure 6-8 Pulse Train: Export to File Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

l

Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 — Requires: Option UNW)

Note: Files can be FTP’d to the BIN (Binary) folder in the instrument, or a USB
stick can be used to download the files to the instrument. Refer to page 55.

FREQUENCY RE_OFF Tnport/Export
6.000 000 000 00 s+ Imeort EromY oo 10
PULSE
Export. TD’ - 0 [
Catalog of Binaru Files in Int Storaoe 32.6MB used  LESME free File
File Hame Tupe Size fodified Enter
1 DISPLAY.EMP EINARY FE918 22/09/06 )
2 DORMYIPM.LIC EINARY 524 22/09/06 Delste Filey
3 LAUNCHUS.EXE EINARY 925636 22/03/06 Goto Top Row
L PTRAIN.CSY EINARY 55 0L/05/10
Ll FTRATN. THT I 0G /05410 Goto Fouk 4
B FPADuG Goto HMiddle Row
Ieror‘% Decigﬁl
eparacar
Dot hﬁﬂ\ Goto Bottom Row
G /052010 0a:56 | Hore 1 FF 2

Import/Export > Tolumn Separator
Export. Column Selects whether the Selects whether the 9‘3'9"‘" . The Export to File softkey menu,
Separatore decimal point is a - Comma separator is a tab, ", *,” or “a writes out a CSV/ASCII file to the
or “,*” during export during export of the CSV/ASC” BINARY directory. You may supply
Export Decimal of the CSV/ASCII files. This valve is persistent your own extender as part of the
EeEEre e files. This value is Semicalon across preset/recall and power filename.
lEijCDI'ITI'EI [ persistent across cycles. Example:
preset/recall and SCPI Commands: MEM EXiD PTR "myfil "
power cycles. Tab :MEMory:EXPort[:ASCii]:SEParato EXP:PTR "myfile.csv".
SCPI Commands: r:.COLumn SCPI Command:
:MEMory:EXPort[:AS TAB|SEMicolon|COMMa|SPACe :MEMory:EXPort[:ASCii]:PTRAIn
Cii]:SEParator:DECi Space MEMowEXPmﬂASQﬂSEPwmo <"filename">
mal DOT|COMMa r.COLumn?
:MEMory:EXPort[:AS
Cii]:SEParator:DECi
mal?
\i
FREQUEHCY RF_OFF Text Entry
6.000 000 000 00 &z Enter
PULSE
Export to: pTRHINTXTI Clear Text
Cataloo of Binary Files in Int Storage 32.6MB used LESME free Use the text editor keys to
File Hame Tupe Size Nodified rename the file to be exported
1 DISPLAY.EMP EIMARY 76918 22/09/06 22:36 Editing Mode to the BIN (Binary) folder.
2 DRMVIPM.LIC EIMARY S2h 22/09/06 22:36 Ml Feplace
3 LHUNEHUS EHE EINARY 925696 22/09/06 22:36
B INARY i} DS 1D [oHE)
'} 0 Show Alpha Table
off
ABCDEFGHIJKLA
HOPORSTUMUZEYZ
u_fs8+L1]
Ol 05‘2010 0g:50

Note: Since there is already a file named PTRAIN.CSV the new
filename should be different, to avoid overwriting the original

PTRAIN.CSV file.

For details on each key, use key help as described on page 34.
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Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 — Requires: Option UNW)
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1 Basic Digital Operation—No BBG Option Installed

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter
3, “Basic Operation,” on page 33 and familiarize yourself with the information in that chapter.

See also “Adding Real-Time Noise to a Dual ARB Waveform” on page 229.
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Basic Digital Operation—No BBG Option Installed
1/Q Modulation

1/Q Modulation

The following factors contribute to the error vector magnitude:
¢ Differences in amplitude, phase, and delay between the I and Q channels

¢ DC offsets

The I/Q menu provides adjustments and calibration to compensate for some of the differences in the
I and Q signals or to add impairments. See I/Q Modulation on page 188 for additional information.

See also “Modulating the Carrier Signal” on page 48.

Figure 7-1 1/Q Display and Softkeys

This panel displays the current status and settings
This panel displays the external of the 1/Q adjustments. Grey text indicates 1/Q
1/Q signal routing. adjustments are off.

I/0 adijustments
I/0 Adjustments
0n

ANPLITUDE

00 000 00 &z -144
[T70]

1/0

I
ofr NG
External Input

I/0 Add ustr{gl;%?._ Adjustments

65.0000 .00 n

I/0 Routing & Optipization I/0 adjustments:/ OFf

I/0 CalibrationM— Setsthedc [ Ext In 170 AdJ |
-EHT IN -FlF ouT offset External Input
Ext Input Level I Offset
500 my rms 0.0000 W
Man  Mess
External Input
0 Offset
0.0000 W
04/09/2012 11:00  Hore 1 of 2 o T, e
0.000 d
Quadrature
1/0 Angle Adjustment
Ext In I/Q Atten 0.0
9.53 dB
Marual Offsets the phase of the Q signal
relative to the phase of the | signal.
The quadrature adjustment key is in
units of degrees. This adjustment is
not calibrated.
Y
I/0 Calibration Starts the I/Q calibration
Toggles between DC, User, and Full IQ calibration types. Foutlne for the seleﬁtedth
DC: Calibrates 1/Q offset, gain and quadrature error for a single Execute Cal —ézﬂggl%nrﬁ-;ggs(oﬂsfey e
frequency at the current signal generator settings. select the frequency range.)
This calibration requires that the 1/Q be on, the optimized path be set to Calibration Tupe You can abort the
RF Out, and the source be set to the internal baseband generator. — OC User ﬁi& calibration by pressing the
Changing any instrument setting except for I/Q adjustments after Abort Cal softkey or the
performing a DC calibration voids the DC calibration and causes the Local Cancel/(Esc) hardkey.
signal generator to revert to the factory supplied calibration data. If you abort the calibration,
. . . . the previous calibration data
User: Calibrates 1/Q offset, gain, and quadrature error for all signal is restored
generator settings over a range of frequencies that you define. . o
. . ) This calibration should be
Full: Calibrates 1/Q offset, gain, and quadrature error for all settings run when the ambient
over the full frequency range of the signal generator. temperature has varied by
Revert to at least +/-5 degrees
DBFEU%% Lal Celsius from the ambient
_ SEEES temperature at which the
For details on each key, use key help previous calibration was
as described on page 34. run.
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The following table shows common uses for the adjustments.

Table 7-1 1/Q Adjustments Uses

Basic Digital Operation—No BBG Option Installed
1/Q Modulation

I/Q Adjustment

Effect

Impairment

Offset

Carrier Feedthrough

dc offset

Quadrature Angle

EVM error

phase skew

I/Q Images

I/Q path delay

Configuring the Front Panel Inputs

The MXG/EXG accepts externally supplied analog I and Q signals through the front panel I Input and

Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel
Overview” on page 5.

a. Connect an analog I signal to the signal generator’s front panel I Input.

b. Connect an analog Q signal to the signal generator’s front panel Q Input.

2. Turn on the I/Q modulator: Press 1/Q 0ff On to On.

Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

4. Make adjustments to the I/Q signals (page 126) as needed.
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Basic Digital Operation—No BBG Option Installed
1/Q Modulation
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8 Basic Digital Operation (Option 653/655/656/657)

Before using this information, you should be familiar with the basic operation of the signal generator.
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter
3, “Basic Operation,” on page 33 and familiarize yourself with the information in that chapter.

The features described in this chapter are available only in vector signal generators with Option 653
or 655 (N5172B) or Option 656 or 657 (N5182B).

e Waveform File Basics on page 130

e Storing, Loading, and Playing a Waveform Segment on page 132
*  Waveform Sequences on page 135

e Saving a Waveform’s Settings & Parameters on page 139
* Using Waveform Markers on page 145

¢ Triggering a Waveform on page 162

¢ C(Clipping a Waveform on page 169

* Scaling a Waveform on page 178

¢ Setting the Baseband Frequency Offset on page 184

* I/Q Modulation on page 188

* [/Q Adjustments on page 192

¢ [/Q Calibration on page 194

* Using the Equalization Filter on page 196

e Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter on page
198

* Modifying a FIR Filter Using the FIR Table Editor on page 204
e Setting the Real-Time Modulation Filter on page 208
e Multiple Baseband Generator Synchronization on page 209

* Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator
Synchronization on page 216

*  Waveform Licensing on page 221

See Also:
* Adding Real-Time Noise to a Dual ARB Waveform on page 229
¢ Real-Time Phase Noise Impairment on page 238

e Multitone and Two-Tone Waveforms (Option 430) on page 297
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Basic Digital Operation (Option 653/655/656/657)
Waveform File Basics

Waveform File Basics

There are two types of waveform files:
e A segment is a waveform file that you download to the signal generator.
For information on creating and downloading waveform files, refer to the Programming Guide.

* A sequence is a file you create in the signal generator that contains pointers to one or more
waveform files (segments, other sequences, or both).

For information on creating sequences, see page 135.

Signal Generator Memory

The signal generator has two types of memory:

¢ Volatile memory, baseband generator (BBG) media, where waveform files are played from or
edited.

e Nomn-volatile memory, either internal (int) or external (USB) media, where waveform files are
stored.

Dual ARB Player

NOTE The MXG/EXG’s ARB Waveform File Cache is limited to 128 files. Consequently, once the 128
file cache limit has been reached, the waveform switching speed will be much slower for
additional files loaded into the volatile waveform memory (BBG).

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or
internal) waveform files in addition to building waveform sequences. The dual ARB waveform player
also provides markers (page 145), triggering (page 162), clipping (page 169), and scaling (page 178)
capabilities.

Most procedures in this section start from the Dual ARB menu, shown below.

130 Agilent MXG and EXG X-Series Signal Generators User’s Guide



selecty] page 132

Figure 8-1 Dual ARB Softkeys
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Basic Digital Operation (Option 653/655/656/657)
Storing, Loading, and Playing a Waveform Segment

Storing, Loading, and Playing a Waveform Segment

NOTE The MXG/EXG’s ARB Waveform File Cache is limited to 128 files. Consequently, once the 128
file cache limit has been reached, the waveform switching speed will be much slower for
additional files loaded into the volatile waveform memory (BBG).

Before using this information, you should be familiar with the signal generator’s file menus. If you
are not, refer to “Working with Files” on page 50 and familiarize yourself with that information.

See also: “Waveform Sequences” on page 135.

The signal generator has two types of waveform media: non-volatile (internal or USB), and volatile
(BBG). BBG media is also called “working” media, because before you can play, edit, or include a
waveform file in a sequence, the waveform file must be loaded into BBG media.

Figure 8-2 Waveform Segment Softkeys
Note: When a sequence is selected, this key name

Mode (7D U page 145 ——panges to Show Waveform Sequence Contents.
Arb Select Havefarm
AFE (=hONE=) Arb Seaments
an
Y Display Waveform, Stare Arb Seoments
NModulation Hode And Markers
Select, » FRename Seoment
Dual AREMH— HEEHEr Haveform Load Seoment
Seament.s® From Int Media
Arb Setupk Goto FRowe
ARE Custom Load All
Modulat fon” From Int Media Text Entry
Trioger Tupe
Feal-Time Custom (EDEtinuausib Enter
= ree Run
Modulat ion Goto Roue Delete Seamentk
Real-Time, SDeletE ﬂél Clear Text
i i eaments Onk
ApPplications fore 1 of 2 SEnies N
it.ing Mode
__Tlore 1 of = — Ml Feplace
Mult itonek P
Hore 1 of 2 These keys change to indicate the default media. Shiok ﬂlDB?FTale
For information on selecting the default media, LoD
see page 61.
FBCDEFGHIJELN
HOPORSTUVHXEYZ
For details on each key, use key hel Use the arrow keys or knob to
A yhew highlight a letter or character. —————— u-$s8+L1

as described on page 34.

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included in a sequence.
Cycling power or rebooting the signal generator deletes the files in BBG media.

NOTE Each time the instrument powers up, two factory-supplied segments are automatically
created in BBG media: RAMP_TEST WFM and SINE TEST WFM.

There are additional sample waveforms that are available in the internal storage and that
can be loaded into memory. Refer to www.agilent.com and search on “Factory Default

N5182B” and “waveforms”.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.
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Basic Digital Operation (Option 653/655/656/657)
Storing, Loading, and Playing a Waveform Segment

2. Press Load Store to highlight Load, then use the arrow keys to highlight the desired waveform
segment.

3. If there is already a copy of this segment in the currently selected media and you do not want to
overwrite it, rename the waveform segment before you load it (refer to the previous procedure).

4. Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press
Load All From currently selected Media.

Storing/Renaming a Waveform Segment to Internal or USB Media

Use the following steps to store a copy of a file in BBG memory to the currently selected media
(page 61). If you have not downloaded a waveform segment, either refer to the Programming Guide,
or use one of the factory-supplied segments.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Store.

3. Using the arrow keys, highlight the waveform segment you want to store.
4. Optionally, rename the segment.

If there is already a copy of this segment in the currently selected media and you do not want to
overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.

b. Enter a name for the waveform segment.

c. Press Enter > More.

d. Highlight the waveform segment that was renamed.

Press Store Segmentto currently selected Media.
6. Repeat Step 3 through Step 5 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press
Store All to currently selected Media.

Playing a Waveform Segment

1. Press Mode > Dual ARB > Select Waveform.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.
3. Press Select Waveform.

4. Set ARB 0ff On to On.

This plays the selected waveform segment. Both the I/Q and ARB annunciators turn on, and the
waveform modulates the RF carrier.
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Basic Digital Operation (Option 653/655/656/657)
Storing, Loading, and Playing a Waveform Segment

FREQUEHCY

ARB

Annunciators display with active waveform (ARB On)
Arb
ARE

0ff N

Select,

Selected Uaveform: WFM1:RAMP_TEST_NFN
Filter: Off B

Trig Tupe: Continuous (Free Run)

Pouer Search Reference: RMS
AWGH: Off

Haveform

On
Arb Setupk

Trigoer Tupe
(Cont inuous ,»
Free Run.

Current waveform selection

Fhase Moise: Off
03/03/2012 19:17

5. Configure the RF Output:

fore 1 of 2

Set the RF carrier frequency and amplitude, and turn on the RF output.

The waveform segment is now available at the signal generator’s RF Output connector.
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Basic Digital Operation (Option 653/655/656/657)
Waveform Sequences

Waveform Sequences

Figure 8-3 Waveform Sequence Softkeys
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For details on each key, use key help
as described on page 34.

A waveform sequence is a file that contains pointers to one or more waveform segments or other
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or
other sequences, or both thereby eliminating the need to stop waveform playback just to select
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the
sequence; you must also store the individual segments or they are lost when you turn off or reboot
the signal generator. If the segments are located in internal/external media, you must load them into
BBG media prior to selecting a waveform sequence (see page 132). If you attempt to play a sequence
without the segments loaded into BBG media, the signal generator reports: ERROR: 629, File
format invalid. If this happens and the segments are not stored in internal/external media, you
must recreate the segments using the same file names that the sequence points to before you can
play the sequence.
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Waveform Sequences

Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other sequences
(nested sequences). The signal generator lets you set the number of times the segments and nested
sequences repeat during play back. But there is a difference between repeating a segment versus
repeating a nested sequence. Each segment can repeat up to 65,535 times, but no matter how many
times a segment repeats, it counts as a single segment. However each repetition of a nested sequence
counts as additional segments.

—— Segment 1
Sequence A —| 2 segments
L Segment 2
Waveform 11 segments
Sequence Sequence AN\ ¢
— egments
Sequence B —] repeated 4x 9 segments

L Segment 3

The maximum number of times that a nested sequence can repeat is based on the number of
segments in the nested sequence and the remaining number of allowed segments (1,024). For
example, with a sequence that contains 24 segments and one nested sequence with 4 segments, the
nested sequence is limited to 250 repetitions:

24 + (4 x 250) = 1,024 maximum number of segments per sequence

Even though there is a limiting factor on the maximum number of times that a nested sequence can
repeat, each segment within the nested sequence can repeat up to 65,535 times.

Example

Use the following procedure to create and store a waveform sequence using one repetition each of
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on loading
waveform segments into BBG media, see page 132.

1. Select the first segment:

a. Press Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence > Insert
Waveform.

b. Highlight the desired waveform segment and press Insert.
2. Select the second segment:
a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting

136 Agilent MXG and EXG X-Series Signal Generators User’s Guide



Basic Digital Operation (Option 653/655/656/657)
Waveform Sequences

3. Name and store the waveform sequence to the Seq file catalog:
a. Press More > Name and Store.
b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 137 and “Setting Marker Points in a
Waveform Segment” on page 152.

Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence:

Through the Waveform Sequences Softkey
1. Press Mode > Dual ARB > More > Waveform Sequences.

2. Highlight the desired sequence.

3. Press Show Waveform Sequence Contents.

Using the Select Waveform Softkey
1. Press Mode > Dual ARB > Select Waveform.

2. In the Sequence On column, highlight the desired waveform sequence.

3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

* change the number of times each segment or nested sequence plays

* delete segments or nested sequences from the sequence

e add segments or nested sequences to the sequence

* toggle markers on and off (described on page 158)

* save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

CAUTION If you edit and resave a segment used in a sequence, the sequence does not
automatically update the RMS value in its header. You must select and update the
sequence header information (page 139).

Use the following steps to edit a sequence that has two different segments so that the first segment
repeats 100 times and the second segment repeats 200 times, then save the changes.

Assumption: A waveform sequence that has two different segments has been created and stored (see
previous example on page 136).

1. Select the sequence:
Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence >
Edit Selected Waveform Sequence.
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Waveform Sequences

Change the first segment so that it repeats 100 times:
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry.

Change the repetition for the selected entry to 200:
Press Edit Repetitions > 200 > Enter.

Save the changes made in the previous steps:
Press More > Name and Store > Enter.

To save the changes as a new sequence:

a. Press More > Name and Store > Clear Text.
b. Enter a file name (for example, SINE100+RAMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence.

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 136.

NOTE To play a waveform segment individually or as part of a waveform sequence, the segment

must reside in BBG media. See also, “Loading a Waveform Segment into BBG Media” on

page 132.
1. Select a waveform sequence:
a. Press Mode > Dual ARB > Select Waveform.
b. Highlight a waveform sequence (for this example, SINE100+RAMP200) from the Sequence On
column.
c. Press Select Waveform.
The display shows the currently selected waveform (for example, Selected Waveform:
SEQ:SINE100+RAMP200).
Annunciators display with active waveform (ARB On)
FREQUENCY Arb
6.000 000 000 0Q e
. A 0ff N
m Se%ect'
HRB Dn Fvetorm
|SElEl:tEl:I Haveform: SEQ:SINE100+RANMP200| a
12 L I0CkK . AU DIOCCCorTS. i SRiEUE
Filter: Off
Trioger Tupe
Current waveform selection (Cont inuous ,»
Trig Tupe: Continuous (Free Run) IFrEE R
Pouer Search Reference: RMS
ALGM: Off Fhase Moise: Off
03/04/2012 15:36  Hore 1 of 2
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Basic Digital Operation (Option 653/655/656/657)
Saving a Waveform’s Settings & Parameters

2. Generate the waveform:
Press ARB 0ff On to On.

This plays the selected waveform sequence. During the waveform sequence generation, both the
I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier.

3. Configure the RF output:

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector.

Saving a Waveform's Settings & Parameters

This section describes how to edit and save a file header. When you download only a waveform file
(I/Q data, which the signal generator treats as a waveform segment), the signal generator
automatically generates a file header and a marker file with the same name as the waveform file.
Initially the file header has no signal generator settings saved to it, and the marker file consists of all
zeros. For a given waveform, you can save signal generator settings and parameters in its file header
and marker settings in its marker file (page 145); when you load a stored waveform file into BBG
media, the file header and marker file settings automatically apply to the signal generator so that the
dual ARB player sets up the same way each time the waveform file plays.

Figure 8-4 Header Utilities Softkeys

Mode > Dual ARB > - Edit. Header
More > - Edit Neader
Header Utilities Edit Header Enter
5 Enter
Edit
Description®] page 142 Unspecified
Edit Unspecified
>
S Calculate
Edit AHGH, ‘
RMS Override”
Header File
Clear Header 5 Stor‘gd
Edit Header _— Eaments
Header File
Save Setup
To Header Select Header Seguence
For details on each key, _More 1 of 2 __ 1 g 0; F%elec%
use key hel ifferentH— Catalog Tupe
as desgribez on IREEEEr (BEG Segments) [~ B0 Seanents
page 34.

When you create a waveform sequence (as described on page 136), the signal generator automatically
creates a waveform sequence header that takes priority over the individual waveform segment
headers. During a waveform sequence playback, the segment headers are ignored, except to verify
that all required options are installed. Storing a waveform sequence also stores its file header.

Some of the current signal generator settings shown in the file header appear as part of the softkey
labels, and others appear in the dual ARB summary display, shown in the following example.
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FREQUEHCY

ARB

Filter: Off

6.000 000 000 00 &+

Selected laveform: WFM1:RAMP_TEST_UFMN
Art Sample Clock: 200.000000000MHz

All settings in this menu can be stored to
the file header (Table 8-1 on page 140

AMPLITUDE lists all settings stored in a file header)

0.00 den

Arb Setup

Softkey label,
Arb Sample Clock .— file header
Z200. 000000000MHz setting
off
Real-Time ALGN,
Setup
Feal-Time .
Phase Noise Setup® The Runtime

Scaling softkey is

leG: 0Ff

Trig Tupe: Continuous (Free Run)

Pouer Search Reference: Fixed

only available under
the Dual ARB menu.

Funt.ime Scaling
70.00 X

i - Modulator Atten
03/0L /2012 16:01 E.00 dB

I
ARB summary, file
header settings

Table 8-1 File Header Entries

Hore 1 of 2 Softkey labels,
file header
settings

Arb Setup
see page 184 —— Easeband
Freguency Offset
0.000 Hz

Hulti—BBGSSgnc

Feal-Time
Modulation Filtere
(Off2

fore 2 of 2

32-Character Description A description entered for the header, such as a the waveform’s function (saved/edited with the Edit

Sample Rate

Runtime Scaling

RMS

Marker 1...4 Polarity

ALC Hold Routing

Description softkey, see Figure 8-4).

The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown
in Figure 8-1 on page 131).

The Runtime scaling value is applied in real-time while the waveform is playing. This setting can be
changed only for files playing in the dual ARB player (see page 181).

When the modulator attenuation setting (see page 131) is set to Auto, this value is used to calculate
the I/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562.

Marker polarity can be positive or negative (described on page 158).

Which marker, if any, implements the ALC hold function (described on page 147), which holds the
ALC at its current level when the marker signal is low. All waveforms generated in the signal
generator have a marker on the first sample point. To see the results from the three routing
selections, you may need to select a range of sample (marker) points (see “Setting Marker Points in
a Waveform Segment” on page 152).
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RF Blank Routing

Mod Attenuation

BB Freq Offset
AWGN: State
AWGN: C/N Ratio
AWGN: Carrier BW
AWGN: Noise BW
AWGN: Carrier RMS
Phase Noise State
Phase Noise F1
Phase Noise F2
Phase Noise Lmid
Modulation Filter
Over-Range Protect
Unique Waveform Id

License Required

Can be Read Out

Viewing and Modifying Header Information

Basic Digital Operation (Option 653/655/656/657)
Saving a Waveform’s Settings & Parameters

Which marker, if any, implements the RF blanking function (described on page 156) when the
marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold
Routing for the same marker when you are using the RF Blank Routing function. When the marker

signal goes high, RF blanking discontinues.

The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 8-1 on

page 131).

The baseband frequency offset, in Hz (see page 184).

Indicated whether real-time noise is on (1) or off (0) (see page 229).

Carrier to noise ration, in dB (see page 234).

Bandwidth over which the noise power is integrated, in Hz (see page 234).

Bandwidth of the noise, in Hz (see page 234).

The carrier RMS across the carrier bandwidth (see page 234).

Indicated whether phase noise is on (1) or off (0) (see page 238).

The start frequency for the level mid-frequency characteristics (see page 238).

The end frequency for the level mid-frequency characteristics (see page 238).

The amplitude for the level mid-frequency characteristics (see page 238).

The real-time modulation filter type selected (see page 208).

Indicated whether DAC Over-Range Protection is on (1) or off (0) (see page 242).

0 = no Id; once an Id is assigned, it cannot be changed.

Indicates whether a license is required to play the waveform. See also: “Viewing Options and

Licenses” on page 30

Indicates whether the waveform can be queried through SCPI or FTP.

The following example uses the factory-supplied waveform file RAMP TEST WFM.

1. From BBG media, select the waveform RAMP TEST WFM:
a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On column, highlight the waveform RAMP TEST WFM.

c. Press Select Waveform.

2. Open the Header Utilities menu:

Press More > Header Utilities

The Figure 8-5 shows the default file header for the factory-supplied waveform RAMP TEST WFM.
The Header Field column lists the file header parameters; use the Page Down key to see them all.

The Saved Header Settings column shows that most of the settings are Unspecified.
Unspecified means that there is no setting saved for that particular parameter.
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The Current Inst. Settings column shows the current signal generator settings. In this
example, these are the settings that you will save to the file header.

NOTE If a setting is unspecified in the file header, the signal generator uses its current value for
that setting when you select and play the waveform.

Figure 8-5 Example File Header

rees The name of the waveform file.
Mode > Dual ARB > More > Header Utilities

FREQUEHCY ANPLITUDE ader
: The description can be up to
Edit
6.000 000 000 00 GHz 0.00 dBm Descpiption*—32—characters_
Edit
File Header Information :mmnnnnpjmulm < = RMS"|  Opens a menu for manually
Header Field Saved Aeader setiings  Current Inst. Settings defining the carrier RMS value
Descript ion Rame (I down, O up) HHSESR HL_JEN’ |__to use for calculating the
wertide . i i

Sample Rate Unspeci fied 200.000000000MHz the Hoador Fiom, 18 valuein
JRunt.ime Scalin 78.78 X 78.78 X :
RIS 0.814852207 ) M/A Clear Header +—Resets th
Marker 1 Polarity A Unspecified Fos h::gesr Se?t;]avsed
Marker 2 Polaritu T Unspecified Fos : 9
Marker 3 Polarity | Unspecified Pos Save Setup | ©ntries to default
Marker L Polarity | Unspecified Pos To Header settings
ALC Hold Routing Unspecified Mone

03/04 /2012 16:01 fore 1 of 2 -

Edit. Header
Default header settings Current signal generator settings Enter
To calculate the RMS waveform voltage:
Press Calculate Unspecified

I—————Then refer to Header Field information.

Note: For greater accuracy, if the waveform has long rise/fall times, a DC Calculate
offset, or noise* already added to the waveform (for a bursted signal), it
is recommended that the Edit RMS and Edit AWGN RMS Override

softkeys are used for the best measurement accuracy.

*Option 403 Real-time AWGN does not affect the Header Field RMS
value. But, noise added to the waveform prior to downloading and
playing in the signal generator does affect the Header Field RMS value.

3. Save the information in the Current Inst. Settings column to the file header:
Press Save Setup To Header.
Both the Saved Header Settings column and the Current Inst. Settings column now display
the same values; the Saved Header Settings column lists the settings saved in the file header.
4. Edit and Update Settings

a. Return to the ARB Setup menu:
Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the file
header. Figure 8-1 on page 131 shows the ARB Setup softkeys used in the following steps.

b. Set the ARB sample clock to 56 MHz:
Press ARB Sample Clock > 5 > MHz.

c. Set waveform runtime scaling to 60%:
Press Waveform Runtime Scaling > 60 > %.
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d. Return to the Header Utilities menu:
Press Return > More > Header Utilities.

As shown in the following figure, the Current Inst. Settings column now reflects the
changes to the current signal generator setup, but the saved header values have not changed.

FREQUEHCY ANPLITUDE Edit. Header
Edit
6.000 000 000 00 &z 0.00 den pescr £t
Edit, Values differ between
File Header Information: WFHLzRANP_TEST_UFN . RMS") __— the two columns
Header Field Saved Header Settings Current Inst. Settings
Description Rame (I down, O up) Edit AMGM,
RMS Override
Sample Rate .
Funt.ime Scaling 78.78 X
RS 0. 8ILEEZE07 WA
Marker 1 Polarity Pos Pos Clear Header
Marker 2 Polarity Pos Pos
Marker 3 Polarity Pos Pos
Marker L Polarity Pos Pos S?SEHggégﬁ
ALC Hold Routing Mone Mone
030472012 16:17 fore 1 of 2

e. Save the current settings to the file header:
Press the Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear in the Saved Header
Settings column. This saves the new current instrument settings to the file header.

If you change any of the signal generator settings listed in the file header after you select the
waveform file, the changed setting(s) appear in the file header’s Current Inst. Settings column
and are used instead of the saved header settings. To reapply the saved header settings, reselect the
waveform for playback.

Viewing & Editing a Header without Selecting the Waveform

As described on page 141, you can view and edit a waveform’s header information after you select
the waveform; you can also edit waveform header information without selecting a waveform, or for
another waveform than the one that is currently selected.

1. Access the file header utilities menu:
Press Mode > Dual ARB > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was last
selected. The following figure shows an example of the factory-supplied waveforms in BBG media.
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Active media

Header File

Active waveform catalog
Select Header

Cataloa Tupe
(BEG Seoments) /I~ |

LB used 3.87GE free

Nodified

03/04/2012 16:20

y
Header File
Type: ) Stored Catalogs that enable you to
\lilv\/FVMVI‘ll; Vo’\ljatlle\f,elgnlwerét Seanents view files in the active media.
= Non-Volatile Segment
SEQ = Sequence ¢ For details on selecting the
Sequence active media, see page 52.

BBG Seoments

Files in BBG media —

For details on each key, use key help
as described on page 34.

2. If the desired catalog is not displayed, select it.
3. Highlight the desired waveform file and press Select Header.
The signal generator displays the file header for the selected waveform file.

4. To edit the header, press More, and proceed as described in Step 4 on page 142 (Viewing and
Modifying Header Information section).
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Using Waveform Markers

The signal generator provides four waveform markers to mark specific points on a waveform segment.
When the signal generator encounters an enabled marker, an auxiliary signal is routed to a rear
panel event output that corresponds to the marker number.

* Event 1 is available at both the EVENT 1 BNC connector (see page 16), and a pin on the
AUXILIARY I/O connector (see page 17).

* Event 2 is available at the TRIG 1 & TRIG 2 connectors (see page 13), and a pin on the
AUXILIARY I/O connector (see page 17).

¢ Events 3 and 4 are available at pins on the AUXILIARY I/O connector (see page 17).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer
to “Using Waveform Markers” on page 145 for details.

When you download a waveform file that does not have a marker file associated with it, the signal
generator creates a marker file without any marker points. Factory-supplied segments
(RAMP_TEST WFM and SINE TEST WFM) have a marker point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player.
These procedures also discuss two types of points: a marker point and a sample point. A marker
point is a point at which a given marker is set on a waveform; you can set one or more marker
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:
Clearing Marker Points from a Waveform Segment on page 151
Setting Marker Points in a Waveform Segment on page 152

Controlling Markers in a Waveform Sequence on page 158

This section also provides the following information:

¢  Waveform Marker Concepts on page 146

¢ Accessing Marker Utilities on page 150

¢ Viewing Waveform Segment Markers on page 151

e Viewing a Marker Pulse on page 155

¢ Using the RF Blanking Marker Function on page 156
¢ Setting Marker Polarity on page 158
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Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers for use on a waveform segment.
You can set each marker’s polarity and marker points (on a single sample point or over a range of
sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

J_L Positive 4% EVENT N

Mlgirlzer > O —|— Marker N
Bit N o —|_|— RF Blank Off On
Set Marker Marker : /Q Blar':/lgrlg?:rvls\/lhen
- On Off Polarity Negative Marker is Low
|—
When the signal generator encounters an enabled marker (described on page 158), an : RF Blank Only: includes ALC Hold
auxiliary output signal is generated and routed to the rear panel. :
. . . / Marker N

Event 1 is available at the EVENT 1 BNC connector (see page 16), and at a pin on the 5 » Holds ALC when
AUXILIARY I/O connector (see page 17). Marker is Low
Events 2 through 4 are available at pins on the AUXILIARY 1/O connector (see page 17). Marker N

ALC Hold Off On

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator.
However some settings such as amplitude, filters, and so forth within the RF output path can create
delays between the marker EVENT output signal and the modulated RF output. When using the
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency,
and if needed, reset the marker point positions, include delay (page 192), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker
file associated with it causes the signal generator to automatically create a marker file, but does not
place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG media
(see “Loading a Waveform Segment into BBG Media” on page 132).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator,
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the marker
polarities or routing (RF Blanking and ALC Hold) and save the information to the file header

(page 139).

NOTE When you use a waveform that does not have marker routings and polarity settings stored in
the file header, and the previously played waveform used RF Blanking, ensure that you set
RF Blanking to None. Failure to do so can result in no RF output or a distorted waveform.
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either before
or after you set marker points (page 152), setting a marker function before setting marker points may
cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods,
burst ramps, or when the increased dynamic range encountered with RF blanking (page 156) is not
desired.

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output
signal (the carrier plus any modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

NOTE Because it can affect the waveform’s output amplitude, do not use the ALC hold for longer
than 100 ms. For longer time intervals, refer to “Power Search Mode” on page 102.

Markers set to account for marker
response relative to RF output

RF OUTPUT =>>

i
-"-

<<
Marker _ﬂ 2> ”
Positive Polarity
¢ 100 ms »:
. Max ALC hold time .
CAUTION Incorrect ALC sampling can create a sudden unleveled condition that may create a spike

in the RF output, potentially damaging a DUT or connected instrument. To prevent this
condition, ensure that you set markers to let the ALC sample over an amplitude that
accounts for the higher power levels encountered within the signal.
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Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the waveform’s area of

highest amplitude. Note that the marker is set well before the
waveform’s area of lowest amplitude. This takes into account any
response difference between the marker and the waveform signal.

(e e
Wb f,{ il

i
U R R
L

il

Close—up of averaging

The ALC samples the waveform when the marker signal goes
high, and uses the average of the sampled waveform to set the
ALC circuitry.

Here the ALC samples during the on marker points (positive
polarity).

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Positive

This example shows a marker set to sample the low part of the
same waveform, which sets the ALC modulator circuitry for Marker
that level; this usually results in an unleveled condition for the
signal generator when it encounters the high amplitude of the
pulse.

Marker

\l_l. 1=' D

Pulse Unleveled
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Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative

This figure shows that a negative polarity marker goes low during
the marker on points; the marker signal goes high during the off | Marker On  Marker | . eron -
points. The ALC samples the waveform during the off marker Of

points.

Sample range begins on first point of signal

Sampling both on and off time sets the modulator circuitry
incorrectly for higher signal levels. Note the increased amplitude
at the beginning of the pulse.

Negative range set between signal and
off time
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Accessing Marker Utilities

Mode > Dual ARB > More > Marker Utilities

Arb Harkers

Marker Polaritupf———9

For details on each key, use key help
as described on page 34.

Harker Polarity

Marker 1 Polarit
Heg lﬁ

The settings in these menus

Marker 2[\1281% < can be stored to the file
header, see page 139.
Note: This is the Marker Routingw: Markar 3 Polarit
second Arb menu. arker Neg Eﬁ
Set Markersk Marker L Polarit NMkr To ALC Hold
arker 0lari r To 0.
Heg lﬁ ;
/,r" Mkr To Pulse
—* Hone
page 42— Foute To i
. EINES' Narker Routing
Pulse/RF Blank,
(Mone* Marker 1
> —>
Marker Range ALC Hold,
First Mkr PDini‘I (one)” ferker 2
Harker R Elt?r_“gage
arker Range melituder Marker 3
Last Mkr Point (None )
200 First Mkr Point
Arb Harkers 1
I Marker L
Marker # Skipped Points
2 3L 0 Last Mkr PDEiBB

Set Marker On
First Point

Set. Marker On,|
Range 0Of Points

Set Marker Off,

F————® Applu To Haveform

-

Range 0F Points®

Displad Haveform,)
And Markers®]

FREQUEHCY

6.000 000 000 00 &+

ARB uauefur‘m And Markers
UFNL :RANP_TEST_WFTI

o Apply To Hawveform

ANPLITUDE Harker

-144.00 den

The display below shows the | and Q components of the waveform, and

First sample point
shown on display

First
Sample Poin%

These softkeys change
the range of waveform
sample points shown

Zoom In

FLm=\o -

Zoom Out. on the marker display.

Each press of the
Zoom In Hax softkey changes the
sample range by
approximately a factor
Zoom Out. Max of two.

Marker points
on first /‘

sample point

Sample Point

28
03/05/2012 12:12
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a
segment (this example uses the factory-supplied segment, SINE TEST WFM).

1. In the second Arb menu (page 150), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE TEST WFM).
3. Press Display Waveform and Markers > Zoom in Max.

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to
existing points. Because markers are cumulative, before you set points, view the segment (page 151)
and remove any unwanted points. With all markers cleared, the level of the event output signal is OV.
To clear marker points on a segment, the segment must reside in BBG media (page 132).

Clearing All Marker Points
1. In the second Arb menu (page 150), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment (in this example, SINE TEST WFM).

3. Highlight the desired marker number: Press Marker 123 4.

4. For the selected marker number, remove all marker points in the selected segment:
a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of the
waveform. The factory-supplied waveform (SINE TEST WFM) contains 200 samples. To clear all
set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from Step 3 for any remaining marker points that you want to remove from the other
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10-20. This
makes it easy to see the affected marker points. The same process applies whether the existing points
are set over a range or as a single point (page 152).‘

1. In the second Arb menu (page 150), press Marker Utilities > Set Markers, then select Marker 1.

2. Set the first sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

3. Set the last marker point in the range that you want off to a value less than or equal to the
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this
example, 17):
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Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

. . Arb uavefl:lr‘m And Markers
This turns off all marker points for UFI1 :STHE_TEST_UIFH
the active marker within the range I
set in Steps 2 and 3, as shown at 0
right. %
How to view markers is described E
on page 151. 1 Sample Point 28

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 151, but set both the first
and last marker point to the value of the point you want to clear. For example, if you want to clear
a marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 132).

When you set marker points, they do not replace points that already exist, but are set in addition to
existing points. Because markers are cumulative, before you set marker points within a segment, view
the segment (page 151) and remove any unwanted points (page 151).

Placing a Marker Across a Range of Points
1. In the second Arb menu (page 150), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: Press Marker1234

4. Set the first sample point in the range (in this example, 10):
Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.
6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends
on sample point 20, as shown in the following figure.

Arb uauefur‘m And Markers
UFN1:STHE_TEST_UFNI

FwMe O H

1 Sample Point 28

How to view markers is described on page 151
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Placing a Marker on a Single Point

On the First Point

1. In the second Arb menu (page 150), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment.

3. Select the desired marker number:
Press Marker1234.

4. Press Set Marker On First Point.
This sets a marker on the first point in the segment for the marker number selected in Step 3.
On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on page 152, but set both the
first and last marker point to the value of the point you want to set. For example, if you want to set
a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped
points) between each marker. You must set the spacing before you apply the marker settings; you
cannot apply skipped points to a previously set range of points.

NOTE The skipped points value is limited to the size of the range of points.

1. Remove any existing marker points (page 146).

2. In the second Arb menu (page 150), press Marker Utilities > Set Markers.
3. Highlight the desired waveform segment.
4

Select the desired marker number:
Press Marker1234.

5. Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range. (The last marker point value must always be less than or
equal to the number of points in the waveform, and greater than or equal to the first marker
point, in this example, 25):

Press Last Mkr Point > 25 > Enter.

7. Enter the number of sample points that you want skipped (in this example, 1):
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.
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This causes the marker to occur on ArD Liaverorn And fiarkars
every other point (one sample point is UFHL:STHE_TEST_IIFN
skipped) within the marker point range, I
as shown at right. 0
How to view markers is described on %
page 151. E
1 Sample Point 28

One application of the skipped point
feature is the creation of a clock signal
as the EVENT output.
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Viewing a Marker Pulse

When a waveform plays (page 138), you can detect a set and enabled marker’s pulse at the rear
panel event connector/Aux I/O pin that corresponds to that marker number. This example
demonstrates how to view a marker pulse generated by a waveform segment that has at least one
marker point set (page 152). The process is the same for a waveform sequence.

This example uses the factory-supplied segment, SINE TEST WFM in the dual ARB Player.
Factory-supplied segments have a marker point on the first sample point for all four markers, as
shown.

Arb Waveform And Markers
Marker points on UFN1 :SIHE_TEST_UFH
first sample point of I

waveform segment

FLrde

]

1 Sample Point 28

How to view markers is described on page 151
In the first Arb menu (page 131), press Select Waveform.
Highlight the SINE TEST WFM segment and press Select Waveform.
Press ARB Off On to On.

Connect the signal generator’s rear panel Q OUT output to the oscilloscope’s channel 1 input.

S

Connect the signal generator’s rear panel EVENT 1 output to the oscilloscope’s channel 2 input.

When marker 1 is present, the Agilent MXG/EXG outputs a signal through EVENT 1 as shown in
the following example.

QOouT

Marker pulse on the Event 1 signal.

T [eed mIE
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the Marker
Utilities menu) either before or after setting the marker points (page 152), setting a marker function
before you set marker points may change the RF output. RF Blanking includes ALC hold (described
on page 147, note Caution regarding unleveled power). The signal generator blanks the RF output

when the marker signal goes low. This example is a continuation of the previous example, Viewing a
Marker Pulse.

1. Using the factory-supplied segment SINE TEST WFM, set Marker 1 across points 1-180 (page 152).
2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1:

In the second Arb menu (page 150), press Marker Utilities > Marker Routing > Pulse/RF Blank > Marker
1.
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Marker Polarity = Positive

When marker polarity is positive (the default
setting), the RF output is blanked during the off
marker points.

ov

Marker Polarity = Negative

When marker polarity is negative, the

RF output is blanked during the on marker
points

ov
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.
1. In second Arb menu (page 150), press Marker Utilities > Marker Polarity.
2. For each marker, set the marker polarity as desired.

e The default marker polarity is positive.

* Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 146.

As shown on page 156:
Positive Polarity: On marker points are high (=3.3V).
Negative Polarity: On marker points are low (0V).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.

Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed
to the rear panel EVENT output (described in “Rear Panel Overview” on page 12) corresponding to
that marker number. For a waveform sequence, you enable or disable markers on a
segment-by-segment basis; this enables you to output markers for some segments in a sequence, but
not for others. Unless you change the sequence marker settings or cycle the power, the marker setting
for the last segment edited in the sequence applies to all segments in the next sequence that you
build. For information on building a waveform sequence, see “Creating a Sequence” on page 136.
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Figure 8-6 Waveform Sequence Menus for Enabling/Disabling Segment Markers

Mode > Dual ARB >
More
AN
\
Arb
Haweform,
Sequences

Haveform,
Utilities

Marker,
Utilities

Header,
Utilities

fore 2 of 2

Note: This is the second Arb menu.

Arb Sequences

Build Mew,

b

Haveform Sequence”

Edit Selected,
Haveform Sequence

Shon Haveform,
Sequence Contents

Delete

Haveform Sequence

Goto FRowe

Arb Sequences

L

For details on each key, use key help

as described on page 34.

Insert,
Haveform

Delete Selected
Haveform

Delete ALl
Haveforms

Edit Repetitions
Ermable/Dissble,
Markers

fore 1 of 2

Arb Sequences

Goto FRowe

Arb Sequences

Insert,
Haveform

Delete Selected
Haveform

Delete ALl
Haveforms

Edit Repetitions

Ermable/Dissble,
Markers

fore 1 of 2

Arb Sequences

Edit a sequence to
enable/disable markers

Enable/Disable markers while
creating a waveform sequence

Arb Harkers

Togole Marker 1

Togole Marker 2

Toggole Marker 3

Togole Marker L

Goto FRowe
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s
markers independently. You can enable or disable the markers either at the time of creating the
sequence or after the sequence has been created and stored. If the sequence has already been stored,
you must store the sequence again after making any changes. Enabling a marker that has no marker
points has no effect on the auxiliary outputs. To set marker points on a segment, see “Setting Marker
Points in a Waveform Segment” on page 152. This example assumes that a waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 132).
2. From the second Arb menu, press Waveform Sequences.
3. Highlight the desired waveform sequence.
4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.
5. Toggle the markers:
a. Highlight the first waveform segment.
b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that
segment; no entry in the column means that all markers are disabled for that segment.

c. In turn, highlight each of the remaining segments and repeat Step b.
Press Return > More > Name and Store.

Either rename the sequence using the text entry keys (see page 133) or just press Enter to save
the sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence file.

The following figure shows a sequence built using one of the factory-supplied waveform segments; a
factory-supplied segment has a marker point on the first sample for all four markers. In this
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and
markers 3 and 4 are enabled for the third segment.

Seanent. On Sequence On |(UNSTORED) SINE+RANP =
Po 1/1 BEG Media Int fedia Pg 1/1 Haveform Reps Hkr Sequence marker column
RAMF_TEST_HFN ANTENNAZH WFM1:SINE_TEST_HFM 1
STHE_TEST_UFN SINE+RAMP LFM1:SINE_TEST_WFH Togole Marker 3 )
SINEL100+RAMP200 LIFM1:SINE_TEST_WFN 1 This entry shows that markers
3 and 4 are enabled for this
segment.

For each segment, only the markers enabled for that segment produce a rear panel auxiliary output
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.
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Using the EVENT Output Signal as an Instrument Trigger

For details on each key, use key help as described on page 34.

One of the uses for the EVENT
output signal (marker signal) is to Mode

trigger a measurement instrument.

The settings in this menu
You can set up the markers to start — can be stored to the file
h he begi . Y I header, see page 139.
the measurement at the beginning oduiation fiode i
of the waveform, at any single point on
in the waveform, or on multiple e —™ coloct Arb Setup
. . . . elec
points in the waveform. To optimize Waweform® Arb Sample Clock Sample
. ARE Custom, 200. 000000000MH= P
the use of the EVENT signal for HModulat iom : rate
measurements, you may also need ) Arb Setupkl—B  pooi Time AUGH setting
. Real-Time Custom, Y=t
to adjust the sample rate. The Modulat ion T p—p—
location of the sample rate setting _ (Cont inuous,» I
A K K . Real-Time Free Run) Phase Noise Setup®
is shown in the figure at right. Applicat ions

The EVENT output signal can exhibit jitter of up to *4 ns on the rising and falling edge. This jitter
can be minimized in either of two ways.

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N can
be represented exactly on the display.
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on.

If the result cannot be represented exactly on the display, jitter will be present.
For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 Mhz, which is truncated when
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 ns.
For example: A 200 point waveform with a marker on the first point and a sample clock of 50 MHz
provides a marker every 4 us. Because 4 us is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample

rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of the
original waveform with a sample rate change, you will have to also recalculate the sample values. The
following figures illustrate the marker signal jitter and its affect on the waveform.

EVENT output signal exhibits jitter Waveform appears to exhibit jitter when The jitter is gone with
due to a non—optimal sample rate triggered using EVENT signal with jitter. an optimal sample rate

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal
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Triggering a Waveform

Figure 8-7 Triggering Softkeys
Mode > Dual ARB Arb
FRE
on

Select,
Haveform

Arb Setupk

Trioger Tupe
(Cont inuous ,——>page 163
Free Run.

| page 164

fore 1 of 2

For details on each key, use key help
as described on page 34.

Triggers control data transmission by controlling when the signal generator transmits the modulating
signal. You can configure trigger settings so that data transmission occurs once (Single mode),
continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another,
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is
because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To
maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages
set to values other than zero.

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering
mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF
output. The Arb will present the idle IQrms value of the next Arb waveform to the IQ modulator.
This ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a
trigger. When that trigger is received, the Arb begins playing the waveform and the modulated RF
carrier exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:
e Type determines the behavior of the waveform when it plays (see Trigger Type on page 163).

¢ Source determines how the signal generator receives the trigger that starts the modulating
waveform playing (see Trigger Source on page 164).
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Trigger Type

Type defines the trigger mode: how the waveform plays when triggered.

NOTE The example below shows Dual ARB Mode, but trigger functionality is similar for other
modulation modes. Available trigger types vary depending on the modulation mode selected.

Mode > TContinuous fode | Immediately triggers and plays the waveform; triggers
Dual ARB > received while the waveform is playing are ignored.
Trigger Type Arb Trigoer | Free Run
Cont inuouskf——— P i i ived:
TriEEEr & Fum Plays the wav_eform whe_n a trigger is received;
subsequent triggers are ignored.
Single
(Restart on Trig)" Reset. & Fun
Segment. Advancer Plays the waveform when a trigger is received; subsequent
triggers restart the waveform.
Gatede Ignores an early trigger
A segment in a sequence plays received while a
once, ignoring the repetition \ waveform is playing.
setting, after which the dual ARB Sinole Hode
player stops and waits for a
Gatedgliode < trigger before advancing to the Mo Retrigger An early trigger received
Aetive Lo V next segment. The nelxt segment while a waveform is
Seo Advance Hode then plays to completion. ) playing waits until the
i . ) i BUFAEEE TIFe current waveform
Active High Single If a trigger is received while a completes, then plays
segment is playing, the segment . the waveform once
plays to completion. The dual Restart on Trig
Cont inuaus ARB player then advances to the An early trigger received
next segment and p_Iays that while the waveform is
The waveform stops during the inactive segment to completion. playing immediately
state of the trigger source, and plays restarts the waveform.

during the active state.
A segment in a sequence plays continuously until the waveform receives another trigger.

If a trigger is received while a segment is playing, the segment plays to completion. The
dual ARB player then advances to the next segment and plays that segment continuously.

For details on each key, use key help
as described on page 34.

¢ Continuous mode repeats the waveform until you turn the signal off or select a different waveform,
trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

¢ Single mode plays the waveform once.

NOTE In Single No Retrigger, do not use Continuous Reset & Run mode due to the variable latency of
this setup.

No Retrigger: If a trigger is received early it will be ignored. The gap in your playback is dependent
on the trigger period, after which time the RF will start up again where it is expected.

Buffered Trigger: An early trigger will cause the waveform to play to the end and then start again.
The RF will not be aligned with this early trigger.

Restart on Trigger: The ARB will reset itself and trigger again but there will some gap in the
playback while this is occurring. It will reset itself for every trigger it receives.
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¢ Segment Advance mode plays a segment in a sequence only if triggered. The trigger source controls
segment-to-segment playing (see Example: Segment Advance Triggering on page 165). A trigger
received during the last segment loops play to the first segment in the sequence.

¢ Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and
stops playing the waveform in response to an externally applied gating signal. See Example: Gated
Triggering on page 166.

Trigger Source

Mode >
Dual ARB >
Trigger Source

Arb Trigger

Trigger Source,
(Ext)

Arb Trigger

\J

Ext Source, Trigger Keu

(Patt Trig In 1)

Neg = the signal generator g (1550 T TS

Ext Polarity responds during the trigger signal Pgﬁ‘ﬁ ggﬂ?eé» Patt Trig In BNC connector Bus
Pos | g 'OW State. (Patt Trig) (see page 16)
- ; Patt Trig 2
Ext Delau Pos tgej'g.nal ?he ”ffa“’“ ional ENC Sourced Aux I/O connector Ext
o high state, oo N (BB Trisger 2) (see page 17)

Key inactive until Ext
Delay is enabled On.

For details on each key, use key help
as described on page 34.

External Trigger Polarity
¢ In Continuous, Single, and Segment Advance modes, use the ExtPolarity softkey to set the external
trigger polarity.

* In Gated mode, the Active Low and Active High softkeys (page 163) determine the external
trigger polarity.
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Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence.
This type of triggering ignores the repetition value (page 137). For example if a segment has
repetition value of 50 and you select Single as the segment advance triggering mode, the segment still
plays only once. The following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on page 136.

1.
2.

Preset the signal generator.

Configure the RF output:

* Set the desired frequency.

¢ Set the desired amplitude.

e Turn on the RF output.

Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.
c. Press Select Waveform.

Set the triggering as follows:

e Trigger Type: continuous Segment Advance
Press Trigger Type > Segment Advance > Continuous.

e Trigger source: Trigger hardkey
Press Trigger Source > Trigger Key.

Generate the waveform sequence:
Press ARB Off On until On highlights.

(Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure the
oscilloscope so that you can see the signal.

Trigger the first waveform segment to begin playing continuously:
Press the Trigger hardkey.

Trigger the second segment:
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next segment
to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first
segment in the waveform sequence to start when the last segment finishes.
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Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1.

Connect the output of a function generator to the signal generator’s rear panel PAT TRIG IN
connector, as shown in the following figure. This connection is applicable to all external triggering

methods. The optional oscilloscope connection enables you to see the effect that the trigger signal
has on the RF output.

Function Generator

pooooooos O
ooooooos o

Signal Generator ( PAT TRIG Oscilloscope
— = prd N
o oooo o — anoo oe—=)
oy ©@°°c0000®
® ®@ ® ©
cooooooo ®
(-] o o [+ o
RF OUTPUT i 0 0 ©
i S Q0B O0dob ® © © o
H 1
E Channel 1 i Channel 2
i i

Preset the signal generator.

Configure the RF output:

* Set the desired frequency.

e Set the desired amplitude.

¢ Turn on the RF output.

Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.

Set the triggering as follows:

e Trigger type: Gated
Press Trigger Type > Gated.

e Active state: Low
Press Active Low.

* Trigger source: External
Press Trigger Source > Ext.

¢ Input connector: Rear panel Patt Trig In BNC
Press Ext Source > Patt Trig In 1.

6. Generate the waveform: Press Return > ARB Off On until On highlights.
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7. On the function generator, configure a TTL signal for the external gating trigger.
8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external
triggering signal. You will see the waveform modulating the output during the gate active periods
(low in this example).

The following figure shows an example display.

Modulating Waveform RF Output

N
N e

]

Externally Applied Gating Signal
Gate Active = Low
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Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel

BNC connector

FUNCTION
GENERATOR
Y A
I €]

poooooood ©
ooooooog

PAT TRIG

SIGNAL GENERATOR OUTPUT

1. Connect the signal generator to the function generator as shown above.
2. Configure the RF output:
e Set the desired frequency.
e Set the desired amplitude.
* Turn on the RF output.
3. Select a waveform for playback (sequence or segment):
a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.
4. Generate the waveform:
Press ARB Off On until On highlights.
5. Set the waveform trigger as follows:
a. Trigger Type: single
Press Trigger Type > Single > No Retrigger
b. Trigger Source: external
Press Trigger Source > Ext
c. Input connector: Rear panel Patt Trig In BNC
Press Ext Source > Patt Trig In 1.
d. External Trigger Polarity: positive
Press Ext Polarity until Pos highlights
e. External Delay: 100 ms
Press More > Ext Delay until On highlights
Press Ext Delay Time > 100 > msec
6. Configure the Function Generator:
* Waveform: 0.1 Hz square wave
¢ QOutput Level: 3.5V to 5V.
168 Agilent MXG and EXG X-Series Signal Generators User’s Guide



Clipping a Waveform

Basic Digital Operation (Option 653/655/656/657)

Clipping a Waveform

Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting in
spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping function
enables you to reduce high power peaks by clipping the I and Q data to a selected percentage of its
highest peak, thereby reducing spectral regrowth.

¢ How Power Peaks Develop on page 170

¢ How Peaks Cause Spectral Regrowth on page 172

e How Clipping Reduces Peak-to—Average Power on page 173

¢ Configuring Circular Clipping on page 176

¢ Configuring Rectangular Clipping on page 177

Figure 8-8 Clipping Softkeys

Mode > Dual ARB > More —p»

For details on each key, use key help

as described on page 34.
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How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks develop
as you construct a signal.

Multiple Channel Summing

I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an
unusually high power peak (positive or negative)